ROCK can't log in to Tidal

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet Windstream

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

DigiOne Signature

Description Of Issue

If I use my MacBook as Roon Core, Tidal logs in automatically. If I switch to the NUC, Tidal is not logged in. When I try to log in, Roon replies “Network Error - please check your connection”. Everything except Tidal works properly. Roon can reach all of my endpoints and my NAS library.

Hi @Lee_Dickinson,

Since experiencing this issue have you tried rebooting the ROCK Core? Does that help?

No change by rebooting. thx - Lee

Thanks for giving that a try, @Lee_Dickinson.

Is the ROCK Core connected directly to the Windstream router via Ethernet or are there other networking devices in use?

Did you just recently switch to ROCK? Was this working with ROCK before?

It has worked before on ROCK. The Windstream T3200 Modem/Router, the ROCK NUC, and all of my endpoints are connected through a single Hewlett-Packard HP-1810-24G managed switch. My MacBook, when using it as core, is connected via WiFi.

I’ve logged other problems with the NUC in the past, but it has been operating smoothly for a couple of months now until this issue cropped up.

Hi @Lee_Dickinson,

Can you try clearing your Cache?

  • Stop RoonServer via the Web UI
  • Find and open your Roon database
  • Navigate to /RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Restart RoonServer using the Web UI

Did that. The Roon control app on MacBook now won’t load. At first the icon would just bounce in the task bar but there was no dialog box indicating an action I need to take. After about 10 minutes of that, I force quit the app, booted the Mac and tried again. Now the icon won’t even bounce. So, I launched the control app on my iPad and the ipad app functions fine. I can see my NAS content and play it. However, when I went to settings and tried to log in to Tidal, I get the same error message as before on the Mac. The log-in credentials I am using were working before with the Mac as the Core. They also work to log into Tidal directly on the site. Now the Mac Core is not visible on the iPad control app. ROCK is visible and works as above - except no Tidal. The ROCK UI is accessible and its functions are working.

EDITED TO ADD: The Roon Mac control app is back to working as before with a power-off restart of the Mac. The Mac Core is also visible again and functions properly. Tidal is logged in when I visit SERVICES using Mac as Core.

Hi @Lee_Dickinson,

Just to verify, did you clear the cache on the MacBook or did you clear the cache on the ROCK Core? Clearing the cache on ROCK should not have impacted the MacBook in any way.

I cleared the cache on the ROCK core. The problems with the MacBook turned out to be unrelated and were cleared up with a hard reboot of the Mac.

Okay, thanks for the clarification @Lee_Dickinson.

Can you try using Google DNS and let us know if this helps with the login issues? We’ve seen Google DNS help with TIDAL connectivity in the past, so it’s definitely worth trying out here.

I am already using Google DNS ( and

Hi @Lee_Dickinson — I’ve sent you a PM with next steps.

Hi @Lee_Dickinson,

To summarize so far, we’ve confirmed:

  • This account works on all other devices
  • This account works on your network from another device that is connected to WiFi
  • Clearing the cache did not help
  • Rebooting did not help

The main difference I see here is that the ROCK Core is connected via the managed switch while the MacBook is not. As noted in our Networking Guide, managed switches often require some advanced configuration and it could be interfering with this connection. As a test, can you try connecting the ROCK device directly to the main router via Ethernet and let us know if that results in any changes?

Connecting ROCK directly to the modem made no difference. BTW, the MacBook does go through the managed switch. It is on a Ubiquiti UniFi WiFi access point that is supplied from the managed switch. The switch was not using flow control, so I enabled flow control. It is not throttling and it is configured to pass multicast and broadcast.

Hi @Lee_Dickinson,

Next I’d like to enable diagnostics on your account. Would you first please try to log in and make a note of the time in your local timezone that you receive the error message? Once I have this timestamp I can then enable diagnostics so the team can take a look.


8:27AM Eastern

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.