ROCK Core isn't updating to 1.8

Is this correct, Danny???

After updating Android and Windows remotes to 1.8 they can’t connect to ROCK 1.7 and initiating update from Android or Windows looks like every other screen shot on this post. Small progress bar never completes.

I’ve restarted and rebooted ROCK/NUC several times.

This happened to me with ROCK last night (in Europe).
1st I a very slow download bar - got to about 25% then i got the “error checking for update” box pop up.
I left it for 30 mins or so and then tried again - was a very slow download but it did eventually come through.

Hello @RPlace ,

I think ROCK was failing to download due to server overload we were having. Try rebooting the box and follow the standard process. Since we past the crises it should succeed ( though might take few minutes to download).

Apologies for inconveniences

I started this, watched “on the Waterfront” and this is where it is after 1 hour 57 minutes.

What are my next steps?



Ok reinstalling Roon OS sorted this


@vova I’ve been repeating these steps since 7PM on Feb 9th. It is now almost 6PM on Feb 10th.

  • Reboot NUC/ROCK
  • Try to connect with Win 1.8 version
  • Tells me ROCK needs to update
  • Download progress bar progresses very slowly only a tiny amount
  • Eventually gives message There was and error checking for an update (Retry)

I’ve done this at least 50 times. I’ve rebooted every switch on my network. Next I moved my NUC/Rock onto my ISP’s modem via cat-5 to give it the most direct connection. Still no luck.

At this point I don’t care about my 1 year of history. Would downloading ROCK installer and starting from scratch (via USB like I originally did) give me a better chance of getting 1.8? I’m dead in the water with all my Remotes updated to 1.8 and my NUC/ROCK unable to get the update.

Very frustrating, no music for almost 24 hours in my entire house.

Have you tried reinstalling Roon OS?

I see you did, but I had to do it twice for whatever reason.


1 Like

Yes three times now. I’m a software developer by profession. If I had a release like this for one of my clients I’d be looking for a new job. Sad, very sad. No way to go back to old version and wait till the problems are ironed out. Not like it is a $0.99 cent app on my phone made by somebody trying to learn how to program.

I get that there are issues with software, but how about some actual support for my hard earned money.


Now it looks as if it is trying to update the already updated Windows remote as well as ROCK

I have the same issue with you, RPlace. Have tried many times until I make this done recently.

Just do a reinstalling for my Roon Nucleus+ and it can work this time for the update. The Build is upgraded to 756.

I think you should do 1 more round of reinstalling your ROCK and try update again to see how.

Good luck!

1 Like

@vova So I let it go overnight and woke up to this. Now it seems to think it needs to download another version of the 1.8 windows app along with the ROCK update

@vova @danny I’ve Reinstalled Operating System like first screen capture above (top left button on ROCK UI) four times now. I’ve rebooted the NUC/ROCK 10s of times. Still won’t download ROCK update. Tiny progress on progress bar then says “Retry”.

Ideas on downloading ROCK install compressed file and installing to USB sick like original ROCK install to the NUC or should I hold off on that?


@vova @danny
Please, please, please tell me how I can get the 1.7 app back for Android devices?

My wife’s phone had not updated Android app (Thank Gawd!). It was the only way to connect to my 1.7 ROCK/Core which won’t update itself. So I found an old windows install .exe and it was able to put the 1.7 windows app back on my PC.

So for now I am back in business with 1.7 on a single phone (wife’s) and my PC. My other Roon Remotes are the primary control devices. They are my phone and a Samsung tablet.

HOW can I get the updated 1.8 Android device back to having a 1.7 remote/control app?

Any and all help greatly appreciated. I’ll deal with 1.8 down the road if I must.

I’ve asked your ROCK to report ping times to us, and you have an extremely slow network situation… it’s taking you 4 seconds to ping our servers… the download must be eventually timing out on your end due to network instability.

You should figure out why your network connection is so slow and retry the download.

I live in the middle of nowhere. That is why I have Roon and all my music files locally on a NAS and don’t stream. I’ve been able to pay you my money to date and do everything else I need to do with Roon. Why not this? Sorry if that sounds harsh, but I think you can see my point.

If I were to take my NUC/ROCK 45 minutes away to a friends house with stable/fast/broadband can I put it on his network and still connect with my account? I can take the NUC, switch, remote/control device, etc. It however would not be practical to take my NAS…but I don’t care about the actual music, just getting things to work.

What about getting a 1.7 .apk so I can put my Android control devices back to talking to the 1.7 core?

As for slow network, I’m able to develop software for several clients and deliver it to them. Slow yes but not impossible to do most other on-line related tasks. Can you send me some sort of install file via FTP or similar?


Not for ROCK – it’s not meant for “exceptions” – there is no way to update it out-of-band.

This would be easy if you were running Ubuntu or some other distribution where you get to install RoonServer however you want, but ROCK only does it one way.

@mike, do we have a 1.7 APK we can give to @RPlace? I assume he has a way to sideload it.

BTW, if you install the APK, there is no guarantee you won’t have additional problems later. Not taking updates will absolutely result in instability as we deprecate the older protocols talking to our services.

Since I’ve not had any music for 3 days. I’m keen to get something going in the short term. I’m not seeing 1.7 as a long term solution.

I’ve been able to do everything else Roon-ish from my same location/connection. It’s done all the other updates along the way just fine. I’d guess in a few days to a week I’ll be able to update. Guessing the real problem is on your end but my slower connection exposes that. Why else would the rest have worked in the past if not sheer lack of scalability on your part? I’d be happy to assist with my cellular only solution to make your product better. I can’t be the only singe Roon user with a less than optimal pipe to the Internet.

I can have 10-way zoom calls. I connect and mange large databases. I provide software updates to customers. About the only thing I can’t do with my connection is stream NetFlix, but that is due to data caps not speed.

What about my question of taking my NUC to place with faster Internet access? Can I take the NUC/ROCK and my remote device(S) and log in with my account and connect? I’m unclear how that architecture works. I think I’ve read that using it in multiple locations is problematic. I don’t want to actually use it for music playback just have enough the ecosystem in place for it to update.

So what is the name/ip of you download server. I’d like to ping it on my end and see what I get back.


I asked your machine for logs. It was slow to respond, but it worked. It’s trying to download RoonServer 1.8, but only gets a few megabytes in, and then the connection times out.

There is very little I can do here beyond telling you to get a more reliable internet connection. We’ve had many tens of thousands of users update successfully in the last 4 days.

I know that’s not helpful… pinging community is a good test for performance – we proxy downloads through that same server.

btw, 45ms for pings is REALLY slow, but it shouldn’t fail. I expect that things are getting worse/congested with higher data throughput, which is why the download bombs after a few megabytes.

@mike, apk?

I asked more than once and nobody from room ever answer about taking the equipment minus the music to a different location.

For anyone interested in the future that works. I went to a house with fast broadband, hardwired the NUC and connected to ROCK with a phone and tablet via Wi-Fi.

The really curious part is prior to this I could always get the system to download the Windows update within the windows Roon GUI, but never the Core portion of the upgrade. At the remote location the Core part was very fast, a second or two. The windows part took much longer.

Let me know if I can assist you all in trouble shooting slow systems. I can’t be the only one.

1 Like

sorry, missed that question… yes, you can take it just for the update.

Glad you got it working.