ROCK database and settings not ready

Core Machine (Operating system/System info/Roon build number)

Intel NUC6i7KYK Rock / Version 1 (build 175)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear GS724Tv3 Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Updating ROCK does not work.

For the last few weeks my Roon remotes have been telling me to update to build 183(?) but have not been able to do so. With the release of Roon 1.7 I tried again to update to the newest version but the update got stuck at about 30% of the update bar.

To try and get round this I’ve tried using a flashed USB stick with the latest ROCK downloaded from Roon and using the recover option from the USB. I made sure that the bios was up to date and that the bios options were correctly selected.

I got the following error message from the NUC during the update:

On reboot the ROCK boots but the Roon database and setting show as “Not Ready”:

Reinstalling the OS via the web UI has no impact.

Any thoughts would be welcome.

Hello @dpstjp,

We’ve enabled diagnostic tools and pulled logs from your device. It seems like something is happening with the internal drive - feels like internal drive file system is messed up or drive itself is corrupt.

@vova thank you. I’ve just tried a completely fresh install using the version of ROCK downloaded from Roon late this morning my time, thinking I would restore the database from a back up. It worked fine and the Roon Core is seen but the ROCK is still version 1.6, and not 1.7.

I just get a spinning circle and being told Roon is checking for an update. It’s been like this for 10 minutes.

@vova This has been spinning around for the last 5 hours and I have no response from Roon. Please can I ask for an answer?

I’m looking that all further attempts to get logs from that box has failed, so I don’t see what is happening now. In an old OS level log we were seeing this:

Nov 21 12:52:17 (none) user.crit kernel: [ 2191.763276] EXT4-fs error (device sdb1): ext4_ext_check_inode:498: inode #2885464: comm RoonAppliance: pblk 0 bad header/extent: too large eh_max - magic f30a, entries 1, max 2052(4), depth 0(0)

This feels like a problem with a partition.I would try to re-format it into another file system on the other machine or by installing different OS on this one and checking health of this drive with tools provided by manufacturer of the ssd.

@vova OK, so I installed RoonServer onto my main MacMini whilst I waited for a USB drive big enough to load Ubuntu.

After I loaded Ubuntu onto the NUC I tested the drive (using smartctl command) and the drive “PASSED”.

I then reloaded ROCK onto the NUC, closed RoonServer on the MacMini and fired up the NUC.

The OS is 1.0 (build 175) and the Roon Server software is 1.6. Opening up Roon on my MAC (not RoonServer) I get the option to connect to the NUC, then to update the Remote Core:

Immediately I click the Download and Install button I get an error message:

I’ve switched the NUC to DHCP and rebooted the whole system. The first update downloaded by then Roon crashed. A second reboot and the download appears to have worked, allowing me to relaunch.

Now I need to restore the whole back up overnight to see if the restore has worked.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.