ROCK disappeared from network

Roon Core Machine

RAM: G.Skill Ripjaws SO-DIMM 8GB DDR4-2400Mhz

Networking Gear & Setup Details

Google Nest Wifi → LAN cable → USB3GIG (LAN/ USB adapter) → USB connection to ROCK.

Connected Audio Devices

Devialet 440 connected by LAN cable directly to NUC

Number of Tracks in Library

Around 20.000 tracks

Description of Issue

After a (maybe failed?) upgrade and reboot at November 9th the ROCK is not showing up on my network. My setup has worked (more or less) without any problems since 2018, but not anymore. See attached picture of the NUC-screen. Hope you can help.

Best regards


I’m assuming you can’t ping it or browse to the ROCKs web-admin page.

As a troubleshooting measure can you connect the NUC directly to your LAN via it’s RJ45 port, thus removing the USB3GIG (LAN/USB adapter) from the chain?

Hi Carl,

Thanks for the quick reply

As expected, cannot be pinged (

Just tried to replace the Google Nest Wifi connection with a ordinary LAN (RJ45) cable into the NUC, but the NUC shows exactly the same message (also IP

Hi Carl/support,

Any idea what I should do now?

Best regards

Hi @NPV,

Thank you for your patience in awaiting a response.

Here is something you can try. It seems relevant since the Nucleus seems to be pulling an IP that isn’t valid. You might also check your router config to ensure that a typo or something similar didn’t assign this IP to the unit.

Let me know.



It actually solved the problem :-). But since the original setup where both the network (internet) and the Devialet were wired to the ROCK using LAN-cables (the internet using a USB/LAN adapter) was reset, i decided to use the standard-setup:

ROCK is now connected to the network via a switch (down in my basement), while the Devialet is connect to a Google Nest Wifi point via LAN-cable. Haven’t checked if the new setup has had any (negative) impact on SQ.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.