ROCK does not update with missing codecs

Hi there

Have just purchased a new NUC to run ROCK. Went to load the codecs: downloaded ffmpeg and unzipped using 7-Zip. Copied the file across and rebooted. But the UI still says ‘‘Missing Codecs.’’

My NUC is:

Intel SSD 760 P 128GB M.2 2280 NVMe PCIe Gen 3 X 4 SSD
8GB DDR4 SODIMM 2400 MT/s (PC4-19200)

I read elsewhere on here that it could be a permissions issue - but see screen shot below.

Any advice?

The ffmpeg codecs are or were when I looked double zipped. So unzip again and see what happens.

1 Like

Thanks, tried that but no change.
Still says Missing Codecs (after rebooting)

Some have had permission issues with ffmpeg when copying it to ROCK. Make sure you have downloaded the correct version. Make sure it’s just the ffmpeg binary you copy across and before you do make sure after uncompressing it you make sure permissions are all open.

yeah this is all gooblygook to me.
What’s the correct version? I downloaded the one in the Roon page link. Surely that’s the right version
What’s the binary?
I added a screen shot of the permissions page above - is this right?
See below for the unzipped ffmpeg file unzipped in the codec folder

Not sure if this is an issue, but I have my ffmpeg file in the Codecs folder not a subfolder as you have shown. You may want to move the ffmpeg file up into the Codecs folder. I also checked the updated link you referenced and replaced my older ffmpeg file with the one linked to there. Rebooted and all was well.

The binary is the file called ffmpeg, it’s above ffprobe in your picture. That is the only file that should be in the codecs folder, nothing else, no subfolders.

Done it! Just copied the ffmpeg file to the first level CODEC directory and it’s solved it.
Many thanks! @Simon_Arnold3 and @George_Abrahams!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.