ROCK Dual Ethernet - Primary Port Not Exposed [RESOLVED]

This is working flawless now. Great feature! The new update made it idiot proof. I can no longer bring the network down.

No worries. The $15 USB3 gigabit ethernet adapter worked great and I didn’t experience any speed issues when the adapter is connected to the router. Lots of bandwidth there.

I’m answering my question here. Yes, it does! Best of both worlds. The clean Intel ethernet port that is free of USB translation goes direct to the music renderer. Simplicity at its best. Wonderful!

1 Like

This is good information and a handy adapter :grinning:

Tried this, must’ve done something wrong. Now I can’t access Web UI. Any recommendations before I try reinstalling ROCK?

without screenshots, i don’t know what went wrong… next time, take screenshots of the web gui before hitting save :slight_smile:

before you reinstall, the console should give you the ip address of your ROCK to access the web ui. what does it say? (take a photo of it with your phone)

Try to remove the USB Ethernet adapter and reboot ROCK. You may be able to recover your network without re-installing ROCK again.

Will try this when I get home. Thanks!

I decided to give this “bridged” setup a try before selling my sMS-200. The last few days I’ve been testing NUC/ROCK connected direct to SOtM tx-USBultra (on loan) via USB. This combo, with tx-USBultra feeding my 2Qute using Curious USB short links has given me the most euphoric music delivery since I started my Home-Fi adventure. Before this I had the NUC/ROCK (Synology NAS before that) further upstream behind routers and switches, with sMS-200 feeding the 2Qute directly…and then for a short time with the tx-USBultra between the two. I want to try going back to the sMS-200 between the NUC/ROCK and tx-USBultra before making final decision. But, I suspect (based on what I’ve been hearing the last few days) that the sMS-200 will be going up for sale shortly and the tx-USBultra will find a permanent place between the NUC and 2Qute. The NUC/ROCK (soon powered by a sBooster LPS), tx-USBultra, 2Qute (both currently powered by W4S PS-1) separated by a few short inches of Curious cabling, sounds simply stunning. I did test for a few minutes connecting the NUC directly to the 2Qute, but it sounded so lifeless and dull after hearing the tx-USBultra. In
my opinion, the tx-USBultra is the difference maker.

This is no longer called a “bridged” setup. It’s more “subnet” setup…

So you will be using NUC as a Server and Bridge (music renderer) and getting rid of sMS-200? I went the other way around by replacing the sMS-200 with sMS-200Ultra plus a clock modded switch to avoid further load on the NUC. Interesting to see what the difference will be.

Yes, getting rid of the sMS-200 altogether is my current strategy. NUC direct to DAC via USB was blah. It sounded better with sMS-200 feeding tx-USBultra. But NUC to tx-USBultra to 2Qute is a revelation. My guess is that there will be nothing gained by having the sMS-200 in the mix. The added benefit of NUC to tx-USBultra is that I can feed 2Qute and Mojo using it’s two USB outputs and not have to deal with networking headaches associated with the “subnet” setup. I just select which DAC via Roon remote and play. The sMS-200 feeding the tx-USBultra would not allow me to select which DAC to drive. It always gave priority to the 2Qute in eunhasu web UI. The only thing I have to deal with now is the fan noise on the NUC :confused:

@danny Here’s screenshot. I can’t access using

2 DAC set-up. Yes, you are better off with tX-USBultra. Just don’t use them both at the same time :wink:.

Get the Akasa and you’re done.

You can’t use that IP for ROCK. That is for the sMS-200. Your set-up should look like this:

NUC (Intel) ethernet 1 port:
gateway: nothing
dns: nothing

NUC (USB Ethernet adapter) ethernet 2 port:
DHCP (you can set-it up as static IP but use the IP within your subnet.)

sMS-200 IP:
gateway: nothing
dns: nothing

ROCK will provide the IP of your LAN network that was set in DHCP. For example: 192.168.0.x or 10.10.10.x. This is the IP you will access from your Roon remote (browser). IP’s and cannot be accessed from your browser because they are now in a different subnet.

1 Like

I see. I guess what’s done is done. the question is can I change it back or do I need to reinstall OS?

What’s the ip of the computer you’re trying to connect from?
Theoretically you can just temporarily set it manually to the same subnet (i.e. Use or something) so you can access the web gui to reconfigure?

(Also unplug the SMS from the network if it’s also set to use


If you don’t want to re-install ROCK, connect your PC directly to the NUC and change the IP of your PC to Once you’re connected to the NUC in, change it to DHCP.

With that said, it is easier to re-install. :wink: It takes less than 2 minutes in my system.

1 Like

You guys are brilliant. Worked!

How did you set IP for sMS-200? And when you do, can you still access http://eunhasu/ ???

sMS-200 procedure shall be requested from SOtM. You will no longer be able to access http://eunhasu after that. To update the firmware in sMS-200, change the IP of your PC to the same subnet, e.g. and connect the LAN cable of your PC directly to sMS-200.

I have a very similar setup as illustrated in the diagram using a laptop with a usb to ethernet adapter bridged and a SOTM sms-200 Ultra as the music server. My question is if I should be able to use the SOTM sms-200 ultra as a music server for a second stereo system that is connected to the network through the modem as depicted in the diagram.


I was fiddling with the fixed ip settings and failed. I managed to get it working after several reboots, but now I can’t delete the fixed ip settings. How do I restore it to default?

switch to DHCP