ROCK file download and transfer to USB

Core Machine (Operating system/System info/Roon build number)

Not even there yet, but this is all in service of setting up an Intel NUC …

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Again … soon I’ll be there, but the issue is even more basic …

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Downloading via MacOS 10.15.2 on an iMac.

Exposing myself as not the brightest bulb in the ceiling, I have a question about the ROCK download instructions.

Step three worked fine. I downloaded the ROCK app. However, I did not get a .img.gz file.

The downloaded file is “roonbox-linuxx64-nuc3-usb-factoryreset-100000183.img” (quote marks are mine). It does not appear to be a zipped file.

Step four also worked fine. I downloaded etcher, and transferred the file to a USB thumb drive. Upon completion I had the following in my USB drive directory:

Identity (a folder)

I know the bz2 is a zipped file, so I simply clicked on it and it opened and wrote the Roon Server files.

So … when you list the next steps, here’s where my ignorance blossoms:

The instructions state that commands should be entered into a Unix terminal screen.

Is there such a thing native on my iMac, or shall I download it from somewhere?

Or, are these instructions to be followed on the NUC, after I plug in the thumb drive and turn on the machine?

Any help is appreciated!

img is a “disk image” file, its what you need to burn to the USB stick with etcher. MacOS has automatically unzipped it for you.

Thanks … but what of the Unix command line? If it comes to me unzipped, I should disregard that step?

Yes, just move onto the next step

Hi @George_Paaswell,

You only need to do that step if you are flashing from a Linux OS, since you are using Etcher, you can move on to the following steps.

Thanks. I get the NUC on Monday. Looking forward to setting it up.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.