ROCK installation image broken [resolved]

I was wondering if someone might clarify and installation problem I’ve encountered:
I just purchased a NUC7i7DNH and followed the instructions in the ROCK Installation Guide to update and set BIOS.

I downloaded the ROCK reset image and used etcher to flash it to a USB flash drive.

When I put the flash drive in the NUC, and press FR10, I get an error message. When I look at the flash drive in Windows “my computer” screen, it shows as two separate drives “L” and “O”.

Did I need to do something other than use etcher on Windows 10 to write the image to the flash drive? (I thought the Linux Command Line directions below the etcher directions were only for Linux users).

Thanks for any advice you can offer!

Hello Marc,

i think you have to go to the bios and change the boot sequence to USB first.
let the stick at the NUC and go to the bios at starting
i used etcher under win10 too and had two partitions too, thats normal and the stick should be ok.
the uefi bios i disabled

as far as i remember (no monitor at the ROCK to check :wink: )
F2 is bios entry
F7 for bios flash
F10 direct for boot order (but that does not work for me)

i hope that was a help

you don’t need to set it to boot to USB – just press F10 on boot to see the boot menu and pick the usb at that time.

what error?

When I press F10, my USB is listed.
I select it “USB: ScanDisk: Part0: Boot Drive”

I receive the message: “failed to load ldlinux.c32” “Boot failed, please change disks and press a key to continue”

Thanks for your help Danny

I’m having the same issue.

I have tried all suggestions but still get the “failed to load ldlinux.c32” message.

Looking at other posts, it appears this problem is not limited to new, not yet fully tested by Roon, Intel Dawson Canyon NUC7i7DNH installations. Others with already tested NUC’s are experiencing the same problem, and it appears Roon is busy looking into this.

Hoping for a quick resolution. Roon is fantastic, and I can’t wait to get a ROCK installation up and working.

Some of us were having that error until the Roon team uploaded a new disk image…then it worked for many of us who were getting that “failed to load ldlinux.c32” message. Perhaps downloading a new factory reset disk image from step 3 here ( will help. That solved the issue for me and others.

I have same problem, i try to compilate boot drive in varios program but resalt is the same “Fail ldlinux.c32”
i think the problem is in broken img
7i7BNH bio 63

The “failed to load ldlinux.c32” error appears to be the fault of the image on the USB flash drive and not my NUC7I3BNK. I tried to boot a laptop with Windows 10 using the USB flash drive and promptly received the “failed to load ldlinux.c32” message.

try to re-download the image file. I fixed it again.

1 Like

It works. Thanks.

This topic was automatically closed after 32 hours. New replies are no longer allowed.