ROCK Issue with IFI iGalvanic 3.0

Core Machine (Operating system/System info/Roon build number)

Intel® NUC Kit NUC8i7BEH (ROCK/Roon version 1.7 Build 528)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ROCK has been connected through Ethernet with Asus AC68U wireless router. All music files store at NAS (Synology DS918Plus)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Audio Endpoint is Melodious Audio DA800 Pro. ROCK is connected with the USB input from DA800 Pro

Description Of Issue

When I put the IFI IGalvanic 3.0 between ROCK and Melodious Audio Da800 Pro (DAC), no sound coming out from the speaker. I have double checked that all connection are good. Once the igalvanic 3.0. is taken out from the connection loop, all will be fine.

Besides, when I play the song from my core control (iphone), the timer is moving. Signal path shows the full path and processing speed indicate 66X. However, the only problem is no sound coming from speaker.

For troubleshooting, I use my laptop to connect Igalvanic 3.0 with Dac (same USB cable). All are normal and prove that Igalvanic function properly.

Is this a new piece of equipment or has it just stopped working?

Hi ged_hickman1

This is brand new product. I have just brought it a few days ago.

If you search the forum the posts all seem to be “it doesn’t work” but with no resolution.

Only thing I could spot in the docs is that one should connect the device to the turned-on DAC first and to the PC/source last for proper device detection. As there is also written that one may have to install the USB device drivers again when using Windows, the device seems to definitely change something in the USB device chain (adding an additional hub/port or something like that). As there are no drivers that one can re-install when using ROCK, you might be lost here (have you already tried to reboot the ROCK?).

TBH, This is not a ROCK issue. I had issues when using iUSB from iFi, I figure out my issue and got passed it… My issue was the Power Auto Switch.

Done that before. not working.

Yes, not working.

I don’t get it. Is it the built-in function of iGalvanic 3.0?

No, What I meant is that in my case, the issue was in the device and not in ROCK.
Does ROCK see your DAC with the galvanic in plcae?

Yes, ROCK see the DAC. Like I said above. Just no sound. All seems to be normal. You still can see the time sliding bar moving.

Update on 14 Mar 2020, 9:00 am Hong Kong Time.

This is my further investigation.

  1. Reinstall Rock on Intel NUC and stick to the guide provided by Roon’s faq. Recover the Roon Core and test USB issue. The result is negative . No sound.

  2. install Roon Core on my Synology 918 plus ( all music files are still there). The result is good. Sound is coming out of speakers.

  3. Install Roon Core on Windows 10 on other desktop, The result is positive. Sound is back.

Any advise?

Update on 19 March 2020.

After 5 days plug and unplug and refer to the FAQ from IFI , this audio drop-out is caused by no / multi grounding. As suggested, just switch the ground link up. All issue should have been solved. However, IFI forget to remind user to reboot the source and Dac before the change has been applied. This make me spend 5 days to figure it out.

My conclusion is that this issue is nothing to do with Rock

1 Like

And such is the nature of electronic troubleshooting. Good effort Dick, but sorry you had to do it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.