ROCK loses access to USB drive if NUC is turned off or loses power

Roon Core Machine

NUC7 running ROCK with storage on a USB drive.


If the NUC is turned off - manually using the on/off button - or loses power for some reason - e.g. power cut - when it is turned back on I no longer have access to the database.

On an endpoint Roon reports an error indicating that it can’t find the database. If I go to Settings/Storage and try to browse to the database at the old location, it appears that it is not seeing the USB drive at all (i.e. I cannot browse to any location on the drive).

The light is still on the USB disk when plugged in to the NUC so it is powered on.

If I remove the USB disk and attach it to a Windows PC, it tells me that there is a problem with the disk and that I should scan and repair it. When I run the scan/repair it finds no errors but if I now plug it back into the NUC, Roon can see the storage and all is well again.

The database doesn’t live on an external drive that’s just your storage for files in your library . Roons database lives on the internal m2 drive you can’t navigate to it as it’s part of Roons code. If your getting storage issues I suggest trying another drive as sounds like this one’s on the way out.

@CrystalGipsy is of course correct that the actual Roon database is not on the external drive. But if what it can’t find is actually your local storage of music files:

Is your external disk format NTFS? Sounds like it.

After the chkdsk, remove properly:

To avoid this, format it to extFAT instead as recommended for external drives in the ROCK documentation.

How do you do this? A short or long press? To shutdown gracefully, a quick press is needed; a long press is a reset, and similar to dropping the power.

1 Like

Ah, yes. Thanks for the correction. Was writing in a hurry and got a bit loose with terminology, I suppose I was thinking of the Data directory when I said database. At any rate, it is where the music is stored that I mean.
I reckon the disk is probably fine and I get the same result with a different disk. It looks like it is primarily down to using disks already NTFS formatted.

Thanks very much. I have been simply reusing existing disks that would have been NTFS formatted (I imagine). I will find another disk, format it properly, transfer the data across, and hope not to see the problem again.

1 Like

I’m not entirely sure. It would have been when I moved the NUC from one room but it was some time ago. It’s rare for it to powered off manually. Unfortunately, though, we live in a relatively out of the way part of the world and power cuts - sometimes momentary ones - are quite common so having to repair the disk every time we have one is a nuisance. I will try starting from scratch with a disk formatted as Roon advises and see how it goes.


Hi @Fengoon,

How are things going? Were you able to get the USB media formatted exFAT?


Hi Wes…thanks for checking up…yes, I used an alternative disk and formatted it as suggested (very quick to do)…we have had at least one brief power cut since then and there was no issue with reconnection so I think it is all sorted…cheers

1 Like

Music to my ears!

Thank you for letting me know.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.