ROCK: M2 not recognised after BIOS update

Roon Core Machine

ROCK on a NUC8i3BEH with 256GB Samsung M.2 SSD, 8GB memory and a 1TB WD drive for storage.

Description of Issue

I’ve been running this setup for 3-4 years with no problems. Recently the NUC started to make a bit of noise so I upgraded the BIOS [BECFL357] and now ROCK won’t start.

It tells me ‘A bootable device has not been detected.’ Rock is installed on the M2 - the M2 is listed under Devices > SATA in BIOS but not listed as a bootable device.

Any advice welcome.


Rock does not seem to be in play yet. The BIOS needs to find the bootable disk first, then it hands off the control to the operating system that is installed on this disk (the RoonOS of Rock in this case). However, it doesn’t even get that far.

This sounds like an issue with the BIOS or its installation. Intel has some instructions here, but they are not very comprehensive:

Please take photos of what you see in the BIOS and post them here.

Most likely, the noise you heard before the BIOS update was already part of the problem, maybe the NUC was already failing. What kind of noise was that?

I would also go through the BIOS settings and make sure they are correct:

To repeat/confirm - this setup has worked flawlessly for 2-3 years. I installed it all from scratch. A recent BIOS update seems to have killed ROCK’s ability to recognise the M2 card. The BIOS update installed fine and I can boot into BIOS with no issue. All BIOS settings are correct. The M2 card is displayed in BIOS under Devices > SATA - but not listed as a boot drive.

I am pretty tech-savvy (I’ve built and configured Unix servers for years) and it looks very much to me like the issue is with ROCK.

Perhaps I should re-install ROCK?

Is anyone from support able to advise?

Screenshots of relevant BIOS pages:

You shouldn’t have messed with it then! :wink:

On a more serious note, simply disable UEFI and set it back to Legacy boot then? Unless you have updated your Roon OS, Legacy boot is a requirement.

1 Like

Going to echo Mikael. If you installed this years ago then it was as a Legacy Boot. So, the BIOS needs to be setup up for that. It is showing UEFI boot checked on the first pic.

1 Like

Exactly :slight_smile:

Hmm - still not there yet.

Thank you: disabling UEFI and enabling Legacy Boot does show the M2 card as a boot drive - but setting it to boot from that drive (i.e. no. 1 priority) results in a “Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key” error.

Interestingly I also get this error if I try to start from a ROCK factory reset image on a USB stick.

You should be able to run UEFI boot with the latest Roon OS installer though? If you are on the way of reinstalling, i mean?

Which tool are you using to create the Roon Install stick? Can you try it in any other device? (Not going through with the install. just to check it’s booting capabilities)

… not being able to boot from a USB stick was because I’d restored factory defaults and left secure boot on.

I have now solved this by replacing the M.2 card and installing from scratch and then restoring a backup.

Odd points to note:

the old M.2 card works fine when put in another device and re-formatted;

my initial BIOS update - which went fine (and has eliminated fan noise) seemed to affect the old M.2 card in some way.

Ultimately it was inexpensive to sort out - just a bit annoying.

Thanks for all suggestions.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.