Rock nas smb - unexpected error [Resolved network settings?]

i was using roon with a ethernet connected synology nas for a while.
now i switched to rock. so far so god. but rock is not finding the the shared folder? i get unexpected error…ame settings as before…smb//diskstation/music - name - and pass…
also youre faq website rock:_Storage_Basics is not working…so i´m kinda lost…

setup: synology- connected to a router- connection to rock nuc (with new bios and ffmpeg) - ethernet to allo usbridge - dac and ipad remote…


The syntax above its incorrect try

\\diskstation\music or \\ipaddress\music

This is how my NAS is setup - also synology

why is it incorrect? it´s described like that and it worked before with roonserver…but no problem i tried before yore recommendation without success…

before with same settings as roonserver…

then the / and \ are different and not interchangeable

in your SMB example you are missing the : … all these must be in the correct places for it to work

You will use your username and password you have that has access to the music (muni in your case) and your IP address or hostname as defined in your NAS


same with “DiskStation212” in stead of ip-adress
no success

Are your cut and pastes of the details typo’s or are you using these invalid (based on your settings) copies?

To put a \\ you need to put 3 's in your post (see the right side edit preview) and I think capitalisation matters if you use the name so Diskstation and diskstation might be treated differently (don’t quote me on that) but IP address is safer and I assume its a fixed IP address in your NAS network setting too.

" \\\muzi"

Is this what you really have?

What OS is your remote using?

i try hard…
everything is setup correct…

as far i tried
reboot all devices…
i can stream a imported radiostation…(test)
no luck with nas-share

diskstation is up-to-date
only smb is activated…

and static ip for all devices

check the SMB advanced settings and maybe be sure jumbo frames (MTU) is also off while you are at it. your gateway and other numbers will maybe be different too


transfer logs enabled and min smb1 (before smb2)???now its working…


thank u for helping

1 Like

Hmm im not sure that transfer logs made the difference - thats just a system logging

Checking this option enables logging of file access operations, including creating, deleting, reading, writing, moving, and renaming files or folders via CIFS/SMB protocol, also known as the SMB protocol.

But whatever you did its working so thats great…happy days.

This topic was automatically closed after 41 hours. New replies are no longer allowed.