Unable to access Roon Backup after new Rock installation [resolved: netbios was disabled]

I just installed ROCK for the first time, and want to restore from a database I used in my prior windows installation.

However, when I try to access my backup, I get the error message: Invalid network path specified.

My backup is on a Synology NAS.

I have the path as:


I typed in my username and password like I usually do, but am unable to access.

I also can’t access any of my Music Folders on my Synology NAS – get same error message

What am I doing wrong?

Another call for help.

Can’t figure out how to add music from my Synology NAS using Roon ROCK.

Any help would be much appreciated!!

I do not own either, but what about trying with the Synology IP address instead of the name? i.e. smb://192.168.1.xxx/RoonBackups. If ROCK for some reason can not resolve name-to-ip you’d get errors like this.

I tried that, but no luck.

I also tried \DiskStationxxx\RoonBackups and was also unsuccessful.

Would really like to get this solved.

ROCK and your Synology is in the same IP subnet? Does the sharing on Synology contain any ‘allow’ rules or anything that can prevent ROCK from connecting?
Let us ping @support here to make sure they see your request for help.
Also this thread deals with the same issue

I think the part ‘Minimum SMB …’ is significant as I believe I’ve read somewhere on this forum that ROCK uses SMB1

I think SMB2 is now supported with the latest update.

Hello @steveoat87,

Could you try connecting to the share using the CIFS protocol instead of SMB? To do so, just replace the “smb://” with “cifs://”. We are actively investigating a few bugs relating to SMB and NAS usage on Linux cores and hope to have some more fixes out soon.


Finally got this to work. Enabled NetBios and this seems to have helped.