ROCK no longer shows my Schitt Modi DAC as an audio connection

Roon Server Machine

Intel NUC / ROCK version 1.0 build 259 production.

Networking Gear & Setup Details

The NUC is Cat 6 to router configured as an access point, which is Cat 6 to the central router

Connected Audio Devices

Schitt Audio DAC connected by USB to the Intel NUC USB output.

Number of Tracks in Library

Don’t know number of tracks, about 200 CDs

Description of Issue

Since originally installed, the system immediately recognized the Schitt Audio DAC connected and it was set up as my main audio system.

Otherwise I have a number of Sonos speakers connected as end points also, and those continue to work.

It’s been a few weeks since I used the DAC connection. I just turned on the system and Roon is no longer showing the DAC as an endpoint. Rebooted the DAC and the NUC, and still no luck.

Don’t have any other system to try the DAC on.

Hi @Rex_Noel ,

Have you tried any other USB cable to USB port on the NUC? If you haven’t yet, then that would be a good test as well. One other thing you can try is to set up a fresh RAATServer instance on the ROCK and clear out the USB zone settings.

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Stop RoonServer from running on ROCK’s Web UI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart RoonServer from the Web UI to generate a new RAATServer instance

Noris, thanks for getting back to me. I was able to follow this process successfully. I’m no IT guy but your help pages got me through. Unfortunately, this doesn’t appear to have brought back my DAC for the main system. In the Roon app, on the audio tab, I see all of my Sonos speakers listed and enabled as before. I do not see anything obviously looking like my Schiit Audio DAC. I do see six items under the heading Connected to Core (directly). They are:
HDA Intel PCH ALC256 Analog
Same as above HDMI 1 through 4
It’s been a while since I originally set up the system, but I think when I did the DAC showed up visible in the app as soon as it was added.

Noris, some additional info. Using the app, I enabled all of the directly connected devices I listed in my reply above. When I did so, the Analog connection immediately showed Rogue as the name, instead of unnamed as it did before. Promising, since my amplifier is a Rogue Audio unit. But it still wouldn’t play music from Roon as it did before. Then I clicked setting on the Rogue connection, then Device Setup and searched for Schiit Audio, clicked on that and then my DAC model (Modi). But still no joy. Started a song from the app on the Rogue output and no sound. To repeat myself, this output worked fine a month ago when I last used it.

That is the headphone jack on your NUC - it’s not a USB connection.

You’ve rebooted both your NUC and the DAC. Have you tried disconnecting the USB cable and then reconnecting it to see if Roon will then pick it up?

Thanks Geoff, I should have guessed that. I have rebooted both the NUC and the DAC a couple times. I also have disconnected the USB cable and then reconnected. I booted the NUC both with the DAC attached and then again without, attaching the USB cable after the boot.
I unfortunately don’t have another USB to RCA cable to try - would have to order one. But the connections disappeared without anyone touching the system, so a cable failure seems unlikely, although certainly not impossible.
I also tried the USB cable in other ports on the NUC

Some additional info as I’ve been trying to troubleshoot what I can. It will be obvious I’m not very knowledgeable. I don’t have another audio system to try the DAC on. But I just tried plugging the USB cable into my laptop. There was no reaction from the laptop as I would normally see when plugging in a device like a hard drive or memory device. I looked to see if there was now another audio device showing, and looked in the device manager to see if it showed up somewhere, and nothing. This makes me wonder if the Schiit Audio Modi DAC may have failed. It only has an indicator light, which is on. No other screen or anything. Any thoughts on this?

You are eliminating variables - so the only two possible causes left (I think) are either a failed cable or a failed USB digital connection in the DAC?

Makes sense to me. I’ve just sent an email to Schiit Audio. I assume I won’t hear back from them until at least tomorrow. Told the the details and asked how I could proceed with further troubleshooting on the DAC and see if I can find or buy another cable to try.

I was able to track down two other USB cables and tried them both without success.

1 Like

Problem solved, after some more detective work. Was not a Roon software problem. It was the DAC. My Schitt Modi DAC was not visible to the PC. A lot of searching led me to what turned out to be the problem. There was apparently a run of the Modi units with a problem with an IC in the USB circuit. By slightly heating the chip, you can get it to start operating. Some folks replace the chip (beyond my skills) and some creatively used a small heating pad to warm it up. While testing the DAC in my office and reading all this, I looked up at my sunny windowsill, and after a half hour there, the DAC worked fine. After that it continued to work for a few days on my system. None the less, I decided to upgrade to the Modius DAC, it arrived last week, and it sounds distinctly better. So I’m happy with the new DAC and won’t look back. Thanks for all your advice.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.