ROCK NUC needs [Solved - Enabled DHCP in Router Settings]

  • Intel NUC C7I3BNH
  • Ethernet
  • Pioneer U05 DAC


As suggested on the Roon website, I have bought a Intel Nuc C7I3BHN with 4GB RAM and 64GB M.2 SSD following the link to amazon on the website. I am a lifetime member of Roon.

I have meticulously followed the instructions on the ROCK_Install_Guide

There did not appear to be any trouble updating the BIOS. The ROCK installation went fine as well. I managed to unzip the codec files suggested and move the ffmpeg file to the codec location on the NUC. So far so good.

When I open the ROON app on my mac, the app says that an update is required for the roon optimized core kit. After trying to update it in the desktop app it states that there was an error checking for updates.

The same thing happens when trying to control the NUC from my iPhone.
I have tried the reinstall all the files (BIOS, ROCK and the codec file) and i have tried to restart the server software and reinstalling it in the web user interface.

What am I doing wrong?

Kind regards Jon

Hi @Jon_Bjorn,

Can you try a manual install from the ROCK Web UI? You can access this by going to the ROCK’s IP address or by opening a internet browser window and typing in rock/. Then, you’ll want to press the OS reinstall button:

Please let me know if that helps!

Dear Noris,

Thanks for the fast reply. Unfortunately it did not solve the issue. The desktop app still says a software update is needed and that “There was an error checking for an update”.

Kind regards

Can it “see” the internet?

Yes I think so. When plugging in the ethernet cable, the no network connection message disappears. Furthermore, I have no issue connecting to the web UI. Makes sense?

Hi @Jon_Bjorn,

How the ROCK connected to the network in this setup? Is it connected directly to the router or to a switch/range extender/powerline adapter? Is the behavior the same if you try connecting it directly to your router?

– Noris

Pluged it directly in to the router now and updated the OS now. No difference at all.

Hi @Jon_Bjorn,

Thanks for giving that a try. I have a few other ideas here:

  1. How are your DNS servers configured on the router? I have seen other users get out of this state in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?

  2. I am wondering what the Roon Logs display when this issue occurs, this might help us here. Can you use these instructions to navigate to your ROCK’s Log folder and send me that info?


I am a bit of an illiterate when it comes to DNS configuration etc. I will try to get some help with that.
The second question seems easier, but I have trouble uploading anything but image files. How should I send it to you?

Kind regards

Hi @Jon_Bjorn,

You can send it to me as a shared Dropbox/Google Drive/Firefox Send link.

– Noris


I have followed the instructions and changed the DNS to the google The problem persists. Still claims that there was an error checking for an update

Hi @Jon_Bjorn,

I am seeing that you are having issues accessing the network on the ROCK:

04/17 03:32:25 Critical: [easyhttp] web exception without response: : System.Net.WebException: Error: ConnectFailure (Connection refused) ---> System.Net.Sockets.SocketException: Connection refused
  at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP) [0x000b6] in <126998f2e5ae42fe95554117eb649feb>:0 
  at System.Net.WebConnection.Connect (System.Net.HttpWebRequest request) [0x0016d] in <126998f2e5ae42fe95554117eb649feb>:0 
   --- End of inner exception stack trace ---
  at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00058] in <126998f2e5ae42fe95554117eb649feb>:0 
  at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (System.IAsyncResult iar, System.Func`2[T,TResult] endFunction, System.Action`1[T] endAction, System.Threading.Tasks.Task`1[TResult] promise, System.Boolean requiresSynchronization) [0x0000f] in <370a0c27f4b74d1a81431037df6d75bf>:0 
--- End of stack trace from previous location where exception was thrown ---

I have seen similar symptoms before with VPN or firewall connections blocking Roon from contacting our update servers. Are you perhaps running a VPN on the router or somewhere else in the chain? Does anything change if you temporarily disable this feature?


@Jon_Bjorn you are not by any chance in China are you?

I’m just a semi-innocent bystander, but if you have the latest ROCK image then you shouldn’t need an update. I’ve install ROCK three times and have never seen that message, at least not that I can recall.

What would happen if you downloaded the image again and started fresh? Just a thought.

This does look like a firewall problem, are you sure there’s nothing blocking unfiltered internet access?

No, I am in Denmark, Europe

I do not have a VPN connection. I have managed to access the network settings and set the firewall level to low as there does not appear to be any way to turn it completely off. Still the same.
Why is it that I need to update the OS the the ROCK anyway? The image file I downloaded to begin with is this one:
which comes from the roon rock installation guide. Is that the newest one? It appears that the version on my Mac i newer (se image below)?

It is a good input but I have already tried that. Thanks

Hi @Jon_Bjorn,

Can you please let me know the model/manufacturer of all your networking gear? I’m going to be starting a case for you with our QA team and will ask them to take a look over the diagnostics received from your Core.

– Noris