ROCK NUC10i5 - Stuck "adding music to library" and "Playback was interrupted"

Core Machine (Operating system/System info/Roon build number)

ROCK / NUC10i5fnk2 4+4GB RAM - 128 M.2 SSD / Roon 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Config 1:

Router AsusRT-AC1750U

  • ROCK on NUC (Earthnet)
  • QNAP NAS TS-253A (Earthnet)
  • Switch TP-Link TL-SG105 -> MarantzNR1200 (Earthnet) / Nvidia Shield (as display) (Earthnet)
  • DevoloMagic2 EoP -> Asus Laptop (Wifi) - Wadia 151PowerDac (USB)

Config 2:

Router AsusRT-AC1750U

  • QNAP NAS TS-253A (Earthnet)
  • Switch TP-Link TL-SG105 -> ROCK on NUC (Earthnet) + Chord Mojo (USB) / MarantzNR1200 (Earthnet) / Nvidia Shield (as display) (Earthnet)
  • DevoloMagic2 EoP -> Asus Laptop (Wifi) - Wadia 151PowerDac (USB)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Wadia 151 Power Dac - Wifi + USB
Marantz NR1200 - Earthnet
Chord Mojo - USB to ROCK

Description Of Issue

My Roon server setup evolution:

  1. Roon Server on QNAP NAS (slow experience)
  2. Roon Server on Macbook Pro (good experience but macbook 24/24 lifetime issue)
  3. ROCK on NUC10 i5 fnk2 (worse experience so far)

Here is my issue:

Since I bought a NUC and installed ROCK I started experiencing new problems I never had before:

  • ROCK samba protocol isn’t compatible with SMB3, I had to change my QNAP samba config to SMB1 make it work;
  • At first step I was running Config 2 where I just replaced my MacbookPro with ROCK and after fowllowing ROCK config setup I noticed that after reboot music starts playing on every endpoint but after some minutes stops “Playback was interrupted because track fails to load” and after that no more playback.


It also stucks at “Adding Music to Library: 74 Tracks, 0 added, 0 identified”


  • I did some research over the forum and I discovered someone with issues about TP-Link Swich, so I decided to move to Config 1 and no switch between ROCK and NAS. I’m experiencing exactly the same problem.

Anyone with same problem?

Hello @Nuno_Pedrinho,

Thank you for reaching out and for your patience while your support request reached our queue.

Does this behavior occur with both local and streaming content? What happens if you try to put a few files on a USB drive and connect that directly to the Core, do you get any issues with playback?

You should be aware that we have seen issues in the past surrounding powerline adapters and instead suggest using a mesh-style network whenever possible. Our Networking Best Practices Guide provides more details on this.

It sounds like these endpoints are connected to the ROCK, but if they are not, I would also try to connect one directly to ROCK to verify if the same issue occurs.

Does this change at all after a reboot or are you still stuck at 74 before and after a reboot?

There might have been a problem with a roon library restore. That happened when I migrate from NAS core to NUC Rock. A clean library solved the problem. I lost my favourites but everything got solved.
Thank you.

1 Like

Hi @Nuno_Pedrinho,

Thanks for letting us know that the clean library has helped with the issues you were having here!
As a precautionary measure, we suggest keeping regular Backups of your Roon database, so if you have not set a backup strategy yet, please do so as well. If you have any other issues or questions, just let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.