ROCK on Intel NUCD54250WYKH

Hi All,
I’ve been given an Intel NUCD54250WYKH and I want to try to install ROCK and use it as my ROON Core.
It has an Intel Core i5-4250U processor, 4GB RAM and a 64GB SSD. I intend to add a 500GB or 1TB 2.5" SSD to store my CD collection.
I’ve checked the list of ROCK compatible NUCs and this one is not on the list.
As far as I can tell the processor is not quite as capable as the one in the official Nucleus; Passmark CPU Mark is 2208 vs 2703. It is a bit better than the Dual-Core i5 (CPU Mark = 2031) in the Mac mini 2011 I’m presently using as my Core.
Has anyone got any experience of using this NUC as a ROON Core?

Right off the bat the 4gb ram might pose a problem unless you have a very small music library.
8gb is really about the minimum with 16gb being a better bet.

It might work but…….

OK thanks, installing more RAM won’t be a problem, the spec says it will take up to 16GB. I really want to find out if the main hardware will work OK before I spend money on upgrading it.

I’ve now found this thread MOCK - Tell us what strange gear you've installed ROCK on! - #2 by Aris_Theocharides where someone has got ROCK working on an Intel NUCD54250WYK. The extra H on the end of mine signifies the High case that gives space for the 2.5" drive.
So its looking promising :slightly_smiling_face:

1 Like

Tbh you can usually get Rock running fairly easily,it’s just how well it will perform that’s the question.
If it was me I would throw 16gb ram in it, a 1tb drive for music and give it a whirl.
Large library?
Intend to use heavy Roon DSP processing?

If you have read the Mock thread you have an idea on just what can work.

Good luck and have fun!

OK, 16GB of 2nd hand RAM ordered from eBay. Decided to pull the 1TB SSD out of my seriously old Early 2009 iMac; it got used twice during lockdown for Zoom calls, otherwise it just sits on the floor using up space!
I’ll update the post when the bits are assembled :nerd_face:


Hi Adrian,

I have been using one of these (sans the “H”) for maybe a year; I think with 8GB ram. Repurposed from a prior life as a streaming box, in the world before NF and smart TVs.

I was previously running the core on a home brew i5 with Ubuntu server. I’ve found the NUC to be more reliable. Library size is 170k tracks. Using it to upsample everything to DSD128, and never seems to miss a beat.

I do get some delay at the clients sometimes, loading or searching; I don’t know if this is the machine, the network, or just the software (it’s not bad enough that I’m ever motivated to find out). It’s certainly not worse than when I was running the core on beefier hardware.

In short, you should be OK (at least, it won’t be a dumpster fire ;))

Good luck.

1 Like

Hi Adrian,
I have this Nuc. Tried Rock some time ago, no problem. However I have a problem with the internal sata port which is not detected periodically, so for me unusable. Seems to be a known hardware bug.

Thank you Scott and Nickpis for your input.
Delays are one of the reasons that I want to try running the Core on a dedicated machine.
I’ve presently got my Core running on a 2011 mac mini with a 2.3 GHz core i5 processor and 8GB of RAM. I listen to a lot of internet radio and I’m surprised that it often takes up to 28 seconds before the radio starts playing. But once started it keeps running.
Previously I had the Core running on a 2009 mac mini with a 2.26 Core 2 Duo processor and 4GB of RAM. In this case, internet radio started in a few seconds, but it stopped playing every now and then.
Both machines are hard wired ethernet connected to the same broadband so I’m not sure why there is such a difference. So I’m hoping that changing the Core to ROCK running on the NUC may have some positive benefits.
I am going to wait for the few days before the all upgrade bits arrive so I will only have to do the installation the once :slight_smile:
Once done I will update the post to let you know how it goes.


Ok, update ready.
It’s taken quite a bit of time and effort to get the NUC running ROCK properly. That was because my original D54250WYK board turned out to be faulty. (The PCH Temperature reads 0°C so it turns off after a while. I tried all sorts of things to get round it but no joy).
I found another one so I now have a NUC D54250WYK with a new CMOS battery, 16GB RAM, a 64GB SSD for ROCK and a second 480GB SATA SSD for the music files. I’ve used CCC to copy the music files from my mac mini with my iTunes master music database.
So far it is all looking good. :slight_smile:


Just noticed this. Not very useful at this point, but I’ve been using this antique NUC to run ROCK for several months. No problems.

I use the exact machine.
Works fine. Installed, no issues.


I think the NUC D54250WKY is OK when used with one or two endpoints in a group. Once you go to three in a group then it starts having problems.
See my other thread at

Since changing the Core to a high spec 2019 i5 iMac I’ve been able to run 4 endpoints in a group. There have been a few dropouts but the Roon logs imply they are due to glitches with our external broadband connection.

I’ve done some more experiments trying different combinations of kit. The conclusion is that the Intel NUC NUCD54250WYK is not compatible with ROCK or even Roon itself. And that’s with 16GB RAM and a 60GB SSD
Whenever I have a NUCD54250WYK in the system, as either the core or an endpoint, I get dropouts. And I’ve now had the problem with 3 different units! I recall that somewhere along the road I found a suggestion that there might be a problem with the Ethernet port on this particular model of NUC. Unfortunately I haven’t been able to re-find the comment.

I have now settled on -
Core running on a late 2012 Apple Mac mini - 2.3GHz i7, 16Gb RAM, 1TB SSD with the CD collection installed on it.
Endpoints -
late 2009 Apple Mac mini - 2.26Ghz core 2 duo, 4GB RAM, 120GB SSD
Mid 2011 Apple Mac mini - 2.3GHz Dual-Core i5, 8GB RAM, 1TB SSD with a backup of the CD collection installed on it.
Late 2019 IMac - 3GHz 6 Core i5, 32GB RAM, Fusion HDD
Late 2013 Mac Pro - 3.5GHz 6 core Xeon E5, 64GB RAM, 512GB SSD

And just for good measure, we have upgraded our broadband connection to 500Mb FTTP.

This setup has been running continuously for 4 days now and has not missed a beat.:blush::+1:
Another bonus is I’m back to only having a single operating system to manage.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.