Rock on NUC doesn't see my usb DAC [Resolved]

Dear @support,
I just got a NUC 7i7 to run ROCK. I followed yours guidelines to install it and move my current library. The main reason to move to ROCK was to directly connect my DAC and Roon Core/Library through usb (before I used an old MacBookPro with Roon Bridge). All went good and I can already enjoy the new ROCK through most of the wifi devices in my home.

The main issue is ROCK doesn’t see the main DAC (Yggdrasil from Schiit). I tried different usb cables and connection (with and without Intona insulator) but I could never succeeded to see the Yggdrasil in the available audio devices.
Actually, as soon as I plug Yggdrasil into NUC usb, it recognised a 96/24 signal (despite no music is played) but it doesn’t show up in ROCK audio devices.
Any similar experience?
Any recommendation from your side?
Thanks a lot for your great support
Kind regards

Dear @support
I just connected my other DAC (IFI iDAC2) and all works properly. Same if I connect the Yggdrasil through the MacBookPro with RoonBridge
It seems a problem with ROCK/NUC/Yggdrasil. May it be because NUC has only usb 3.0? Any way to make them compatible with 2.0 version too?
Your view?

Hi, @moos, thanks for the report! Could you please follow a procedure here and send me your logs from themachine that’srunning ROCK via PM using your Dropbox or Gdrive account? If you don’t use any of those services, let me know, I’m sure we can find a workaround for you.


1 Like

Just an update for whom is facing similar issue.
I upgraded my Yggdrasil with the new Gen 5 usb board and all is now working well. the dac is recognised by ROCK when connected directly to the NUC.
Still unclear the reason why Gen 3 usb wasn’t working but, at least, the problem is solved