ROCK OS freezing after startup

Just got a NUC7i3BNH for use as a Roon core. I don’t really know much about computers but was able to install:

Crucial 4GB Single DDR4 2400 MT/S (PC4-19200) SR x8 Unbuffered SODIMM 260-Pin Memory - CT4G4SFS824A

Intel SSD 600p Series SSDPEKKW128G7X1 (128 GB, M.2 80mm PCIe NVMe 3.0 x4, 3D1, TLC)

Samsung 840 EVO 500GB 2.5-Inch SATA III Internal SSD (MZ-7TE500BW)

The system booted and I verified the bios version was up to date. I then adjusted bios settings according to The Definitive Guide To Roon Optimized Core Kit (ROCK) on Computer Audiophile. I also followed the rest of these instructions including installation of the Roon OS which seamed to go well.

The problem is after booting, connecting to the network, and displaying the IP address the OS will run for about a minute and then just freeze. The command line will be flashing and I can access the web UI until it freezes at which point the line stops flashing and the UI can no longer be accessed. I have been able to format the 500GB SSD and copy the codec file to the network folder during the short moment the ROCK is operational but it always freezes. I have tried reinstalling the OS twice now to no avail, I have even tested the system with MemTest86 to insure it was not a cpu or memory issue which it was not. Please help because so far my Roon Rock is completely unusable.

I would set the bios settings to what Roon recommends, defaults I believe.

I read you tested the cpu and ram, but it could be a poorly seated module. If you installed the cpu, remove and reinstall, if not, leave it be. Make sure the fan/heatsink is properly mounted. Is there thermal paste between the cpu and heatsink?

Remove each memory module and carefully reset. Same with each cable to storage.

Intel provides diag tools but probably require Windows.

Failing all of this, you could have a faulty motherboard, cpu or ram module, or drive or cable or power supply.

Thank you for the reply Larry.

I also looked at the bios settings Roon recommends and they match the Computer Audiophile guide.

The nuc comes pre-assembled only requiring installation of memory and storage, so I have not touched the cpu or its heat sink.

According the MemTest86 Literature the testing of the memory should prove that it and the cpu are operational, meaning they must be seated properly. I allowed the test to run for over an hour so I am fairly confident the hardware is running properly and there is no problem with the cpu, memory, motherboard, or power supply.

However I will go ahead and reseat the memory module based on yours and my IT friend’s recommendations. He works for Microsoft and said that because the system can boot the OS there shouldn’t be any problems with the hardware or bios settings. This makes sense to me because I only changed bios settings from the default under the boot tab. So after the OS boots the bios should have no affect on operation right? My friend told me if it were Microsoft he would check Windows logs but since that isn’t an option with Roon OS we decided I should ask Roon for support.

So I am hoping there is a way to diagnose this problem using the Roon OS either with prompts on the system itself or using the web based UI and I hope someone here can describe how to do this to me.

I am also concerned this issue might be caused by my Network settings but according to my IT friend that shouldn’t be the case.

Sounds like you’re getting good advice. Agreed, once the NUC has booted, the firmware has little involvment…except if the OS leverages power settings configured there, but ROCK does not. Network settings should not cause a lockup.

You could install Windows and see if it runs without issue or not. If not, I’d request replacement hardware.

Probably best to wait for Roon support to enable diagnostic logs on your account and hopefully they get something…

FWIW, I’ve installed and successfully run ROCK on several PCs, non of which are NUC and thus not supported, and I have yet to experience a single issue. Don’t give up on ROCK, it’s a fine solution.

@Tim_Wilson I assume you are accessing the Roon core (NUC running ROCK) via a pc or iPad and that is where you see the freezing.

Thanks Larry.

Yes Ratbert, I am accessing the core via a pc and the web based UI. I have also accessed it through the shared network files. I also have a monitor connected to the core which displays the IP address when it has booted. I am seeing the freezing at all three locations, the web based UI looses connection, the shared network file disappears, and the cursor on the screen stops flashing.

Hello @Tim_Wilson,

Thanks for contacting support and just a quick shout out to the users (@Ratbert & @Larry_Post) who have already started helping Tim, we appreciate all the help our community provides so I appreciate you guys taking lead on this here while the case reached our queue. @Tim_Wilson, I have gone ahead and enabled Diagnostics Mode on your account and what that will do is that then next time the ROCK setup is active and connected to internet, a diagnostics report will automatically be uploaded to our servers and we can take a closer look at the log files for errors.

The actions that I would like for you to perform is to make sure the ROCK is powered on, connected to internet and please make sure that you can connect to the Web UI, even if you can only access the Web UI for a brief period of time. I appreciate your patience while we find out what exactly could be going wrong and I look forward to speaking with you further after we receive said logs!


Thank you Noris! I will power on the ROCK as soon as I get home in a few hours. Would you like me to restart it after it freezes assuming it continues to do so? I can do this a few times to provide multiple reports if that helps.

Hello @Tim_Wilson,
If the ROCK freezes please attempt to restart 2-3 times. Alternatively, you can let me know when you are home and have booted it up and I can confirm if the logs have successfully reached our servers. The log reports saves information of errors between reboots so just receiving the more recent log file should be sufficient enough information, but I can make sure to verify that it is after you have powered it on.


Just powered it on.


Thanks for your reply, I can confirm we have successfully received your logs and they should indicate some information about past freezes as well. I will be sure to update you once QA has completed their report for your case.


1 Like

Hey Noris, any word on the report yet?

Hello @Tim_Wilson,
Sorry for the delay in getting back to you! We’ve been doing some testing to try and reproduce, and while we have not reproduced your symptoms exactly, we do have some theories about what might be happening here that I’d like to play out.

There are a few settings and diagnostic functions I can enable on your account that will help us test here. Once we enable those settings, I may need you to reboot the Core or confirm whether things have improved, and I can also generate additional diagnostic reports as we investigate this, which will generate logs our developers can analyze. All of this should help us understand the issue more clearly and hopefully get this resolved for you.

For now, I’d just ask you to leave ROCK on and running. Let us know when it’s up, and we’ll enable some of these diagnostic modes on your account and follow up soon. I appreciate your patience here while we get this sorted out!


It’s up now.

It still freezes after a short time though so I’m not sure if leaving it on will help you guys but I will do so anyway.

Hello @Tim_Wilson,

Thank you for letting us know that it is up and running and I do apologize about the delay in getting back to you here. I have enabled those additional diagnostic reports I mentioned but because the machine is not properly booting up, those diagnostics have been unable to reach us, unfortunate leaving us with the only option of troubleshooting the device through you.

I have done some more research on the setup you have and I noticed another user reported similar symptoms on the intel forums here: As you can see on that thread, he was having similar issue and replacing the RAM module solved the issue for him. I think that it is the same issue here where the RAM is not fully compatible with your setup. Intel has a list of approved RAM at this link:®%20NUC&productType=Kits&productName=Intel®%20NUC%20Kit%20NUC7i3BNH# and I would suggest you navigate to the section “Memory Modules” and try to use one of the “Intel Validated” RAM modules instead of the Crucial RAM you have now.

This would probably be the simplest solution to verify if the RAM is at fault here or if there is something else going wrong. One other question I have for you, is the machine in a suitable location with enough airflow to prevent overheating? As in is it located in a drawer/closet where this could be a cause of concern? It seems unlikely but I though I would ask regardless in case that gives us additional information. Please let me know how the machine is working after you have had a chance to replace the RAM module with an Intel Validated one and if it is still freezing after doing so. Looking forward to you observations.


Hi Noris,

I have a hard time believing the RAM is at fault because I ran Memtest86 and found no issues. Also other people wrote reviews on Amazon mentioning using this RAM successfully with the same NUC that I have. However I don’t really understand this stuff very well so I’ll take your word for it and try switching out the ram. I initially planned on using the RAM listed on the Roon Optimized Core Kit page:

This RAM is also made by Crucial and is not listed as Intel Validated. So what do you recommend? Using an Intel validated memory module or the one Roon recommends which is not validated?

Hello @Tim_Wilson,

I have been discussing this thread with my colleagues and they have shared some important information with me. While it is still possible that the RAM is causing the issue here, they have a theory that something else is going wrong. The RAM that you have is actually listed as one of the supported RAM modules under the updated certified RAM list (as well as the RAM we recommend on our ROCK setup page). My colleagues have proposed that we attempt to install another operating system on the NUC and verify that it boots up properly, such as Windows or Ubuntu (if you have no Windows license available) so that we can rule out the hardware, Intel provides additional instructions on how to do so here. I would suggest that you try to install Windows on it to see if we can stabilize the system, you may even decide to remain on Windows and just install the Roon App that way. I do apologize about the RAM confusion and I appreciate you pointing that out for me. I look forward to your observations after you have had a chance to try the NUC with another operating system.


Thanks Noris,

I was just thinking the same thing and I talked to my IT friend from Microsoft who say’s he can get Windows 10 installed on the nuc this weekend. Is there any settings to change to optimize Windows 10 for Roon?

Hello @Tim_Wilson,

Generally speaking having the newest drivers for your Intel NUC & DAC is recommended, other than that you should be good to go. Drivers for your NUC can be found at this link here. Hope that helps!