ROCK repeated dropouts requiring reboot

Roon Core Machine

  • Intel NUC6I5SYK running ROCK 1.8 (had the same problem with previous versions)
  • i5-6260U
  • 2x4GB DDR4 2400
  • Intel SSD 535 Series 120GB M.2 SATA running ROCK
  • Samsung SSD T1 500GB connected via USB with Roon library (I have tried unplugging this)

Networking Gear & Setup Details

  • ROCK connected via ethernet to Asus RT-AC68U running Merlin firmware (802.11ac 5GHz network, 2.4GHz network recently switched to 802.11n/g/b legacy mode for some other devices on network). Internal firewall on Asus has been tried both on and off with no effect. I usually have a second RT-AC68U running in mesh mode, but currently do not.
  • RT-AC68U connected via ethernet to Technicolor DJA0231 Modem (WiFi turned off) with 100/20 broadband.

Connected Audio Devices

  • Chord Hugo 2 connected to TV via TOSLINK using Google Chromecast Ultra as endpoint (as an aside, is there a way to configure this setup to deliver more than 16/44.1?)
  • Woo Audio WA8 Eclipse connected to PC via USB
  • 2x Google Nest Hub 2nd Gen (also can’t get these to work in display mode despite trying the accessibility workaround on the forums)
  • Samsung S22 Ultra

Number of Tracks in Library

Unsure and can’t access, but approx 200-250GB of local tracks, plus Tidal.

Description of Issue

After power-on and bootup, my ROCK core drops out after, at best, 30 minutes or so and, at worst, 1 or 2 minutes. At that point, all clients simultaneously drop to ‘waiting for Roon core’ or ‘uh oh’ and never re-establish a connection until the core is rebooted, following which the same issue occurs, until another reboot, and so on etc.

On occasion, a reboot is not sufficient to restore access to the core (including repeatedly right now as I attempt to find the number of tracks in my library for this post - I will keep trying and post this later if possible).

I have had this issue ever since (iirc) ROCK 1.4 and, as a result, haven’t bothered with Roon for an extended period due to the continued frustration.

Recently, I plugged the ROCK back into my network in the hope that an upgrade to 1.8 might somehow resolve the problem. It has not. I was able to complete the upgrade to 1.8, but the issue remains.

In addition to bringing the core up to 1.8, I have attempted connecting the core to different LAN ports on the router and removing the USB library SSD. I also intended on attempting recovery using the ROCK installer on a USB flash drive - however, the installer was adamant that ROCK had never been installed on the drive/device and warned whether or not to proceed, so to avoid potentially blowing up my database, I did not.

Would really like to get this resolved and get back to using Roon. Is it possible to switch on diagnostic mode on my account in the hope that this might identify the problem?

Cheers.

While we’re waiting for Support to respond, the thought struck that perhaps this issue may have a physical cause:

  • overheating caused by dust build-up in the fan; it may need cleaning?
  • poor connection of internal components; try re-seating the memory modules and the M.2 SSD?
1 Like

Hi @Geoff_Coupe, thanks for this.

I was just inside the case earlier to check how much RAM was in there and the SSD model. There was a little bit of dust build-up around the rear venting (not loads), which I cleared out.

Will see how re-seating the RAM and SSD goes.

Cheers.

Okay, so I’ve probably narrowed the cause a little. No joy with jiggling everything around, but I brought the NUC into the study to connect up to a monitor, with interesting results.

First power-on, error from the BIOS:

“Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key”

Pressing a key did nothing. Then reset into the boot menu and the M.2 SSD wasn’t showing as bootable (it’s set up as legacy BIOS rather than UEFI btw), selected it anyway gave the same BIOS error.

I next tried going into the BIOS and selecting the M.2 SSD as the boot device from there, and the system booted successfully into Roon OS (it is showing RoonOS 1.0 build 227 - not sure if this is the version it’s meant to be or not?).

I then power cycled the system and that threw out a different error,

“A bootable device has not been detected.”

I’m unsure if this is from the BIOS or Roon, as the text size is the same as when RoonOS boots, rather than much larger text size the first BIOS error threw out.

It seemed ctrl+alt+del kept the SSD bootable, but a power cycle dropped it out again, but whether that is always repeatable I’m not sure.

Anyway, all that perhaps indicates that the SSD (or what’s on it) is at least part of the problem - not sure how to proceed from here.

It could well be an issue with the SSD starting to fail…

1 Like

That did cross my mind, although it’s had like… half a write cycle. Far from the greatest SSD, but that would be truly appalling if it was the case.

Hi @Chris_Jermyn,

Thank you for posting about your issue and I’m sorry to hear that you’ve been experiencing unreliable performance with the ROCK.

We’ve attempted to pull backend diagnostics from the Core, but it appears it hasn’t been online in roughly six days. Are you able to even temporarily restore access to the ROCK at this point with reboot, or has the issue progressed to the point where the ROCK can’t be brought online?

If you have a chance to try to bring the Core online, please let us know. In case our automatic log pull doesn’t go through, please try to access your database and zip up the Logs folder for us.

If you can zip up that folder and send us a copy here, we can get a sense of what’s gone wrong here. We’ll walk you through the next steps once we’ve investigated for possible SSD failure, as well as evidence of corruption or other causes.

Please also share a screenshot of the web administration page for the Core if you have a chance.

Thanks in advance for your patience, and sorry again for the trouble here.

1 Like

Hi Connor, thanks for getting back to me.

I managed to get the core running and reconnected to the network again, and it remained running for about five minutes before going down again - screenshot from client below. It took a few attempts and “A bootable device has not been detected” errors to get there.

Not sure if you managed to pull the logs, but I was unable to see the core from Windows, will fiddle with a few network settings to see if I can get it to show up.

I don’t have the ‘configure’ button in the ‘setup’ tab, screenshot below.

[edit: got the log files, let me know where to send if you need them]



Hi @connor, just checking if the log pull worked?

Hi Roon team, any chance of an update on this? Cheers.

Hi @connor? @noris? @AMP, @enno, anyone…?

Frustrating experience, to say the least…i feel for you.
If I were you, I’d buy a new system disk, reinstall Rock and restore a backup to just get it done over with - you do have a database backup, right?

Hi @Marin_Weigel - I do, but after five years, I have no intention of renewing my membership if this is reflective of the level of respect Roon has for its customers. I have waited years for some of the features included in Roon 2.0, so that is unfortunate, but the way this is being handled (or not handled, as the case may be) is a joke and I’m not going to throw good money after bad.

@connor, over a month ago, I advised that I got my core up and running again (briefly) and asked whether the automatic log pull was successful, and if not, where I should send the log files that I was able to zip up as requested. I have followed up three times since then, only to be met with continued silence. It has been nearly six weeks since the issue was first flagged. I have been patient and, where necessary, repsonsive.

Is there any particular reason why neither yourself or anyone else from the Roon team is bothering to respond?

@noris @Wes @benjamin @joel @AMP @enno