ROCK Software Update Needed


I’ve recently installed ROCK OS on my Intel NUC, but it appears to be an older version. I’ve tried to connect via the roon app on a separate windows PC, and it says that a software update is needed. Current software is Roon Optimize Core Kit 1.7 (build 571) stable.

Attempting to update via either the roon app or the web interface is unsuccessful, with the version remaining the same after repeated attempts to update. The roon app notes that “There was an error checking an update” and any attempts to retry also fail. Any ideas?


I’ve moved your post into the #support category of the forum, where it will be seen, and responded to, by a member of the Support team.

Just to confirm, you’ve tried using the “Reinstall” button for the Roon OS on the Web Administration page, and that has not worked?

As far as I’m aware, the current version of Roon OS is Version 1.0 (Build 227), so please show a screenshot of http://rock.local. Thanks.

Roon Server should be on 1.8 or 2.0. I suspect this is what needs updating. Please confirm.


That’s correct, the reinstall button does not update the server software build.


Yes, the Roon OS is version 1.0 (build 227); however, the roon server software is stuck at version 1.7 (build 571). See screenshot below.

1 Like

How recent and where did you get the image from? A fresh install, downloaded from Roon Labs today, should put you on the latest Server Software.

I just did a fresh install yesterday, and I downloaded the most recent image from the guide on this page:

I’m Talking Rubbish. Ignore my post.

It all links back to the image you downloaded which has not been updated since 1.7? Support needs to jump in here.

Use this page:

Unless I’m missing something, that page also links to the same knowledgebase where I downloaded the image originally.

1 Like

Support doesn’t work weekends. Maybe look at the server logs for clues at this point?

Looks like an issue with connecting the update server.

Your Core doesn’t seem to have access to the Internet or DNS is failing. How is it hooked-up to the network?

It’s connected directly to the router via ethernet. I can access the web interface and SMB shares via another computer on the network, so it shouldn’t have any issues.

I take it back. It’s pointing to a bad DNS server. Working on that…

1 Like

“local access” and internet access are 2 different things. Just because local works does not mean the other will.

You can try setting a fixed IP on your core, via web interface, which will then let you set the DNS servers or change the DNS servers on your router. Roon recommends (Cloudflare) or (Google)

1 Like

Sure enough, I fixed my DNS issue (pihole gone bad) and it’s working now. Thanks for pointing me in the right direction wrt to the server logs.


Aha - that would explain why the Reinstall option did not work in your case. Thanks for letting us know that this issue is solved. This will be useful for future reference.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.