ROCK with Yggdrasil Unison USB

Roon Core Machine

Intel NUC7i7BNH 16GB Intel I7; Roon OS 1.0 build 227;
Roon Server 1.8 build 952

Networking Gear & Setup Details

3Com gigabit using Ethernet.

Connected Audio Devices

Schiit Yggdrasil “Less is More.”

Number of Tracks in Library

15,000 tracks

Description of Issue

Yggdrasil LIM just purchased; has Unison USB. Using USB ports on the NUC to the Yggy, get smeared/heavily distorted sound using the Schiit USB cable. Output to an outboard USB->SPDIF converter works great (same USB port).
Talked to Schiit support and they say the problem “… may just be due to the source and how it outputs USB”
Since the Yggy is “Roon Tested,” and the NUC7i7BNH is recommended by Roon for ROCK, is it possible that I need to change something in the ROCK config?

Hi Michael while I have used them myself and found it fine, Roon generally doesn’t recommend that DACs are plugged directly into the Roon Core.

Do you have a Raspberry Pi or PC or Mac that you can run Roon on just to check that there are no problems with the USB port or the USB cable.

Thanks for the suggestion.

I tried a 2015 Mac running core with output on USB3.0 using the Schiit cable straight into the DAC and it produced good sound.

I have the problem, apparently, only when using the NUC.

I returned to the NUC/ROCK and fiddled with some of the device options (fixed sound, etc) produced no improvement. Occasionally a high-pitched squeal is produced instead of the distorted music.

At present, I set “load defaults” on the interface and changed volume control to “fixed volume.”

Get the smear/distortion all the time – except still sometimes get the squeal on pressing “play,” Must select “device options” to make it stop.

I take it you tried a different USB port on the back, the front ones can be disabled based on my previous usage.
Have you got another USB cable that you can try as well. I never had any issues with using my Nuc in the past, but I did buy an Audioquest Jitterbug and cinnamon cable which made it sound pretty much as good as an external Roon ready devices.

I don’t use it anymore as I mostly have Roon Ready devices now. A Raspberry Pi (for those who like to tinkerer) or Zen Stream are both great little devices and the Stream also has a very good implementation of SPDIF as well as quiet USB if that is something you are interested in

I have two cables that produce non-distorted sound: an old USB2 scanner cable (2M) and a 5M USB printer cable. I tried these on a lark.

The StraightWire 1M from Schiit and a 1.5M AQ Cinnamon produce the severe distortion on any of the NUC’s USB ports and when they are the only connection on the USB bus.

Thanks again for the suggestions!

No problem, at least you made some progress

do you know if the older cable’s are running in USB2 mode? Sounds like that is a bonus in that case.

Sorry, no idea. The cables that worked are thin and cheap. It’s the USB 2.0 “fancy” cables that produce the severely distorted sound. The sound through the cheapie cables is about 90 per cent of what I get on the SPDIF coax input after the SPDIF converter.

Is it possible to put the USB ports on the NUC into USB2 mode?
Sorry I am on holiday so can not even look at mine.
My guess you paid extra for the USB on the Yggdrasil so want to use that.
Hopefully someone with a Yggdrasil can add some more context for you

I found BIOS has option to enable USB 'legacy support ', make it ‘auto’ (disables when nothing plugged in), and disable.
As I understand it, USB 3 ports will operate as USB2 when needed. Anyway, was set to ‘enable.’ and I set it to ‘disable’ and there is no change.

Michael it was worth trying it at least.

You can use any of them. USB3 got nothing new regarding audio; it will still use USB Audio 2.0 - so no issues using USB3 ports for connecting to DAC.

1 Like

I use a 2012 Mac Mini for my Library but seem to prefer the AES input. Though I have UNISON USB on my Yggy OG, I use a DDC bridge, an Audiobyte Hydra Z that converts the USB signal to AES and then on to my Yggy. Just though I’d throw in my 2 cents in case you may want a different path.


Hi @Michael_Ryan ,

It sounds like this cable is problematic for playback somehow. If you try it on a different PC and not the current Core, does the issue reproduce?

I am using the USB cable that Schiit sells; the other cable is USB 2.0, an AQ Cinnamon.

Both cables performed excellently when I drove the Yggdrasil Unison USB input from a Core I installed on a Mac laptop.

Both cables also work with two external USB->SPDIF interfaces, as do the NUC7i7BNH USB ports. ROCK driving the Yggdrasil from the NUC7i7BNH in this way also produces beautiful music.

So, the Yggdrasil and its Unison USB appear to be working fine.

I built a second NUC7i7BNH/ROCK and I get the same results as the first one.

I suppose this will remain a mystery,

Thanks for the suggestions.


If a standard cable works, then the other cables are the issue. Did the packages have the USB certification on them? Boutique audiophile cables might not be made to official standard USB cable specifications.

Load Windows on it and see if the cable works.

1 Like

After some painful work, I loaded Windows 10 and a FLAC player on the NUC10.
Same results.
So it is something with the cables.



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.