ROCK won't connect to internet

After installing 1.8 ROCK/NUC performance was much better with less network errors and connection problems. So I decided it was time to replace my old Linksys WRT1900AC router. Luckily there is a shop nearby :slight_smile:
My new router is ASUS RT-AX88U. Firmware updated. Multicast and IGMP Snooping enabled. Firewall is ON. Everything works fine. Setup is exactly same like Linksys (DHCP,DNS etc)
After few hours of stand by SEARCH took few seconds and NOT 4 minutes including TIDAL and local results.


  • In certain situations Linksys routers may not be the best option for Roon although the technical explanation of why remains to be a mystery.
  • Depending on the connectivity, performance of 1.8 and user feedback, Roon may still require a fine tuning to work in relatively difficult internet infrastructure in the future.

Many thanks to all who contributed!

Enjoy the Music!


1 Like

@esom I’m late to this thread and I see that your problem is solved.
There is one thing I’d like to mention which may help in understanding: if the Huawei unit and the Linksys/ASUS box both has NAT (Network Address Translation) enabled this can lead to trouble. The best would be to set the Huawei box in bridge mode. Then the WAN port of your Linksys/ASUS router would get (via DHCP) an official internet IP address (as opposed to the private addresses used in your LAN) and NAT would work as intended. Your ISP may not allow this so the other solution is what your friend has done - setting the internal Linksys/ASUS box as a bridge thereby avoiding double NAT.

Hi ogs,

Many hanks for your suggestions. My main issue is due to security concerns not to combine telco device and my own router together. Bridge modes will make everything like a single network and this is exactly what I don’t want. Anyway I am happy that my problem is solved but still very curios why it was not working with linksys earlier and what makes Roon ROCK different than many other devices in my network?

Enjoy The Music!


Hi @esom ,

Thanks for letting us know that you were able to resolve this issue by using a different router!
It’s strange that the old Linksys was causing this issue, but happy to hear that it is resolved.
Hope you enjoy using Roon!

I have read this entire thread. I am getting the same error messages with my ROCK server after upgrading to version 1.8. Everything worked perfectly with this Server on 1.7. I have tried the steps mentioned above but have no idea on what to try next. My server is connected via ethernet cable into an unmanaged switch ant to my Apple Airport Time Capsule. I have to have the Rock server near my c2700 preamplifier as it is connected via USB to the preamp.

I loaded the Roon software on my Apple iMac for a test (though this is only a temporary solution) and everything works find. The ROCK server is visible on my network via my internet browser and is seen in the Roon software, however, it cannot connect to the internet when I attempt to log in. I also went back through the reinstallation of the ROCK software using a USB stick which loaded 1.7, which was then upgraded as soon as opened the software. The upgrade was successful. Results with a fresh operation system were the same. I also went through the process of renaming the RoonServer folder as described above.

In addition, I have moved the ROCK server temporarily and connected it directly into the Apple Time Capsule and was able to log in successfully.
Please help.

Hello Mike,

My problem is solved by trial error and not really by technical analysis. I have no experience with Apple networking products, but the functionality must be similar to other routers.
Do I understand your setup correctly?

How is the iMac connected?

  • To the Time Capsule
  • To the switch
  • Wireless or with cable?

If we continue playing the game of trial and error and iMac is connected to the Time capsule, the logical conclusion would be Roon 1.8 and the switch don’t like each other anymore. Why ? The mystery continues…

Good Luck!



Thanks for replying. The time capsule is connected to a switch and my iMac is then connected via wireless network to the Apple Time Capsule. Currently, the ROCK Nuc is in another room with my audio system. I am able to play music on the system by leaving the Nuc plugged in via USB to the McIntosh preamplifier even though I am not using the Nuc computer as the Roon Core.

Your message got me thinking. I have the iMac connected via wireless most of the time but also have an ethernet cable attached to it that runs into the same switch that my Nuc does. When I tried to use my iOS devices to control the audio to my preamplifier, the iOS app would only see the iMac as the core if my iMac is connected via wireless and the Roon app is open on the iMac. When switched to ethernet the iOS devices do not see the core.

It seems that I can switch from the wireless network to ethernet if I use the iMac macOS Roon application to stream to my preamplifier even though the iOS devices are then not able to connect. It is just all very strange as I have probably run this ROCK core through ethernet like this using 1.7 for a year with not a single issue.

Everything has to be on the same network subnet. Sometimes, wireless networks have a different address range than the wired portion. You might use Fing to check if everything on your network is in the same subnet, aka, the first 3 groups (aaa.bbb.ccc) are the same… aaa.bbb.ccc.x… for all devices.

I believe they are all on one subnet. All assigned IP are in the same first 3 groups.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.