ROCK won't connect to internet

Core Machine (Operating system/System info/Roon build number)

ROCK 1.0 build 227 on NUC 5i5RYH Fresh installation

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

First Router Huawei (Fibre) delivered by Telco used only as a gateway (IP range 192.168.100.xx)
Main router connected to the Fibre device, has IP range 192.168.1.xx, has all functions like DHCP , WiFi etc Linksys WRT1900AC
There are many devices working perfectly either connected via Wi-Fi or ethernet via three different switches.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Many audio devices, more information is irrelevant

Description Of Issue

We purchased last week for my friend a Nucleus Plus and had internet connection issues. My friend has similar two layer network setup. He was able to get internet connection only when nucleus is directly connected to Telco Fibre Gateway. Later when we were trying several options I entered to Nucleus exactly the same DHCP obtained values manually and it started working after a reboot. However there are still occasional interruptions.
Based on this experience today I decided to remove my Windows 10 NUC setup and install ROCK instead. Everything went well until the moment of login to Roon. Device is accessible in the local network, can be pinged, can be accessed via browser. Roon client finds the server. ROCK won’t connect to internet !!

Things I tried

  • Enter LAN parameters manually
  • Change DNS from to or
  • created DHCP reservation on Linksys

Things I didn’t try:
Connecting NUC directly to Fibre Gateway. Even if it works I don’t need it that way. This device should work like any other device in my network smart phones, audio devices, IPADs, PC’s etc.

Roon OS (ROCK or Nucleus) has a problem with internet connection in kind of complicated and NOT straightforward networks.
There is a confusion as we are using IPV4 and IPV6.

I will appreciate any suggestions.

Enjoy the Music!




I forgot to wrote earlier that restarting Linksys router didn’t help either.
The same NUC was working for many years without a single problem with Windows and Roon server/core in the same network environment.

  • What is the difference of Roon OS in internet connectivity ?
  • Is Roon OS trying to connect to a different IP address than Roon under Windows?
  • Is Roon OS trying to connect to a fixed IP address xx.xx.xx.xx or url like roon.xxxxx?

If I know the destination, I can try to do some tests, whether the address is reachable from other devices like Windows PC, IPAD, ping, tracert etc.

Enjoy the Music!


As last option I had to try the same trick like my friend with Nucleaus +. I connected ROCK NUC directly to the Fibre Gateway. Connection to Roon established, previous Windows core unauthorized ,new activation done.
Connection back to Linksys network. Everything works fine for the time being. However my friend says , the Nucleus is losing connection to Tidal every morning he needs a restart to have Tidal back.
Of course this is NOT final HAPPY ENDING! This requires an explanation and correction. I am ready to deliver any logs, test results if required.
The only reason I switched from Windows to ROCK is plug and play an forget. Windows 10 made so many updates and restarts and stopped Roon every time. Being forced to do a manual restart of ROCK every morning is definitely not a better one.

Enjoy the Music!


In case you have been patient enough to read this thread, my deepest thanks!
Another small update:
When I play any song from TIDAL, device is establishing connection to Google Cloud and Amazon Cloud. Support may clarify the internet connection process for Roon and Tidal, which may help me to investigate further. It seems mine and my friends Linksys routers although being different models may be blocking certain communication or selected ports or protocol.

Enjoy The Music


Hello everybody!
Probably due to weekend in between, nobody from support responded until now. I investigated further. Here is a little summary.
Many times if any remote tries to connect to the core or if the user starts a SEARCH ROCK Roon core tries to establish a connection to many IP addresses like for different purposes. Most of these addresses are hosted by Google cloud services and some on Amazon cloud services.
I have two connection options:
Option 1 : Directly to the internet gateway modem router
Option 2: To Linksys router directly or via many switches in the network

Ping and traceroute with Option 1 and Option 2 give same result.
Connectivity to Roon servers with Option 1 is quick
Connectivity to Roon servers with Option 2 is very much delayed. (Log file full of network error messages)
Example during normal operation:
Roon ROCK has not been used several hours. I start a search from remote App let’s say Santana. Roon Core must access some destinations on Google and Amazon cloud to get an answer for me.
With Option 2 the search result comes back after 3.5 - 4 minutes. However once the connection to cloud is established all following search results will appear in a few seconds.

With Option 1 the first search result comes back in a few seconds.

It seems something in my network (most probably the Linksys) Router has a delaying and blocking effect on the connectivity. My networking knowledge is not good enough to guess possible causes. I would appreciate some advice from support either how to analyse or even suggest a replacement router. Of course I need guidance what features are necessary in a new router to make Roon work perfectly.

Thanks for reading!
Enjoy the Music!



I know it’s getting annoying, Sorry! Another small update.
To compare my previous Roon Core with Windows 10 on the same NUC, I extracted the old log files to analyse.
In the same network environment log files are NOT full of network error messages, there are occasional " NETWORK REACHABILITY CHANGED REFRESHING" messages.
Some search activities finish in 15-60 ms!!! in RoonOS my best result until now is around 1600ms and mostly above 40000 ms.

Enjoy the Music!


Hi Esom,

Friendly Helpful Fellow User Here.

You have found an answer which is use Option 1. What you have not done is explain why you can’t or do not want to use the solution you found. The RoonCore should not be in the music listening areas anyway, according to Roon’s best practices, so, I am not sure why you do not just leave it sitting next to and plugged into the Huawei.

Since you are having Router issues, have you read the FAQ. At the bottom, there is a list of problematic settings for various routers. Linksys is not on the list, but, you can get a feel for the problem settings on other routers and look for like settings on the Linksys.

Or, use Windows (I do) which seemed to work for you. You can set Windows up to auto login, so even if there is an reboot, you will not have to do anything.


Hi Rugby,
Many thanks for your reply!
I read the article about routers. There isn’t much to help me and there is nothing specific about Linksys as you have seen.
Why not option 1? Good question :slight_smile:
There are several reasons:

  1. My house is one storey and app 20m long Huawei router is on one end in my office area and living room with all music systems is on the other end.
  2. Huawei router is too much accessible by telco, which I see as a kind of security risk. If you search on the internet you will see that all Huawei routers have the same user id and password in the world.
  3. Linksys is in the centre of the house having better Wi-Fi coverage. ( You will suggest bridge configuration (see above item 2)
  4. Although it is an endless discussion in audiophile circles, I believe digital connections (cable, switch) influence sound quality. I have many expensive ethernet cables (Audioquest) as well as a special switch from a German company AQVOX. All my primary audio devices including Roon core are connected to that switch.
  5. MQA is another endless discussion in audiophile communities. I own a Devialet 440PRO and an AURALIC VEGA G2 Streaming DAC. None of these devices support MQA decoding, which requires Roon Core to do the conversion for me. Therefore I would like to keep it that way having all important audio devices connected to the same switch.

However the most interesting part of this is, that I used Roon Core on Windows (same hardware) many years without any of these problems. My friend used on a Mac Mini without any of these problems. He was thinking to buy a new M1 Mac Mini and I suggested him to buy a Nucleus Plus. He is having now exactly the same problems and I feel myself responsible.

I really would like to know what is the difference between Mac, Windows and Roon OS?

  • Different behaviour in case of network errors like short timers or less retry attempts
  • Connection to different clouds
  • Using different protocols

Anyway thanks again.

Enjoy The Music!


Hi @esom,

Seeing too many “Network Reachability Changes” is often not a good sign, how do you have your IP leases set up, to expire every 24 hours? Are you using the latest firmware on the router? Default MTU? Does the issue still occur if you try setting up a Reserved IP for ROCK in the router?

Hello Noris,
Thanks for your reply.
Lease time is 1440 minutes (24 hours).
Rock has fixed reserved IP address, but it didn’t change anything in behaviour.
Firmware is latest just checked again.
If you suggest new lease and MTU values I can try. But my observation is ROCK stays connected to my network but is not staying connected long time to cloud/roonlabs. I may be wrong of course. Roughly I would say in an hour or so again search action becomes 4 minutes long.
Some screenshots which I have never ever seen during windows operation:

ping values between 56 ms and 173 ms



about IGMP…

There are various suggestions in the forum to enable or disable IMGP proxy / snooping depending on network equipment used.

I read following comment about Linksys WRT1900AC in another forum:

Their answer: “WRT1900AC does not support IGMP proxy. However our Business class router supports this kind of feature.”

Can this be the answer to connection problems related to Linksys?


IGMP has symptoms of not finding other devices/endpoints in your network. Your issue is that something is blocking Roon’s “phone home” requests. I would suspect a firewall setting of some kind, although it could also be due to DNS issues.

I’m not sure this has been suggested yet, but, try and set the DNS on your router to or

Hi Rugby!
Many thanks. I tried and directly in the DNS setting of ROCK/NUC but not on the router. I can try on the router, as well to be honest without expecting any improvement.
Regarding the firewall you may be right, the bad thing in linksys routers is that there are no settings allowing you to define firewall rules. You can either enable or disable the firewall without having any clue what it’s doing. I think I can take a small risk and disable them for a very short time when there is not much internet activity at home.

Enjoy The Music!

well, if you do disable it briefly, and it works, then you have your answer for sure.

I disabled Firewalls for IPv4 and IPv6. No success. I understand Roon development should be busy this week with the the release of 1.8. If during this week nobody from support has any better idea, I will be returning to Windows version. Log files show there were some network errors as well but operation was smooth.
I am not willing to change my two layer network where 30 devices are working without any issues the only exception being Roon OS / NUC. I checked yesterday availability of other routers from D-Link, Asus and TP-Link. I just need a technical explanation why this is happening and what should be the criteria to buy a new router.

Enjoy The Music!


did you try changing the DNS of the Router?

Yes I did. No change. Sorry I forgot to report earlier.
I found another thread in the forum
TIDAL errors on NAS + ROCK - Support - Roon Labs Community

Which has a similarity to my problem. In my situation the TIDAL login is taking very long time and delaying the whole process. In search TIDAL is again the major blocking point.

I think we have tried whatever is possible. Somebody who knows very well the connection process and working of Roon may have a better idea. For the time being this is my roadmap:

  • I will update to 1.8 and see if anything changes. If not I will accept the reality that I won’t get much help from ROON development side and return to Windows.

By the way my friend with Nucleus Plus having the same problem with a different model Linksys router has re-configured Linksys to Bridge Mode and everything is fine.

Yes I am crazy and will continue to keep my current setup. :slight_smile:

I have studied user manuals of some other routers available in the market and decided Asus and D-Link are quite good offering much more complicated settings to play with. Tp-Link is similar to Linksys with simple setting options. Netgear is too expensive.

How can I ask users what type of router (Brand Model)they are using if they have their own and not supplied by the service provider? The list can give a general idea which way to go for a replacement router. Although being the only device not working I would have preferred a suggestion from Roon instead of trying external remedies.
Thanks a lot Rugby for your time. Very much appreciated.

Enjoy The Music


Hi @esom,

Is the behavior the same if you try to set up a fresh database for ROCK?

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Verify if the same behavior is occurring on a fresh database

Hi Noris,

Thanks. I will try this. However the issue is purely related to connectivity from my ROCK to addresses. What is the logic behind having a fresh database installation?
And my friend with Nucleus Plus changed the Linksys router to Bridge Mode, all network connectivity problems disappeared.
There are still many unanswered questions, which obviously nobody is addressing:

  1. Why is the linksys router causing a delay towards internet as seen from the Roon software point of view ?
  2. Why Windows and Roon OS versions behave differently? I strongly think timer values are not long enough to wait establishing connection. I am living behind a strong national firewall and can never have the quality of an internet like in USA even with a 200 Mbit/s.

I will report soon about fresh database.

Enjoy The Music!


Hi Noris,
Unfortunately I couldn’t make it work,
02/08 07:13:12 Info: Starting RoonServer v1.7 (build 710) stable on linuxx64
02/08 07:13:13 Debug: [easyhttp] [1] POST to returned after 765 ms, status code: 200
02/08 07:13:13 Trace: [bits] updated bits, in 800ms

02/08 07:13:13 Trace: [brokerserver] Enabling broker server
02/08 07:13:13 Info: [broker/distributed] HTTP server listening on port 9100
02/08 07:13:13 Trace: [broker/backups] initializing
02/08 07:13:13 Trace: [broker/accounts] Data updated. AccountStatus=NoAccountConfigured MachineStatus=NeedsAccount UserId=

Does this mean my account information needs to be re-entered?
I connected two remotes from Windows and IPAD. Both are connected to Core on the IP level (log file)
But they show “Trying to connect” , so I have no possibility to enter my account details and other configurations.

02/08 07:13:38 Info: [brokerserver] Client connected:
02/08 07:13:38 Trace: [SOOD] Adding User IP

After waiting 45 minutes and another full reload. I have returned to my previous Roon Server.