Rock won't log in [Resolved: WiFi setting in BIOS]

Hi there,
I have searched on the forum but could not find the solution to my issue. Although it has been reported more often. I purchased a ROCK, i7, 250gb, 2x8 RAM and 2 tb internal storage. I installed rock and the missing codecs on the rock and all seemed well. I restarted ROON and said that i would use ROCK as the core and no longer my windows surface computer.
I choose ROCK as core and tried to login and login won’t stop and nothing happens. Internet is working fine but ROCK wont log in. It continues logging in.
What is wrong?
I am pretty desperate, cant find what is wrong,
Please help, I will probably do a fresh install of the ROCK… I already erased and reinstalled ROON on windows, that did not help

Many thanks for the help

1 Like

Not sure if I can help, but are you able to type in the IP address of your ROCK and see that everything is ok there? You might have to log in to your router to work out the IP address.

Mine looks like this (ignore the CD ripper part, I’m setting up my ROCK as well right now):


A screen shot of the GUI (like above post) might help us help you. Networking settings can be an issue here too. DHCP is normally safe assuming your router is giving out valid fields to populate.

Thanks but my IP adress is correct and in the overview everything is ok. It is also set on DHCP. In the bios I had set that startup would occur using IP4 of IP6, maybe that is the issue?
I have changed everything as required (disable secureboor, enable legacy, disable network boot, enable usb boot. Although network boot was disabled, i left on IP4 and IP6 (because the document does not mention that specifically). Could that be the issue?

In order to determine whether the issue is the ROCK or logging in, can you successfully log in when choosing your Windows machine as the core?

Yes, i can login on windows but I removed the core already (removed database to prevent issues from arising, as was advised)

I dont get it, everything seems ok, the rock seems to be functioning, i just can’t connect to it???

Can you disable the Windows firewall?

yeah i disabled it already

Try using the same info you see on the GUI but change it to static address, now add after a Space on the dns box and see if that works. Then maybe investigate the dns and dhcp settings in your router

I tried that but it did not work.

In my logs on the network: I read these reports:

[push] restarting connection (Unable to read data from the transport connection: Software caused connection abort.)

Don’t know what that means. I found it in the logs on my Windows computer that accesses the network where is can look into ROCK.

Aaaahh, I am so frustrated, spend 1200 euro’s, doing everything as is told you should to get ROCK started. Really hope somebody can help, anyways thanks for your help.

I have got the logs in a zip file, whom from support can i send it to?

Put them on a google drive or dropbox and wait for @support to reply and you can PM them a link privately

I fixed it myself. My rock was on wifi (in bios) but somehow it was not, so i changed the settings again and after that is worked perfectly.

Now I have the issue that al my Tidal playlists and albums are empty (?). Using the same account I have been using for years, strange.

Anyways happy that the ROCK now works.

Have you restored your Roon database backup?

I never lost it, i unauthorized my computer, selected the rock as my new core and did nothing else

Hi again @Razza,

The Roon database (that holds all your playlists, play history, edits, etc.) is stored on the machine that is running the Roon Core. If you setup a new core on a different machine, it will use a new database.
Thus non of your lists or edits will show up (they are still on the old machine).

You have to backup the Roon DB that was in use on your old core and restore that backup onto the new core, there is detailed information on this here …

As an aside, it’s very important to take regular backups of the the Roon DB, just in case the live DB is lost. If that happens without a DB backup you would have to start all over again.

Hi Carl,
I am not missing my personal playlists. The problem is everything (playlists, songs, albums, everything) is empty in tidal in roon. Using the exact same account outside of roon and everything functions. It seems to be a roon problem,