roo6D - The wireless high-end physical volume knob for Roon

Brian,
such things seem happen if I have a new product and add something to the guide without reading the rest. Sorry for the trouble. Let me clarify:

  • The recommended Raspberry for roo4D is the Pi 4 but there is no reason why not to use roo6D with a Pi Zwero W.
  • The only Roon extension blocked when using WiFi is currently rooUPnP because it transports audio data. This means roo6D can be used with WiFi.
  • I recommend charging the SpaceMouse using the Raspberry. Reason is that wired operation of the SpaceMouse has priority. If the wireless receiver is is the Raspberry and you plug the cable In a PC with the driver installed, you control the PC and no more the Raspberry. Unplugging from the PC returns functionality to the Raspberry. If you use the Raspberry for charging you can still control Roon while charging. So for sure it is reversible and no new installation has to be done.
    DrCWO
1 Like

No problem - I kind of figured that was the situation with the manual. I just set this up, and everything went “swimmingly” as the saying goes. Works great! I reduced the rotation sensitivity - for me, the volume was jumping up more quickly than I expected. Anyway, many thanks for your work on this!!! :slight_smile:

BTW, I have an OSMC remote control connected to my ropieee device, and the two remotes are co-existing happily on the same zone.

1 Like

I installed the Roo6D earlier today and I love the experience so far. Two observations after a couple hours of use:

  1. Something seems to throw off Roon or the extension after scrubbing a track (i.e. ffwd). It takes a few seconds for playing to resume and I had at least one instance where I had to reset the Roon core to become responsive again. Not a big deal, as scrubbing is not a use case for me.

  2. After moving the Pi 4B from one part of the house to another part to try the Roo6D on a different zone, I had to go through the steps to join my Wifi network again. I expected these settings to be preserved.

Soundserge, sorry for the late reply.
I did scrubbing often and got no issue there. I guess it might have something to do with WiFi. Please retry with a wired connection and report if the issue is still there. Scrubbing creates huge traffic.
And of course rooExtend remembers WiFi settings! So after reboot they should be still in place. I had no issue in this direction with any of the many users. But connecting to WiFi takes time, so please be patient.
Restarting Roon server cuts the connection between rooExtend and Roon until to the next boot of rooExtend.
Best DrCWO

Thank you, I was hoping to use a wired connection anyway.

Are there special instructions to establish a wired connection between the Pi and my network? Can I disable WiFi on Pi?

Just connect and WiFi will be disabled automatically.

Just so I understand how this works: if the Pi running the rooExtend image boots while wired to the same subnet as the Roon core, and gets an IP address via DHCP, then the Roo6D will appear in Roon Extensions.

Is that correct?

Correct :blush:
That is how it works. After Boot I look for DHCP to get my IP. If Roon core is in a different subnet it won‘t be found.

Thanks, worked great. Seeking/Scrubbing while wired still caused my Roon core (Antipodes CX) to become unresponsive, but that could be because the core is not able to keep up. It’s not a feature I need anyway.

I love the Roo6D user experience! Really completes Roon. Thanks!

2 Likes

Great to hear! We can certainly try to reduce network traffic for seeking in the next version.

1 Like

I have a wireless space-mouse, so when rooExtend started supporting it I got a license and a Pi to connect it to my Roon setup. Everything went fairly smoothly, but there were a few hiccups along the way. I thought I’d describe those hiccups here - hope this helps others.

I got a Pi Zero W, mostly because I already had a Pi 4 and I was curious about the Zero form factor. The Zero did work, and I don’t think its low power is an issue at all for roo6D. What was an issue, though, was WiFi. RooExtend kept disappearing and reappearing in the Roon Extensions screen. I have an eero mesh network in my house, and although I don’t have proof I’m pretty sure that’s the cause. There’s a lot of discussion on this forum about difficulties with mesh WiFi, but it’s nothing compared to the loads of very upset people over on the eero forum with similar problems! I think eero is great for what it does, but it apparently does not handle low-power 2.4GHz devices like the Zero well at all.

So, I set the Zero aside and used a Pi 4. That process was only interrupted by my confusion about how to revoke my rooExtend license so it could be applied to the new Pi. I had taken the SD card from the Zero and put it into the Pi 4. I kept looking around on the sellcodes.com web site to revoke the license, then I thought it might be on the rooextend.local web page. But that required me to bring the Zero back up. Turns out I had to re-enter the code in Roon for the Zero to work again, and that’s when I realized the revoke happens in the Roon Extensions screen. After that epiphany, everything went fine, and the space-mouse works really well now.

2 Likes

Brian,
thanks for your writing.

Indeed WiFi is an issue with so many mesh products. The reason is that rooExtend does “routing” so if it finds two stations with nearly the same strength and SSID it switches between those. In the rooDial thread rooDial a Wireless Volume Knob for Roon with Microsoft Surface Dial - Audio Products - Roon Labs Community this was an often discussed point because rooDial relies on Zero-W and WiFi.

At luck you found out the mechanism behind license revoking. Also in the rooDial thread there are a lot of posts regarding this aspect. At the beginning you had to revoke on every rooExtend update. Now only if you change the hardware what you did. Basically licensing checks the hardware. So before changing please revoke and relicense on the new platform.

Sorry for the inconvenience. You should have asked me instead of tinkering the whole sunday :wink:

“the space-mouse works really well now.” is not really enthusiastic :cold_sweat:
Would you mind sharing your experience with us and the Pros and Cons?

1 Like

I come from a family where saying something is “not bad” was high praise. So I thought that what I wrote before was me being effusive :slight_smile: But I’m happy to share some more of my thoughts here …

The space-mouse, talking to Roon via roo6D, is for me a really big improvement in my enjoyment of music at my desk because it makes things more direct. I sit at my Mac most work days, getting stuff done and listening to music with Roon. The audio zone is a powered speaker in my office, which is connected to a Pi running ropieee. It’s easy to imagine, skipping tracks and adjusting volume in the Mac Roon app, that the Mac is playing the music. It isn’t, of course; the Mac app is just a remote control that tells the Roon Core what to do, and the Core sends the music directly to the ropieee endpoint. The space-mouse is another remote control, but one that feels natural to use, and doesn’t require me to find the Roon app window among all the others, locate and click on the volume slider with my trackpad, etc. etc. Instead, I just reach over with my left hand and use this thing that feels like a BMW iDrive knob. I realized how non-essential the Mac app was the first time I came back from lunch and tapped the top of the space-mouse to change it from pause to play. Music started playing, then I realized the Mac had turned itself off while I was away! No problem though. Aha … this Roon thing - with the core and extensions, and zones and endpoints - is starting to make more sense to me.

I’ve got the space-mouse settings so the rotation sensitivity is reduced. At the default setting, for me it jumped up too fast. Probably because I listen at low volumes and I generally only want to go from quiet to a little more quiet, or from quiet to a little less quiet. :slight_smile: And I set both shift forward and pull backward to mute. It’s pretty common that someone comes in and wants to talk to me, and I don’t want to have to remember if mute is forward or backward. I’ve seen some discussion here about problems with scrubbing, but it’s been fine for me. I don’t use that function too often, though.

So the Pros for me: the super-high-quality feel of the hardware, so it’s a pleasure to use. It doesn’t move around. It doesn’t rattle. It doesn’t look garish. It doesn’t get fingerprints. But the software connection to Roon is also high-quality (now that I’ve got the rooExtend Raspberry Pi connected to my network via an Ethernet cable). So every time I touch the knob, it works.

Not too many Cons for me: The space-mouse certainly is not cheap, but every time I use it I think the company deserves their money. I do have a second Raspberry Pi to find a place for now, another cord to plug in somewhere, another LED glowing in this small room. I will have to charge the space-mouse at some point, but it’s going down pretty slowly. I didn’t notice the Lifetime option when I purchased the license for roo6D, so now I have to remember to renew it. Really, though, nothing to complain about!

A bit of a paradox, I guess, but adding a complex bit of hardware and another tiny computer to my network has made my music listening seem more analog. For me, the less my music listening seems like just another thing I do on the computer, the more I get engaged with the music and really appreciate it. So, thanks very much!

1 Like

Hi DrCWO!
I have all the pieces (space mouse, Pi4, License for 6D)… I flashed the card and am now stuck at “rooExtend login”… I did not see this in the google doc. Please advise.
Thank you!
CJ

1 Like

Never mind! I just plugged in via ethernet and saw the extensions appear in Roon; I added the lic. and now all is well, so very well!
Thank you!!!

1 Like

i happen to own an idle Pi 3b. Compatible? Advisable?

Should be I think

I would think so. But I have never used WIFI on my RPis, and I vaguely recall that the 3bs were deficient in that area.

But hey, at these prices, I’ll just try it. Thanks!

Should do the job

Please check the Quick installation guide and my rooDial videos to setup WiFi. And please git it time to connect, in some installations it takes up to 5 minutes. Issues were reported with mesh WiFi installations.