rooDial a Wireless Volume Knob for Roon with Microsoft Surface Dial

Well I think it might be done like this:

  • Change name of “Zone” to “Selected Zone”
  • Offer an additional zone selector called “Alternative Zone”
  • Offer an additional press action calles “Swap Zones”

Might work like this:
Performing the associated press action, the content of “Selected Zone” and “Alternative Zone” will be exchanged so the Dial is - after the press action - connected to the zone selected in the “Alternative Zone” setting before. The same mechanism will work backwards.

Is this what you are thinking of?

2 Likes

Indeed so, @DrCWO — that would work very well for both my use case and apparently that of the community member above who wants to swap from speakers to headphones. In my main system, I actually use three DACs — but two are swapped out within HQPlayer, so there is no zone change in Roon when I toggle between those particular DACs. So for me, a single alternative zone choice would work well. I suppose you could make it user adjustable as to how many alternative zones to add for the rotation.

Last night was my first real use of the dial for late night listening on our sunporch audio system. It was really nice to be able to adjust the volume of differing tracks without having to open my eyes to read my iPhone! Cheers. JCR

PS I saw a reference a few posts above to a v1.30 of RooDial. Your download page has the v1.21 image. Is that the current one? And one operational question: I note that a fast double click skips tracks to the next one. Is there a function for going backwards to the prior track? Thanks.

v1.3.0 is still to come. Was a mistake in my processing to load it up for some time :grin:
You can customize your long press action for backward so soubleclick forward, long press backwand.

One thing I would appreciate very much too. thumbs-up

3 Likes

Can’t say enough great things about this setup! IMO, the lack of tactile input for Roon was a major missing piece. Now I don’t have to fiddle with the ridiculously fiddly onscreen volume when I’m cooking. Vielen Dank.

1 Like

rooUPnP is out with a test license FREE OF CHARGE :+1: :+1:

rooUPnP: Finally a Roon Extension for UPnP Streamers - Roon Labs Community

2 Likes

installed 1.3.0 on a new pi zero and it’s working well as expected. perfect timing because I had just got the pi today.

I like the new formatting for the rotation sensitivity, the numbers make a little more sense to me.

Thanks for your time DrCWO!

1 Like

Hi I have flashed a new card with 1.3.0

i did relinquish my licence.

I am on Roon 1.8.

I cannot now see the extension in Roon.

I can see the device on the network and connect to it.

It worked perfectly before.

Have i missed something ?

thanks

David

When you are connected it MUST be visible in the Roon Extension settings.
Please check if you still the the rooExtend WiFi accesspoint.
If yes you are not connected to your WiFi…

@DrCWO About to set up rooExtend this weekend. Just to clarify: if you plugin an ethernet cable in the unit before starting it up, the whole section in the manual about the wifi becomes irrelevant?

I can see the PiZero on the network
I can connect to its web page via TCP/IP
I can’t see it in Extensions on Roon

OK, you are connected, great!

  • Please disconnect the Pi from Power.
  • Reboot Roon
  • Power up The Pi
  • Check if it is still connected in your network
  • Open Roon and it should be visible in the Extendions settings

Thanks

Can now see in Extensions

Really enjoying the functionality.

thank you again

1 Like

Roon server must be up and running BEFORE you start rooDial :+1:

This is exactly the way it is!

@DrCWO, I am having problems with v1.30. On my porch, the Surface Dial is working fine with the upgrade. In my den, the Surface Dial worked with the prior version, but now with v1.30, it will no longer connect — it flashes on and on — I’ve rebooted the pi0w and removed the batteries and rebooted the Surface Dial, both multiple times. All looks right in Roon — the den Pi0w shows up as unpaired, licensed.

So do I need to reflash the mSD card for my den pi0w or do you have any other thoughts? Thanks. JCR

Update: I did go reflash the mSD card and now the Surface Dial paired!

Remaining question: I don’t see any difference when selected 100, 68, 34, etc for volume sensitivity. Info from 100 to zero in a quarter turn on both Surface Dials. I’m assuming the smaller number should solve this, but what am I doing wrong? Thanks. JCR

Further update. The volume sensitivity switching is working. I guess the setup just needed some time to season itself. Everything back working well!

Hope you’ll consider the ability to switch between two DAC endpoints in a future release. Thanks. JCR

Got my rooDial up and running last night and just wanted to say it’s fantastic! The only weird thing I get is the Dial goes to sleep and doesn’t wake up unless I press it down. Spinning it does not wake it up. I didn’t think that was normal behavior but it’s not a huge issue.

Funny,
the two Dial I had until now also woke up spinning them. Seems to be an issue with the dial, never heared it from someone else. Best get a new one from your dealer.

Dear DrCWO,

I forgot to revoke my license before flashing 1.3.0 :frowning:
What can I do now?

Kind regards, Jan

Please send me your license key by PM

1 Like