rooDial a Wireless Volume Knob for Roon with Microsoft Surface Dial

Is part of next release, still working in my home :+1:t2::grinning:

1 Like

Has the speed that the dials rotation changes the volume changed with Roon 1.8?

Before it was great, now it is way to fast. I barely move the dial and it is jumping up in 5, 10, or more. Goes from medium level to off with a small movement. Makes it hard to turn the music down.

Remove batteries and retry please. Should work as it did before in 1.7.

I have followed all the instructions.
Pi zero

When I put the key in it reads:

Not Licensed in Red

Please advise

You may need to select the “License Action” dropdown just above where you enter the key, I missed that yesterday myself :slight_smile:

Yargi Thanks that did it…:slightly_smiling_face:

1 Like

Also having licensing problems… I had it working before, but now 2 things have changed:

  • Updated roon to 1.8
  • Installed new internet modem, so also a new Wifi ssid.

So I flashed the memory card again (v1.2.0), got it connected with Roon, but the license key doesn’t seem to work. After I select the License Action to read “License”, and copy/paste my key and click Save, it immediately returns to the Roon extension overview screen, still reading “not licensed”.

Tried it with Roon on Windows and Android, both same behaviour.

I’ve had the same behaviour occuring a couple of times, after the pi was restarted, p.e. because I moved it to another power socket.
Every time removing & inserting the batteries of the dial it worked ok again.

Have you revoked the license before flashing the memory card?

Aarrrgh I totally forgot to do that…

We have all done it…well many of us failed on this step :upside_down_face:

Everything seems to work now. I can see the R&L on the Extensions line.

However the volume remains resolutely at the same level.

Do i need to change something in device setup ?

Have you selected the zone you like to control :thinking:

By “Zone” do you mean the output device? ie DAC.

If so yes. I have a number to chose from.

The Roon CORE is a ROCK with a Hard Drive directly attached.

All devices a (apart from the PiZero bridge) are on Ethernet.

The Dial makes the line in Extension change from L-> R but the volume does not change

I now see what you mean by “Zone”

It needed setting in the Extension Setting dropdown !!

All working

Operator Error

Thanks for everything

1 Like

Awesome, that worked! Thanks

Upgraded to 1.2 today and latest Roon. Are the shortcut for pause changed? Volume respons but not the pause.

I did take a view on the shortcuts and it use a space based on the info in Roon, but the command in extension seems sending a P

rooDial does not send characters. The P means „Pressed“. What happens when you press can be customized in the settings of rooDial. There was no change in the Roon Extensions API in v1.8.

Thanks. I tried set short and long press to pause. Also double press. But music keeps playing regardless how much I hope for it to stop.

Since it respond to press, what is to try next? Any suggestions?

Double press