rooDial technical integration discussions

Oay, I can license fine, and I paired and the dial shows as connected, but I don’t get L or R, and it doesn’t change the volume. I’ve revoked the license for now whilst we troubleshoot.

Thank you guys for testing.
That was really a very important step to improve the usage of rooExtend on Pi3 and Pi4
Thank‘s for your friendly support :grinning::beer::grinning::+1:t2:

In the Beta there is. Button on the rooExtend.local website at the end of the page. It resets pairing and WiFi so you can restart without reflashing now.

Happy to help. I assume the stein means your sending beer? :grinning:

1 Like

In Corona times only virtual sorry :stuck_out_tongue_winking_eye:

1 Like

I have configured the rooExtend with the lifetime license and let the RPi get its power from my computer. After I was done with the configuration, I’ve moved the RPiZeroW into my IT rack and let it get the power from a RPi 4 which runs Home Assistant server. The rooExtend was not discoverable by Roon, so I assume my RPi 4 doesn’t give to RPiPiZeroW enough power.

Moving back the RPiPiZeroW into the USB port of my Mac (to get the 5VDC supply), the extension has been discovered by Roon. Now here it comes the problem: the Microsoft Surface Dial appears to be connected, but it does not send the commands to Roon.

So what I’ve had to do was to remove the batteries of the Surface Dial and insert them back, then the dial responded as usual. Is this a known issue?

just to get you right:

  • You got rooDial running anything fine
  • You turn off power
  • you turn on power again
  • The rooDial extension in roon says “connected” but no action if you turn the Dial
  • You take batteries out of the Dial
  • You reinsert them
  • rooDial workes as it should.

Is this the right description of the issue?
Please confirm

Yes, that is correct. It happened to me only once, as I could not reproduce the fault afterwards and I don’t know what triggers it. Perhaps there is a sleep time of my Microsoft Surface Dial which I didn’t took it into consideration. What I can recommend here is to test different scenarios and understand when/if the dial enters in sleep mode.

Also, there is perhaps a 2mm free moving space if I lift the aluminum wheel from the battery compartment while the Surface Dial sits on the table. Do you experience the same?

Regarding the mechanical design, I wish that the base could be a bit heavier.

What I have on my Microsoft Surface Dial on its back is Model 1756, manufactured in 2018 and the code 2WS-00006 (lot no: 1810 written on the box). I guess that this last code with 2WS is the market code (mine is for Scandinavia with instructions in Danish, Swedish, Sami, Norwegian and Finnish).


  • sleep mode is quite clear, it happens after five minutes, but the dial reconnect happens so quickly that you don’t even notice. What you wrote is ore as a “no more waking up” condition…
  • The 2mm is also with my Dial
  • On my box I can reasd 2WR-00002 Lot 2042 no idea what is means. But I bought an other Dial but I gave it away and it feels smouther turning ist.
  • My instructions are in English, German, French ans Netherlands


1 Like

Mine too… and wake it is quite instant but if you just do a quick press to start play it might not get it every time tho mine seems to manage ok… I’m still on 1.1.1 and other than the zone sorting (dont really change zones much) I cant see any reason to risk an update yet.

The main benefit of updating was, for me, the Dial now obeys the volume limits set in Roon. There have also been a couple of bugs squashed.


While I have some endpoints that this would be a good to have, volume restricted endpoints are not where I like to use my dial. One other thing is that I have no issues with this extension interfering with other extensions that also allow the same zone to be controlled like my OSMC remote on Ropieee that also my wife uses on her desk to control the lumin zone.

In my main use area there’s a pair of electrostatics rated at 100W driven by a power amplifier output 318W, limits are essential for me.

1 Like

@DrCWO: I am now installing the 2nd Raspi with another MS Surface Dial.
One question here: I have one Wifi (mesh) in the whole house.
When setting up the 2nd Raspi, it does not appear in the Roon - Extensions (Erweiterungen) menu.
Do I have to switch the 1st Raspi off while I am installing the 2nd one?

Thanks in advance!

Update: both setups appear in the settings of roon and do not interfere with another.
2 setups - 2 licences in one Wifi. It works.


in an mesh you may run in trouble if you have more than one accesspoint with the same SSID!
rooExtend does roaming. This means: If the signal of two accesspoints is received by rooExtend with the same volume, rooExtend may switch between those. This can lead to disaperaring and reapearing extensions in roon.

Thank you for the reply. Ok, I understand.
Anyway, in the first tests both dials respond as they should (I did not use both systems at the same time yet).
I have to watch the function carefully.
Is there anyone with experience with a similar setup?

No, only the roaming experience.
You can use both Pis in parallel supporting two different zones with a Dial for each.
This works fine :slight_smile:

In my network, I have 4 fritzboxes (one Master, three slaves) running one wifi-mesh. I have two dials and two rpi with rooDial. All running perfectly.


Hi @DrCWO ,

I am having trouble having the Raspberry Pi connecting to my home network. After the I select the network, enter the password and the tool restarts, It doesn’t look like it’s connecting. The wifi name is still clickable. I am using your latest image file.
There’s no extension appearing under Extensions as well (I’m on Roon v1.8)

Could it be the wifi name having an & in it?

Update: I created a guest wifi without the “&” in the name, and it looks like rooExtend managed to connect to that. But as that guest wifi is isolated from my network, it probably can’t find Roon, so no extension yet.

Would you please confirm if this is a bug when you have a chance?