rooExtend – The easy start with Roon Extensions

Not really, sorry

Hi @DrCWO I updated both of my pi 4s to v2.3.1 and one of them seems to have an issue…
One wouldn’t start, couldn’t open IP in browser and extension would not start in Roon until I unplugged the USB connection from my DAC. After unplugging the extension starts and I can plug my dac back in and it seems to work, but sometime later it will disappear again.

This setup was working without issue under the previous version. I check the logs and you can see it’s having an issue with USB. My other Pi does not seem to have an issue with the Holo dac that it’s connected too.

Aug 17 02:25:33 rooExtend rooExtend[15662]: rooExtend 2.3.1 started…
Aug 17 02:25:33 rooExtend rooExtend[15662]: Config Path: /config.json
Aug 17 02:25:33 rooExtend rooExtend[15662]: Hostname: rooExtend
Aug 17 02:25:33 rooExtend rooExtend[15662]: Ethernet: connected, stop WiFi
Aug 17 02:25:34 rooExtend rooExtend[15662]: Got language: US
Aug 17 02:25:34 rooExtend rooExtend[15662]: Got timezone: America/Los_Angeles
Aug 17 02:25:34 rooExtend rooExtend[15662]: Set timezone: Success
Aug 17 02:25:34 rooExtend rooExtend[15662]: Restarted: true
Aug 17 02:25:34 rooExtend rooExtend[15662]: Has Bluetooth: true hci0 UART
Aug 17 02:25:34 rooExtend rooExtend[15662]: Audio device: Ayre Acoustics Ayre USB Interface
Aug 17 02:25:34 rooExtend rooExtend[15662]: Caught exception: TypeError: Cannot read property ‘interfaces’ of undefined
Aug 17 02:25:34 rooExtend rooExtend[15662]: Exception origin: uncaughtException
Aug 17 02:25:35 rooExtend systemd[1]: rooExtend.service: Succeeded.
Aug 17 02:25:45 rooExtend systemd[1]: rooExtend.service: Service RestartSec=10s expired, scheduling restart.
Aug 17 02:25:45 rooExtend systemd[1]: rooExtend.service: Scheduled restart job, restart counter is at 1840.
Aug 17 02:25:45 rooExtend systemd[1]: Stopped rooExtend service.
Aug 17 02:25:45 rooExtend systemd[1]: Started rooExtend service.
Aug 17 02:25:46 rooExtend rooExtend[15898]: [210B blob data]
Aug 17 02:25:47 rooExtend rooExtend[15898]: [169B blob data]

Just an update, but I think it seems to be ok now. I have to let the Pi boot completely without the usb from the Ayre dac connected. Once done booting and extensions are running I can connect the dac and it seems to be stable. I’ll note that it does not say that an audio device is connected on the RooExtend home page as my other Pi does with the Holo dac, but Roon bridge is working and sees the Dac.

I spoke too soon. RooExtend box connected to Ayre dac disappeared again. Extension was not running and could not reach homepage at IP address. Green light no longer flashing. Had to unplug dac, and the extension came back online within 20-30 seconds or so.

One thing I’ll note is that if I start the Pi with USB dac connected, the red status light on the Pi stays on the entire time. If I boot the Pi without the dac connected then the red status light goes off and has just the blinking green light after all booted up.

@DrCWO - Are you still hosting v2 on Google drive? I only see 2.3.1 available, but I need to roll back one Pi as the extension keeps shutting down. Roon Bridge continues to work, and I can play to the dac, can’t reach rooextend and use the RooDial without reseting the usb connection. Any time Roon is shutdown/restarted, RooExtend goes through the pairing process again and tries to read the USB dac as in interface and gets stuck in a loop.

Roowatch stopped working on my Apple Watch. The licence manager disappeared from the extensions. If I call up the menu page on the pi and click on my wi-fi nothing happens. No green button. What should I do @DrCWO ?

While I am waiting for the wifi to connect, I can see the extension pop-up briefly before disappearing. If I click on Enable it displays the message “Looking for USB Stick to restore licence” or similar. Then it disappears and does not connect. Please advise.

Hi @William,

  • you started with afresh SD-Card?
  • What Pi are you using?
  • Which version of rooExtend?
  • Anything connected to the Raspberry?
  • Ever tried with Wired Ethernet?

I need more information to help you.
Best DrCWO

The pi is hardwired by Ethernet. When I call up the menu it wants the wifi.
No I did not start with a fresh SD card. It just stopped working.
Nothing cconnected to the Pi, it’s dedicated for RooExtend.
Where do I see the version?

Sorry panic over, I came back from shopping and the extension was there. So I could enter the licence key again and it’s up. Thanks

1 Like

Dear customers,
I uploaded a hotfix of rooExtend called v.2.3.2.

The following bugs have been fixed:

  • Nuimo connectivity now works as in v2.2.2.
  • Nuimo heartbeat issue keeping the heartbeat on even if playback stopped.
  • Streaming from iPhone pressing STOP also stops Roon.
  • Switching playback on iPhone between different applications also should be fine now.

I apologize for the inconvenience regarding the connection issues with the Nuimo.

For those of you still on v2.3.0 or v2.3.1.

  • Enter a USB stick in your Pi to save your license keys AND your individual settings.
  • Plug the new SD card PLAUS the USB stick into your Pi
  • Now Boot the Pi
  • In Roon/Settings/Extensions wait until the License Manager apears and enable it.
  • Watch the status line of the License Manager and remove the USB stick if you were told.
  • After a restart of rooExtend all your licenses and settings should be in place again.
  • Now enable all the other Roon Extensions and you will be fine.

Best DrCWO

Some feedback from a very happy customer - I have rooDial running with a Pi Zero, and everything else including Nuimo, Watch and Play on a Pi 4. Couldn’t be happier. Everything works perfectly, and RooWatch is fantastic, voice search for music is so good! DrCWO your attention to detail and care for your products and customers is second to none. Thank you :pray:


I somehow missed that settings are now saved and restored via USB. This is really fantastic. Thank you!

1 Like

I actually came to write an almost identical “Thank You!” but @chris.mi said it so well that I’ll just quote him. rooExtend and the dials and watch experiences make using roon an absolute joy. Thank you!

If you’re interested in supporting another device, I would love to see you support the Lutron Caseta Pico for Audio which you can see here :

I’m not sure the extent to which the Lutron Caseta product line is available outside of the US but it’s popular here among home automation enthusiasts. The Pico for Audio supports Sonos integration which suggests that it would be possible to integrate with Roon. I think Lutron may require a codified partnership to develop an integration, which might be a hurdle. The little remotes are great, though, and while using them requires a hub, you can use many remotes with a single Lutron hub.

Just an idea :slight_smile:

Thanks again for the fantastic products.

Hi @gTunes,
thank you for your positive feedback. I love that so many people like the things I make.
It makes me so happy :+1: :grinning: :grinning: :grinning:

But what a hell, each company makes it’s own hubs, RF standards and contracts to maximize profit and to retain customers as much as possible. What a waste of resources (human, natural, energy) and the planet will be inundated with garbage. What a shame :disappointed_relieved: :disappointed_relieved: :disappointed_relieved:

It took so long for the EU to standardize USB power supplies to reduce e-waste. But hubs are still not standardized :face_vomiting:

I guess the reason why Lutron is not popular here in the EU is their “silent” radio frequency. To use it is probably forbidden in Europe.

Please forgive my frustration. Wouldn’t it be much nicer to have a standardized API in one standardized hub that all manufacturers could use without license fees. Maybe someday in a better world…

Best DrCWO

1 Like

I really like the new display via HDMI. It’s much more convenient than display over Chromecast (which was constantly timing out).

But I have one suggestion and one question.

On 4K TV by default Roon display is rendered within a black frame. That can be easily fixed with two entries in /boot/config.txt:

#uncomment this if your display has a black border of unused pixels visible
#and your display can output without overscan


Could you add an option to set those attributes or add them by default (I don’t know if they have any side effects on non-4K displays)?

And the question: Do you know what’s the max resolution of Roon display? I tried to make it 4K by changing hdmi_mode but failed to actually get anything above 1080p.

Please see my answer here:
rooPlay - From LP, CD and iPhone to Roon - Audio Gear Talk - Roon Labs Community

So the new apple watches are available to order…lets hope the rooExtend will work on applewatch 9.0 and especially the new watch ultra

@Klaus_Engel is back from holiday and will check it :+1:

@DrCWO (my) Problems with Roon Display on TV.
For 2 days I have positioned the Raspberry Pi4 near my TV (Samsung TV UE65) and can therefore use the HDMI output. Basically everything works, in the audio area (roo6D) there is no problem. But playback via HDMI has a life of its own. What am I doing:

  1. I start Roon Rock
  2. Almost at the same time I start the Pi4 with rooExtend
  3. I start my TV

The problem: I have no display icon in Roon


Now I switch to the HDMI input on the TV, there I see that the gray Roon image display is activated. So obviously rooExtend recognizes my TV.

But I still don’t have a display icon in my Roon interface. Nothing has changed. So I can not activate the image playback.

Now I unplug the power supply from the Pi 4, wait 3 seconds and reconnect the Pi4 to the power supply. On the Samsung TV I can follow the start of the operating system.

And now I also have the display-icon available in the Roon interface and can activate playback.


Second try. All devices are switched off. Now I change the boot order of my devices.

  1. I start my TV
  2. I start Roon Rock
  3. Almost at the same time I start the Pi4 with rooExtend

Nothing changes. I don’t have a display icon in the Roon interface.

Third try. All devices are switched off.

  1. I start my TV
  2. I start Roon Rock
  3. Almost at the same time I start the Pi4 with rooExtend
  4. While the operating system of the Pi 4 (root Extend) is starting up, I switch to the HDMI input on the TV and can thus follow the start of the operating system. And now that the Pi 4 and rooExtend are up and running, I also have the display icon in the Roon interface.

Apparently, rooExtend not only needs an already activated TV when starting, but also an already activated HDMI input. Only then will the display icon be activated in the Roon interface. In plain language: No matter what I do, I have to start the Pi 4 on the TV with the HDMI input activated. Only then do I have the display icon in the interface and can use it to activate the image output. That’s sub-optimal for me.

It also doesn’t matter whether Roon Rock and rooExtend are already running (continuous operation). When I turn on the TV, the display icon is missing from the interface. Switching to the HDMI input doesn’t help either. No display icon. As already mentioned, I always have to restart rooExtend with the HDMI input activated so that the display icon is available.

Can this be corrected?