Room losing control of Sonos

@support
Hi,
I’m having constant issues with Roon losing connection and control of my Sonos amp and Sonos connect. Today it’s particularly bad with play being interrupted 5 minutes or less. I can see it still playing in the zone on Roon controller, then play stops and I have to restart it. Please help! Thanks

Hi @Josh_Eisen,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Hi @noris
Network:
Linksys EA9500 router connected to FIOS Quantum Verizon modem gigabit internet 940/880gbps.

System:
Mac mini late 2018 6-core i7 w/ 32mb RAM running latest version of OS Catalina 10.15.5 - 5ghz wifi line of site about 15 feet away.

Roon Connected to:
Sonos Amp via WiFi
Sonos Connect connected via ethernet to Linksys. Connect feeds to Cambridge Audio DACMagic to McIntosh MC2120 out to speakers.

Roon loses control of audio devices. Oddly this happens more with the wired Sonos Connect than with the wireless. This happens during playback and not with any discernible consistency. Most playback is after business hours when the computer I’m using as my core is not being used for anything else. However, even when using Roon during work hours, sometimes it works fine and other times it does not, and doesn’t appear to have any correlation with computer activity. After really bad day of Roon losing connection to Sonos every few minutes, the following day it was working much more consistently, though, like I mentioned above, it seemed to be having more trouble with the wired Sonos than over WiFi.

Let me know if you need more info.

Thanks

Hi @Josh_Eisen,

Thank you for providing that additional information.

Do you know if the sample rate of the track played is related to when the issue occurs? For example does it occur each time you play 96kHz + content? Or when playing MQA/DSD?

If you try to play to your Mac’s System Output zone for the approximate amount of time it takes to affect your Sonos, do you notice any issues on this zone?

Hi @noris,
The sample rate appears to be 96kHz most of the time and doesn’t correspond to when it drops out. yesterday and today I can’t get the Roon stream to play through Sonos at all. If it does, it only comes through the wirelessly connected Sonos Amp, not the wired connection to the Sonos Connect - not sure how that makes sense other than my Roon core is wirelessly connected to my network - could that make a difference? Roon core plays through my iPad, which is wireless, and the system output without interruption so far. What can I try next - the Sonos is my only connection to my music system in my house. Thanks

The system output did stop mid-song after playing for a good 15 minutes. But I can restart it immediately whereas the Sonos only shows that it’s playing in Roon but no sound comes out.

What I also notice is that I can stream from the Tidal app directly to Sonos without any interruptions, and when I stream from Qobuz from within the Sonos app I don’t have any issues. (With my level of Qobuz I can’t stream from teh app to Sonos)

Hi @Josh_Eisen,

Having the Roon Core connected via wireless can indeed cause issues like the one’s you’re seeing, especially if the issues are occurring on System Output as well. I would suggest connecting the Core via Ethernet (even as a test) to see if it helps with the issues.

A post was split to a new topic: Sonos - lost control while playing through Roon