Roon 1.2, ASIO/ALSA drivers and Native DSD [fixed]

I followed the instructions in the wiki on how to set up my e28 with asio drivers. PCM works fine, DSD doesn’, it gets down converted to PCM between the linux roon server (ubuntu 15.10 server) and mac mini roon bridge (OSX 10.11.4). Doesn’t sound too bad, but just isn’t DSD.

The playback settings for it are

Under the general settings, volume control is set to “Use exasound core audio” with a resync delay of 1s, as per the instructions.
If I go back to core audio drivers and DoP all is well roon plays back DSD as DSD.

Any ideas?
Thanks Paul

I think I know what’s happening. Try this:

Open the settings screen
Flip the DSD Strategy to one of the other values
Flip it back to native
Click Save Settings
Try Again

I think there’s a bug with setting up default settings.


Thats fixed it. I switched it over to DoP saved the setting and tried to play something no sound. Switched it back to Native and bullseye. I’m now seeing DSD on the DAC and all purple signal path.

Shut everything down and reopened roon and the DAC and DSD is playing properly.


Ok, thanks. We’ll get it fixed for real in the next release so others don’t run into the same issue, but unless you set up a fresh install, I don’t expect you to come across this again.