Roon 1.2 refuse to play DSD with PS Audio ASIO driver [fixed]

Currently using PS Audio Directstream DAC, after upgraded to Roon 1.2, Roon refused to play any DSD material with ASIO driver but ok with WASAPI to play in DSD over PCM, but once played DSD material with ASIO driver in DoP, will stop immediately and returned no audio device found, but okay if convert DSD to PCM mode.

Tried the trick of save change save of DSD mode didn’t work here.

I pulled a DirectStream down off the shelf and plugged it in to take a look, and…DSD is working great for me on 1.2.

These are my settings with the ASIO driver:

These are two DAC-specific quirks we are aware of for this one:

  • The volume-control built into the USB interface module on the DAC is not bit-perfect, so the volume setting on the computer needs to be at 100% for DSD playback
  • Sometimes, we’ve seen the DAC get into a state where DSD playback will not work, and power-cycling the DAC itself fixes the issue.

A couple of troubleshooting steps that I suggest trying:

  • Go into Roon’s settings, press “Restore Defaults”, and then set them up like mine.
  • Power cycle the DAC using the switch on the back near the power cord
  • Go into the Windows Volume Mixer and ensure that the volume for the DAC is set at 100% there.

I should note that my DirectStream is fully updated and using PS Audio’s latest drivers. If all else fails, and you haven’t taken an update in a while on that end, that might be a thing to try.

If that doesn’t work, I’m sure we’ll get to the bottom of this. Just need to figure out how to get the failure happening in front of me. Thankfully, in this case we have the gear–that’s often the hardest part.

Apologies…I was mistaken. You are right–this is broken in the current 1.2 build.

I couldn’t see the failure because we fixed this yesterday as part of another support issue, and I was running an internal build that has the fix.

This will be all good for the next one! Sorry for the trouble.

At lease it can be fixed on next build and not my setting problem, as my other device work with the save change save trick while just my DS won’t no matter how many times I tried.

This should be fixed in Build 128. Let us know if you’re seeing otherwise.