Roon 1.3 & multichannel - surround speakers mapping (?)

I just started with roon 1.3. I was waiting for it to have the multichannel, but as of now is a big delusion.

I’ve an exasound e38 (with PlayPoint) and a merging nadac MC-8. Both of them are working wonderfully with JRiver MediaCenter.

I’m very intrigued by the roon interface, so I tested it for 2 weeks when it was still vers. 1.2 but I decided to wait for the 1.3 and the multichannel support.

Well, it just came, so I purchased roon (no way to try it again since I already did it last year with the 1.2) and set it up for multichannel listening on my PP/e38 and MC-8 in Win10.

My real problem is the mapping of the channels. I’m using my suff it with MC, HQPlayer since some time, but I had a big surprise discovering that roon decided to map 7.1 channels in a different way than others. So, in my home setup, I’ve the RL/RR (rear L & R) that are working in place of the SL/SR (surround L & R). Why? I cannot change cabling of my speakers for roon only and what about when I use MC or HQ Player? I do not see as of today any way to re-map the rear speakers in roon to fit a setup that is almost standard and it is working with all other software.

I also was surprised that roon configuration with 5.1 channels is currently mapping the 2 rear speakers with SL/SR, so this will fit my installation, but I do not want to use in roon only 5.1 speakers, since I’ve 8 speakers. Also if the music available in 7.1 is very few, I do not want to change roon configuration based on the music I’ll listen. All the other SW I’m using they are properly addressing the 7.1 speaker configuration, not sure why roon is not.

I would really appreciate help from roon team / community.


Have you checked your speaker mapping configuration in Win setup? Apparently, Roon sees that (although JRMC seems to ignore it).

I’m not sure which win setup configuration I’ve to check.
I’m using exasound e38 with PlayPoint, so no drivers are involved in win 10.
I’ve the 2 channels card on my computer and the Denon AVR card (7.1) but they are not used by roon. The 7.1 is configured with RL, RR, SL and SR as surround speakers.

btw, windows does not allow me to re-map any speaker, also I’d like to do so …

I do know that Win10 audio setup affects Roon and that is what I was asking.

Our mappings are documented here.

7.1 in Roon looks like this:

  • Left
  • Right
  • Center
  • LFE
  • Left Rear
  • Right Rear
  • Left Surround
  • Right Surround

This is the closest thing to a standard that exists for 7.1. JRiver states that they use the same mapping in this thread after they came to the same conclusion we did: that this ordering is the most conventional.

HQPlayer also respects the same order as their default–as you can see in the channel mapping screen I pasted below, which, in its default state, maps ports 1-8 in that order.

Since you seem extremely sure that we’ve got this wrong, I decided to be really positive that we’ve got it right before responding to you, so just now:

I got out the PlayPoint+e28 and a set of 7.1ch test files that each play a test tone to one speaker–to make it very easy to hear where things are being mapped.

First, I used the PlayPoint + e28, and confirmed that Roon is sending things to the speakers according to that map.

Then I detached the e28 from the PlayPoint, and plugged it into a Windows machine running HQPlayer. No-one has ever touched the channel mapping settings on this installation.

With HQPlayer, the same tones routed to the same ports on the back of the e28 as they did with Roon+PlayPoint.

Then I shut down HQPlayer, opened up JRiver MC22, set it for “7.1” and “no upmixing or downmixing” and found that JRiver behaved identically.

Then I re-did the three tests using some real 5.1 material to confirm that SL/SR were mapping to channels 7 and 8 as expected, and that channels 5 and 6 were silent. The same content came out the same channels in all three pieces of software.

This is what my settings look like in JRiver and HQPlayer.



Finally, though I did not use this “Order Channels” feature buried in JRiver’s Parametric Equalizer, I did open it up really quick to double-check their defaults in case that forum thread was just out of date and they’ve changed their mind since then. And it isn’t–the output order that they use by default is exactly the same one that we do:

In conclusion:

Roon does not have a facility for arbitrarily remapping channels in any order you like, but we do respect the same defaults as everyone else.

I strongly suspect that you have plugged your speakers in in an unconventional order, then changed the settings to compensate in JRiver and HQPlayer instead of just sticking with their defaults. Every indication I can find suggests that if all three pieces of software were left in its default configuration this would have “just worked” for you.

In case you want to try to replicate my results, these are the test tones I used. If you use them, turn the volume down–they’re harsh. The “real material” was “Quiet Winter Night” in 96kHz/24bit FLAC and MAGNIFICAT 4. Et misericordia in 5.1/DSD64 from the test bench.

1 Like

Hello, Brian. Is the mapping for a 5.1 surround format the same as the 7.1, minus of course the 2 rear channels ( in which case, your test tones should work well to test the 5.1 format)? Thanks. JCR

Yeah, 5.1 is L R C LFE SL SR, so exactly–7.1 minus the rears.

Interesting, I never did any change or tweak to the speakers configuration. It worked ok since day one in HT, as well as, for music.

I’m travelling until the end of the week, so during the week end when I’ll be back at home, I’ll do exactly the same tests you mentioned in your email. tnx for the support.


ok Brian, I’m back at home and I did some tests based on your post. Let me recap:

  1. my surround and back speaker were wired as follows: #5 SL, #6 SR, #7 RL & #8 RR - to fully clarify, for me the SL (surround left) and SR (surround right) are the big (normal) surround speakers used also in HT that play when there is 5.1 audio, while RL (rear left) and RR (rear right) are the small back surround that are playing in HT only when there is 7.1 audio effects
  2. I played in HQPlayer, Roon & JRiver your WAV files and the surround speakers and rear speakers were inverted (side sourround with rear ones)
  3. So, I rewired as the back speakers as follows: #5 RL, #6 RR, #7 SL, #8 SR
  4. I did again the listening with the WAV files and it was ok
  5. I checked also in windows the the speakers were properly mapped. I right clicked on the speaker, then playback devices, then the HT amplifier, and I play the test sounds and the speakers mapping was ok
  6. I listened with roon the ripped SACD Dark Side the Moon (5.1 channel version) and the SL & SR were playing ok while RL & RR were muted (NADAC - no way to specify the channels since it was greyed, PP/e38 7.1 channels)
  7. I listened with JRiver the ripped SACD Dark Side of the Moon (same as #6) (here I start to have issues …) and the surround sound is coming only from the RL & RR, while the SL & SR are muted (!!!) - the JRiver “SP Studio” dialog box is configured as your post (as well as, I did not change any order for the speakers as per the parametric equalizer that was never configured) for the NADAC, while for the PP/e38 there is no way to change anything since the e38 settings are managed through the PP (so, I do not know how to change them …) - anyway, the listening results are the same for the NADAC, as well as, the PP+e38
  8. I listened with HQPlayer the ripped SACD Dark Side of the Moon (the same as #6) and the surround sound is coming only from the RL & RR, while the SL & SR are muted (???!!!) - the ASIO channels mapping is the same as per you post while listening with the NADAC - anyway, the listening results are the same also with the HQPlayer networked with PP+e38
  9. I’m quite sure I did not change anytime the speakers configuration for the JRiver and the HQPlayer and when I has the original speakers configuration as per point #1, I was listening in both cases the Dark side of the Moon properly (the surround music was through the SL and SR)

In summary, the speakers configuration I had before (see my point #1) was working ok with JRiver and HQPlayer but not for roon and it was not matching the windows 7.1 speakers configuration (assuming that the back side speakers should be properly mapped with the SL & SR, …), as well as, the test tones you provided, while, with the new configuration (see my point #3), it is working ok with roon, it is in line with the windows 7.1 speakers configuration, but it is not working with JRiver and HQPlayer … So, it seems that in some way JRiver and HQPlayer on my computer are using a differnt speakers configuration but I don not know why and how to change it …

At this point I do not know what else should I do to get all this working with roon, as well as, with JRiver (I currently I’m using the version 22) and HQPlayer …

Any suggestion?

Swap the channel mapping in JRiver and all should work the same.

It is not so easy.

The channels swap is working only with HQPlayer, when using ASIO - so with the NADAC only, but it will not work with the PP+e38 (or at least I do not know where is with the networking audio the settings about channels mapping.

While with the JRiver channels swapping is ignored - the only place from were I assume it could be done it is in the DSP Studio, the Parametric Equalizer setting a filer to swap channels. Am I right?

I believe so. I think that bypassing the PP would let you do it but that might upset the NADAC.

I’m starting to get a feel for the problem you’re having. It sounds like when you’re playing 5.1 material in HQPlayer or JRiver, it’s outputting using a 5.1 layout, instead of mapping onto your 7.1 layout.

I think that’s why my 7.1 test files mapped as-expected but 5.1 media is not doing that.

There is a secondary issue, I think, which is that the PlayPoint is using a different hardcoded layout for its UPnP support (that’s how you’re using it with JRiver, right? I’m not too familiar with JRiver’s networked playback support).

What’s weird is that when I played 5.1 files using the above configurations, they were being mapped onto 7.1 as I’d expect.

It would be good to confirm that using the exact 5.1 files I played you’re getting different results.

Here’s a question: do you use 7.1 for music at all? I ask because there is very, very little 7.1 musical source material out there. If the answer is “no” one thing to try might be to put the speakers back the old way and use the 5.1 mapping in Roon. I think that would make things like up with the speakers as you had them wired originally.

I’m contemplating what it would mean to support an alternate 7.1 layout that swaps rears and surrounds…

I’m in the trial phase of using Roon, having waited until 1.3 because multichannel music is important to me. I now use JRiver Media Center, which deals with multichannel music via HDMI correctly in my experience. That is, when I play two-channel music my Anthem processor sees the signal as 2.0 channel audio and treats it accordingly. Thus, I can listen in stereo, in Dolby Surround, in DTS NeuralX, or in Anthem Music, a subtle up-mixing mode that I often like to use. When I play multichannel music the processor sees it as such and treats it as such. But in Roon (using ROCK) my options for HDMI are to select 2.0, 5.1, or 7.1 channels. Apparently If I select 7.1 Roon always puts out 7.1 channels, with some channels silent if the music has fewer channels. My processor always sees this as a multichannel signal, so the Anthem Music upmixing mode is not available. I can get it to upmix two-channel music by changing the HDMI output to 2.0, but then it won’t pass multichannel music.

This is very unfortunate, and potentially a deal breaker if true. By the way, all of my multichannel processors and receivers work this way. The upmixing modes I want to use only work with two-channel signals.

Have I got this wrong? Is there some setting I’ve missed or some way to get it to work the way I want?

[quote=“Steven_Goff, post:15, topic:20182, full:true”]
Apparently If I select 7.1 Roon always puts out 7.1 channels, with some channels silent if the music has fewer channels. [/quote]
What is your “Multichannel Mixing Strategy” setting in the Playback tab? On my HDMI output I have “Downmix as Needed”, and this seems to handle all 2.0 and 5.1 material correctly - upmixing the 2.0 material to spread to the other channels as appropriate for my Denon 3808 AVR.

I too have downmix as needed selected. This has no effect because nothing is ever downmixed. The Roon folks have said that if two-channel music is played using a 5.1 or 7.1 HDMI output the results is that 5.1 or 7.1 is sent out but all but two channels are silent. My Anthem processor and my Denon receiver interpret this as a multichannel signal and won’t apply upmixing meant for two-channel sources, including Anthem Music and Dolby ProLogic IIx.

Ah, you’re right - stereo material just gets fed to L + R + LFE. If I want to have all speakers being utilised for such material, I push the “7 Channel Stereo” button on the Denon.

Yes, but that is no good. I for one do not want stereo output over all my channels. I want Roon to send out a proper stereo signal so that my AVR can do its magic and remix it using Dolby Prologic etc.

Roon does send out a proper stereo signal. As it says in the KB.

This thread dates from June 2017. In July 2017, a new release of Roon changed the behaviour to what is now noted in the KB.

Send stereo/mono content as 7.1

Roon 1.3 Build 242 contained a change to our default stereo/mono playback behavior when talking to multi-channel devices. Previously, the full channel layout was always sent, with silence sent to unused channels. Now, stereo/mono content is sent using the “2.0” layout, and only multi-channel content uses the selected layout. This setting allows users to revert to the old behavior if desired, but we expect that the default will work for the great majority of use cases.