Roon 1.6 won't start under OS X Catalina

Core Machine (Operating system/System info/Roon build number)

OSX Cataling, Roon 1.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon Bridge on different device

Description Of Issue

After upgrading to OS X Catalina, Roon would not start (I have my music library on an external disk). As a work around, I ran Roon as root from the command line (this was before the recommendation came out not to do this).

Since upgrading to Roon 1.6, Roon still spins endlessly when starting up. It does work when I run as root from a shell. Reinstalling app did not make a difference.

Do you have an suggestions for how I can get back to normal behavior under OS X Catalina and Roon 1.6?

What Build of roon are you using? Maybe download and install the latest version.

Build 475 (says it is the latest version)

You didn’t act in any of the work around that were posted and then pulled down? Like…log in as admin user and doing things at the command line might have been one of them…anyway someone from support will be along to assist in due course…granted it’s a weekend so be patient :blush:

Hi @Ray_Ghanbari,

Since you have started Roon as root, this may have caused some issues with the way the database is accessed. I would advise creating a Backup of your Roon database and then starting Roon fresh to see if this helps:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify if the fresh database works for a day or two
  • Restore from the database backup you created

Worked like a charm! Thank you very much!

1 Like

Glad to hear that the instructions worked @Ray_Ghanbari, hope you have a great day!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.