Roon 1.7 + BDP-1 Networking Issues

I posted this on the Bryston AudioCircle forum:

With the latest stable build, I am experiencing network discovery and access issues with the BDP and Roon Version 1.7 (build 511) stable.

When running my BDP-1 in MPD mode, everything works great.

In Roon mode, however, the network stack on the BDP goes berserk. For example, repeated reboots of the BDP and my router/switch are necessary to access the Manic Moose user interface (switching back to MPD mode from Roon mode took hours of trail and error).

When in Roon mode, I cannot access the Manic Moose UI using the known IP address (DHCP assigns an IP address to the BDP-1 via its MAC address in my router). I can ping the device, but port 80 (http) connections are refused. Additionally, in Roon mode, I cannot connect via SSH into the BDP; again, connection refused. And, as expected, resolving bryston-bdp-1.local is very spotty.

Switching back to MPD mode (again, this required lots of web UI access attempts and “getting lucky”), all of the above clears up - no problem accessing the web UI, resolving the Bonjour address nor any issues accessing SSH.

One other symptom: when you can get into the Manic Moose UI in Roon mode, I see a zillion, stacked pop-ups on the bottom about “Syncing Qobuz Favorites”. Annoying.

My guess: the RAAT service on the BDP is not initializing properly on boot-up and is blocking/interfering with the initialization of other TCP services (e.g. http, ssh). Note that there is NO change in this behavior, regardless of whether or not I have Roon Core running on my Mac Mini on the same subnet.

And, yes, this is consistently repeatable.

I know Roon 1.7 has been out for some time, but I haven’t been using Roon with my BDP. Decided to switch back over and that’s when the fun began.

I am curious if any Bryston BDP owners using Roon are experiencing something similar.

I have a BDP1 as a roon endpoint… Works perfectly. Please make sure you have the latest Manic Moose firmware installed. That should resolve your issues.


S2.42 2019-12-02

I have exactly the same version you are reporting.

FWIW, I run a BDA-3.14, which combines the BDP-Pi and BDA-3 into one unit. No problems in Roon Ready mode. I’ve been able to do all the stuff you mention being unable to do.

One suggestion I have is, when you’re in the MPD mode and can access the GUI, try a reset to factory settings?

If that doesn’t work you might need to contact Bryston directly. I don’t know if you ever have, but it’s a great experience. Not a single phone tree anywhere, just actual live humans.

Good luck.

Syncing Qobuz favorites…hmmm…I should mention I use my BDA-3.14 only as a Roon endpoint. I have not enabled Qobuz integration with MPD, although my Roon is integrated with Qobuz.

Both of my BDP-1s are working fine with Roon.

I finally narrowed this down to rebooting the BDP-1 while the Bluesound Node 2i was running on the same network. Powering off the Node 2i stops this behavior.

And, yes, they are each joining the network with a unique IP address. But my guess is that something with Bonjour discovery is causing an issue with the BDP-1 when the Node 2i is active.

EDIT: Nope, I was wrong… problem is still there.

I finally did a “factory reset” on the BDP and that seems to have cleared up the problem. Who knows…

Does the “my bryston” web log in provide the same fixed ip address each time. I have two BDP-1s and the log in process is rock solid. By factory reset, do you mean firmware reset? If not, I would suggest you reupdate the Manic Moose firmware, even if its the same version. S.42 I think.

Factory reset wipes all settings and reinstalls the latest, stable version of Manic Moose.

My router assigns the same IP address to the BDP, based on its MAC address.

Something was going on at boot time that was preventing the BDP’s web server from binding to port 80 for listening; same with SSH. You could ping the box, but little else.

After some time I was able to slowly load the web interface. Based on my observations (seeing dozens of pop-ups telling me the BDP was syncing Qobuz favorites), I was suspect of a setting somewhere that was interfering with normal startup. Since I was already running the latest Manic Moose software on the box, and factory reset cleared up the problem, that seems like a good assumption.

Glad you resolved it. I once had a flakey internal card on one of the BDPs (which affected the database). I purchased a new card and downloaded the internal firmware which fixed the issues I was having with the database setup. It was a special square 4GB sd card of a type I’d never used before. Had to buy a cheap writer for it, but everything resolved after the new card insertion. I think Bryston sells the preloaded cards too.

You have to clean the internal cable connections once in a while. They get dirty/corroded and need to be cleaned. It displays an error message when that happens.

I added a vintage USB CD reader I bought off of ebay for $5. Internal AC power supply with a heavy case. Probably made in the 1990s. Works like a primitive BOT-1. No downloading, but plays CDs through the BDP-1 wonderfully.

1 Like

Yes… I am seeing the dreaded Error 09 and I think that is likely the cause.

When I setup my new 2-channel speaker system, I opted for a Bel Canto e.One Stream, as I wanted an all-in-one box with MQA support. I had previously tried out a review model and I was impressed with the sound and the Roon performance (i.e. flawless playback).

When the BDP-1 finally dies (or I get sick of seeing Error 09), I would love to replace it with a BDA 3.14. With my daughter headed to college next year, it might be a while before I am buying anything new/expensive for my head-fi table :grinning:

1 Like

The Error 09 fix will take you about ten to fifteen minutes to fix…a little deoxit, and you’re good to go. Most of the work is opening the unit.

1 Like