Roon 1.8 ASIO problems

Windows 10 (latest version) remote (not Core).
After update from 1.7 to 1.8 everything worked just fine. Problems started next day, when Roon suddenly stopped working with Denafrips Terminator DAC in ASIO mode. WASAPI mode works. Every other application also work in ASIO mode but not Roon.
Removing drivers and reinstalling drivers do not help, system restore also do not help. Reinstalling Roon also do not help.
Roon can see Denafrips Terminator ASIO device, but when I enable it - shown no audio device found.

Maybe some ideas what can I do? Also Other ASIO drivers work just fine.

Hi @Adri ,

Is the behavior the same if you try to temporarily connect the DAC to the Core?
I noticed you have ASIO4ALL, is there any change if you try to disable this?

Today things getting even weirder. Denafrips Terminator DAC stopped working in WASAPI mode, but ASIO mode started working.

Hi @Adri ,

Can you try to see if a RAATServer refresh helps here? You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Restarted Roon server, it solved problem. Now Dac works in ASIO and WASAPI. So I guess problem was on the Roon core side. Still strange before 1.8 version never experienced such problems.

Another day and problem continuous repeating itself, restarting Roon server helps, but need some permanent solution.

This RAATServer refresh need to be done on Core side or Endpoint device?

I have the same problem using USB to RME ADI-2 Pro.

Hi @Adri ,

Apologies for the trouble! We’re working on a solution to this and will keep everyone updated here:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.