Roon 1.8 to 2.0 Upgrade Stalled

I’m checking in to see how the support team is dealing with the Roon 2.0 upgrade. As you’ve seen from several users the upgrade reverted back to 1.8. On my phone I have both the 1.8 and the 2.0 app up and the good news is that it says it’s checking for an update now where it didn’t say that a few days ago. Any idea how long it will take to fix this? I have a Roon nucleus that’s hardwired to my Verizon router.

I don’t have a response for you and I’m sorry that you are without your music; but, I do like your choice of tunes.

Hi @Evan_McGlinn,

Please accept our apologies for the mishap with the automatic upgrade on RoonOS.

The fastest way to bump your Core back to 2.0 is to simply edit the Branches folder in your Roon database by following these steps. I’ve pasted them below, but they’re also linked here in our Help Center.

  1. Go to the /Data/ share (instructions) and create a folder called branches (case-sensitive)
  2. Download the following file: roon_2-0 (It should be named roon_2-0 (case-sensitive) and saved with no file extension)
  3. Copy the file into the branches folder previously created
  4. Rename the file to roon (case-sensitive) (instructions on how to rename files: Windows / MacOS)
  5. In the Web Interface, click “Reinstall” under Operating System

Sorry Connor, but this solution is not always working…tried more than once without any effect
Other suggestions?

Thanks Connor! It worked!

Sorry this solution seems overly complex and indecipherable to be of much help to me. I transferred to 2.0 without any major problems, then out of nowhere my core (on a Nucleus) has somehow reverted to 1.8 and I seem to be in a loop on every device (I can go back one page but when I click on connect I return to a page saying that my Core is on 1.8). What do your instructions mean “Go to the /Data/ share”? I can’t go anywhere in Roon at present except to this message that “one of your devices is running Roon Legacy”. I bought a Nucleus in order to avoid having to be too tech savvy. I either need more specific instructions about what you mean by “Go to the /Data/ share” actually means or (preferably) assurance that Roon is going to provide a fix to this problem in the very near future.


Perhaps this article may help:

Dave…I agree with you that Roon needs to do a better job in how they speak to their users. Not everyone is an IT expert. To make the file with Roon 2.0 you need to type this into your browser…


The “x” stand for the remaining digits in the Nucleus’ IP address. So yours might be something like…

You will be prompted to connect to the server and I used the “guest” option. From there simply make a “branches” folder inside the “data” folder and place Roon 2.0 inside that folder and then remain it “roon” and then follow the instructions on the Roon site. Please let me know how it goes. E

1 Like

Thank you very much for your help on this. It has eventually worked. It took me ages (because I am a tech ninny) but I got there in the end and it seems to have worked fine. I am back listening to music and I do not seem to have lost any data, playlists etc. So I am a happy camper again. Thanks very much for taking the time to help me with this - it is only when it fails that you realise just how much you have come to depend on Roon!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.