Roon 1.8 Update Stuck


I think I have a similar problem. I updated the version on my iPad first and when it tried to connect to the Nucleus it promtped me to update the Roon Nucleus to 1.8. I initiated the update and everything proceeded normally (download new version, started updating, etc.) and then it just got stuck. My two remotes (iPhoneX and iPad) are running version 1.8 and just get stuck waiting for the Roon Core (Remote Connection Waiting for Remote Core…)

I have rebooted my network and restarted the Nucleus a couple of times to no effect.

Also, when I log into the Nucleus directly it says the Roon Server Software is not running. When I click the start button it returns

“Roon Server could not be successfully restarted. Please try rebooting, or contact support.”

I’ve rebooted it without affect.

Interesting, it says the OS version is 1.0 Build 227. Not sure if that is current.

Hi @Guy_Taylor ,

Are you still able to access the Nucleus Web UI? Can you please share a screenshot of what you see there if so?


Here is the screenshot:

Hi @Guy_Taylor ,

That DNS of has been known to be unreliable and has caused issues with other Roon systems, can you try to change your router or Nucleus’ DNS to Cloudflare DNS, Quad9 or Google DNS and then try an Operating System Reinstall on the Web Interface?

Let me try the OS reinstall first. I’ve been running it as is for a couple of years and never had this issue before.

OS reinstall worked.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.