Roon 2.0 hangs and does not load on Mac

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Welcome to the community, @chris_collins.

I think you may have posted before completing the #support template. Completing the template will assist those helping you. You can edit your original post by clicking on the pencil icon at the bottom-right of your post.

1 Like

Running a Macbok Pro M1 Max 64Gb.

Installed upgrade to Roon 2.0 and now Roon hangs either at log in or at clicking the Roon button.

I have cleaned out all Roon backups, reinstalled Roon twice, run the code in terminal and ran with Fire wall on and off and VPN on and Off and it just hangs.

The previous version 1.8 worked fine but this version does not boot up.

I had that problem with Roon 2.0 on my Windows 10 laptop. I finally had to totally delete Roon from the laptop and then installed from the Roon Labs download page.

Hi thanks - I have completely deleted Roon from the computer and rebooted but still get the same problem - the older version worked fine but I have deleted that version now. I have downloaded a fresh version and it still hangs

Still not resolved - I have a life time subscription to Roon and cannot use it - useless support from Roon - I have even flattened the hard drive and reinstalled

Hi @chris_collins,

Thank you for your patience and I’m sorry for the long delay in responding. We’d be more than happy to assist and restore Roon to functionality as soon as possible.

I recommend first taking the following steps to fully refresh the database. This is far more thorough than an uninstall and may resolve the issue, but will regardless stabilize conditions as we troubleshoot:

  • Create a Backup of your current database if you don’t have a recent automated backup
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

If that doesn’t change or resolve symptoms, please respond here with the following information:

  • What’s your Mac OS version?
  • Our request for automated diagnostics from this Roon Core instance keeps failing, possibly because the device is offline or Roon is unable to reach our servers due to the startup hang. There should still be logging available on this Roon Core, however, and it would greatly expedite our investigation if tech support could see it. At your convenience, can you please use the directions found here and send over a set of logs to our File Uploader?