Roon 2.0 keeps crashing on macOS

Roon Core Machine

MacBook Pro Intel i5 running mcOS 12.6

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Roon 1.8 was working beautifully but I decided to upgrade to 2.0. It took me forever to install Roon 2.0 on my MacBook Pro because it kept crashing during the install. It finally uploaded all of my music files but now it crashes after less than 30 sec.

Repeatedly. I have rebooted my laptop, zapped PRAM, and freed up RAM but still keeps crashing.

Please help. It is currently unlistenable and I have gone back to Audirvana until this is fixed. The Roon interface is so much better and I love the linkage with Tidal.

Hi @MICHAEL_LEVIS,

Thank you for your patience in awaiting a response. It sounds to me like there was corruption happening from the very first install of 2.0. Here’s what I think might help. This is essentially getting “medieval” on the problem. Please test that things are working on the fresh instance of Roon prior to restoring your backup. This process will give us a clean slate to test against.

Thanks,
Wes

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Thanks for your reply. I followed your instructions, reinstalled Roon, but the problem persists. It keeps either crashing or just gives me a spinning beachball such that I have to “force quit” the app. Any other ideas?

Hi @MICHAEL_LEVIS,

I’m sorry to hear your issues have persisted.

I would like to confirm that you did indeed rename these folders.

After renaming them, did you successfully get into Roon? Was it the import of your databases that seemed to break it again?

Other things that might need to be looked at are AV, firewalls, or filters in System Preferences > Network. You might try disabling these too.

A fresh install after having renamed folders should work and only one of the aforementioned security features could stop it.

Please take a look at these things, disable them, and test by trying again.

Thanks,
Wes

1 Like

There are no AV issues, filters or firewalls. Nothing has changed in my OS and setup since I switched from 1.8 to 2.0. 1.8 was running beautifully. I would like to reinstall 1.8 and forget about 2.0. Can you tell me how to do that?

Hi @MICHAEL_LEVIS,

I can assist with that for sure.

To be clear, did you ever have 2.0 working with your existing databases? I ask that because backward compatibility isn’t there for 2.0 databases moving to 1.8 Legacy.

If you never imported your DBs into 2.0, you should be able to do this and ignore the backup part since it’s not possible for you.

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from my link here to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

I hate it that you’re having to revert to an older version but would also like to get you back to the music.

Let me know how things go please!

Wes

The furthest I reached wıth 2.0 was, after multiple crashes and relaunches, it appeared that all my music appeared as usual. But then the music wouldn’t play. Whenever I tried to launch a song the app either quit or I got a spinning beachball. So given what you have said, I’m not sure how to proceed. Could I not just delete anything whatsoever to do with Roon on my hard drive and start afresh as though I was a completely new user?

I had a very similar situation when I upgraded to 2.0 on my Mac Mini M1, crashes every few minutes whether being used or not. I run the core on a headless Mac mini, so my solution may not work for you or even be suitable for your situation. I downgraded to 1.8 did a full backup and then deleted everything Roon from the Mac not forgetting those hidden in the Library folder including RAAT Server. I then installed Roon server rather than the full fat version, you can easily restore and setup from a Remote. Since then Roon has run like silk. May be worth a try.

2 Likes

Hello, just wondering if you can help as per my message below? Can I just delete everything Roon on my HD and start afresh with 1.8?

Hi @MICHAEL_LEVIS,

I listed the steps for wiping Roon folders etc and the links necessary to re-install. Can you confirm receipt? It should be 3 posts up from your last one.

Thanks,
Wes