Roon 2.0 Server not compatible with my ROCK on NUC10 i7 [resolved: was being blocked by synology router]

ok, let’s try some simple stuff:

  1. reboot it
  2. go to web ui and and hit reinstall
  3. post screenshot of your web ui

current screen grab:

can i see the “ip address” part?

that’s all internal lan stuff, so none of it exposes public info

ok, my guess is it’s all or something like that… are gateway and DNS server the same value?

yes they are the same value

my guess is that your router’s dns is freaking out… you can get your router to give better DNS to your DHCP hosts, or you can just reboot and maybe that’ll kick it enough to work

Exciting! except I am not sure how to change the DNS settings to do better. I have rebooted the ROCK many times… or do you mean reboot the router?

2 days ago someting was working, since we saw your ROCK machine then…

try rebooting both again? first the router, then the ROCK once the router is back.

let’s confirm that’s the issue before we walk down that road… it could be easy or it could be annoying…

OK I will do this now… bear with me if you can, it may take a few minutes to complete.

Sure… I’m here. I just closed out a bunch of these update issues… you are the last one I have left :slight_smile:

1 Like

Try a public DNS, like in the web gui down right

that requires setting static IP… i should fix that in Roon OS so you can override DNS without overriding DHCP

Yup. And a warning popup maybe, control in Settings or so. Server not resolving DNS.

@danny OK both rebooted and I still get the same address for Gateway and DNS server. The IP address is unique

oh boy, still no response from your ROCK machine at all

try the reinstall button?

if that doesnt work, make note of your IP settings and let’s switch to static ip, filling in everything the same, except your DNS which should be

worthy of note, your mac and synology are contacting us just fine

reinstall shows the same info. I have a synology router and synology NAS. Are you referring to the router contacting you or the NAS?

the NAS.

… but your ROCK just pinged and updated to 2.0!

try it out :slight_smile:

did you do anything other than the reboots and the reinstall button?

@danny I got it up and running! For some reason my Synology router had the internet blocked for the rock.

1 Like

it’s hard for Roon to work if your router is blocking it :slight_smile:

anyway… glad you found the cause!

1 Like

super happy now! Thanks for holding my hand through this. I still don’t know when or how I blocked the internet to the ROCK but I guess it was sometime around the update because 1.8 was working fine.

You can close this thread if you feel all is tidied up here.