Roon 2 (build 1223) cannot find BluOS on NAD M12 DAC PREAMP

Roon Core Machine

MacBook Pro M1 Max 2 TB SSD 32GB RAM
macOS Ventura 13.2.1

Networking Gear & Setup Details

Connected Audio Devices

BluOS NAD M12 DAC/Preamp

Number of Tracks in Library

Description of Issue

My setup has been working perfectly for several years yet since the Roon upgrade yesterday the Core has lost the BluOS NAD M12 DAC/Preamp zone.

I have tried repotting everything, disconnecting ethernet and reconnecting but still doesn’t appear?

Please help - this is crucial for me to play high definition music

Possibly related?

Is M12 usable through the BluOS Controller app?

Have you tried resetting the BluOS MDC module?

Is the M12 not visible at all in Roon, or is there some unidentified “MDC” device in the Roon Ready list that can not be enabled?

I reset the BluOS module. The Roon capability is no longer present. I can play using Apple AirPlay only.

Looks like I’ll have to get hold of BluOS.

Trying this forum was an act of optimism as I have never received any help on the Roon community before. Don’t know why I thought it would be any different this time.

Looks like a BluOS problem then (there WAS a BluOS update very recently). Not that their support were any better; I got far more useful information here than from Bluesound when I had an issue.

I do not think the “Roon Ready” option shows up in BluOS unless it communicates with Roon first, and that is obviously not happening. If you had answered the questions above we’d at least have something to go on.

For what it’s worth, my 4 Bluesound devices work flawlessly, with Roon. One NAD device with MDC card I tried was giving me problems, and that’s how I found that you need to reset the MDC card to factory settings from the device front panel (although unplugging for a few hours worked as well) and then first reconfigure it with the BluOS app) before it can be idenbtified by Roon.

1 Like

The the NAD M12 is visible on the BluOS App but can’t play music as it’s all in Roon.

I tried resetting the module to o factory defaults but on selecting YES on the M12 screen nothing happened at all - it didn’t do anything at all.

For some reason I can play though Apple AirPlay on Roon to the preamp but the Roon Ready zone is not listed.

Playing music from Tidal through the BluOS App and works fine.

So it is the Roon Ready feature that’s not working.

As Mentioned resetting the BluOS module seemed to do nothing

I don’t have the NAD anymore, but I think there were two entries in the menu ,one rebooting the card, and one completely resetting it, to the point that you would need to reconfigure it in BluOS Controller. You’d need to do the latter. If that doesn’t help, or if it doesn’t actually reset, even more likely that this is a Bluesound issue. If you use the “Send Support Request” option in the BluOS app, they usually reply. Eventually.

Many thanks. Appreciated

You’re welcome.

FWIW, when you send a support request to Bluesound, especially from a computer, you get the complete device log attached to it that you can peruse. Depending on how technically inclined you are, you could read it and maybe see if something obvious jumps out…

Just for interest sake. Bluesound responded first thing on Monday morning. As the BluOS module is available to everything other than Roon they believe the Roon update last week has broken something. They have a point - the BluOS App on my iPhone finds the M12 and I can stream music from Tidal through this App. Airplay can be used by any of my devices that are able to use AirPlay. The Bluetooth connection on the BluOS module can be accessed by everything as well. So it is only the Roon Core that cannot find the M12 audio zone.

Bluesound responded immediately and yet I’ve heard nothing at all from Roon other than an email stating they will not refund lifetime subscriptions even though I only did this for months ago. They went to great pains to tell me that they warned me several times about this. And yet nothing from them whatsoever about the problem. I’d put money on it that they’ll provide no assistance at all and will claim Bluesound are the problem.

So much for service to a customer who has paid a lot of money (in South African Rand it’s quite a bit) to them.

Well, again, for what it’s worth, I have 4 Bluesound devices (2 Flexes, a Node, and a Powernode) and all of those are working fine after the update (both Roon, and BluOS). A NAD device with BluOS card on the other hand, was problematic from the start.

Of course, Bluesound will point a finger at Roon, and Roon will point a finger at Bluesound, Of course Lennbrook is a much larger company and has more resources to run support (not that replies I got from them were particularly useful), and Roon might respond… eventually.

In the meanwhile, if you go to Roon’s Settings/Audio page, do you see something similar to this?

If it is something like that, that’s a known problem in BluOS, they might even fix it one day.
If the device does not show up at all then there’s some other problem.

Speaking of which… you said that Airplay from other devices works. Does your M12 show up in Roon at least as an AirPlay device (Settings/Audio/Other network devices)? If you can’t see it as AirPlay either, I would suspect some network issues.

If you can get the IP of your M12 (from BluOS controller, for example), can you ping it from your core computer?

Thanks again. Yes the first thing I checked was the audio zones in Roon to see if the M12 had somehow been disabled but it is not there.

Roon does find M12 Airplay and I am able to stream from Roon to the M12 using this zone.

The M12 shows up on my router as a device connected with Ethernet cable and I’m able to pin to IP address from the Macbook I use as the Roon Core.

You’re absolutely correct - they’re simply going to point fingers at each other. This is very typical in the IT world in which I work and for all I know they could both end up blaming Mac or Asus as the problem.

I’m not optimistic my problem will be resolved so I may just stop trying to get a response from Roon as I’ll be wasting my time

Once again thanks for you taking the time to respond and make suggestions. It’s appreciated

Hmm, interesting, does not look like there are any network issues then.

It would be good if some official support actually replied here, they can at least pull logs and see what happens.

They usually do recommend trying to recreate RAAT Server (shut down Roon, rename original folder,restart Roon and have it completely redo device discovery) but that always looks like a rather radical approach.

Being in IT, I would definitely go digging through server logs. Search them for M12’s IP address and see if anything interesting comes up…

And just skates around the real issues which is why is there discovery protocol and db so flakey that it requires such steps. Fix the problem occurring in the first place.

That would be ideal. I am sure they’d want to, but knowing the software development process from the inside (it’s very much like making sausage), but in practice it might need significantly more resources than Roon has to do it “right now.”

I tried closing Roon, renaming the RaatServer and restarting. Unfortunately didn’t work.

I’m beginning to think that as no one else’s has this problem and Roon themselves aren’t responding they really don’t think this is a Roon problem.

In South Africa we have rolling blackouts every day for many months now. I always ensure my equipment is switched off (actually Standby on the Nad amps) before our electricity is cut (they at least warn us about the times). I’m beginning to wonder if the on and off electricity has somehow caused some sort of damage to the BluOS module that may have damaged or caused corruption to the device. This doesn’t explain everything else working including Roon using Airplay but perhaps there is corruption of the firmware that has affected the Roon compatibility.

I’m clutching at straws as I’ve tried most things - in fact even restoring a backup of my MacBook from 2 weeks ago when Roon as working and this didn’t help.

I can’t think of any other cause other than some sort of damage to the BluOS module from these blackouts several times a day.

Thank you for all this suggestions.

You’re welcome! Sorry it still doesn’t work (and @support really should have piped in by now…)

Honestly, Roon should have said something about it by now although with what… 4 people working support I am sure they are not twiddling their thumbs) but it does look like a problem with the MDC card.

For one thing, when the unit is in standby, it is still connected to mains (and whatever spikes are there due to blackouts can’t be good for it) – MDC card is powered up enough that when it gets play request, be it from BluOS or Roon it can wake p the rest of the unit and start playing – so something could have gotten fried.

For another, gathering together all the pieces I gleaned from Roon’s and Bluesound’s support (which replies much faster, but generally doesn’t offer anything other than “have you tried rebooting?” and “are you on latest firmware?”) as well as some inside contacts, MDC card needs to do a very specific song and dance with the chassis before it starts reporting itself as something Roon recognizes. And that process can be helped (or hurt, I guess) by disconnecting power for a while.

Would still be nice to have Roon pull the logs and see if the M12 is even advertising itself as a proper Roon-ready device…

Hello @anon8060941 Hi @Boris_Molodyi Just had an idea have you turned the switch on rear off, pulled the mains cord out, turn the rear switch back on and leave it for a while to discharge the capacitors completely? Then switch back to off, plug mains cable back in. I can’t remember specifically how I had my M33 jammed up when I first got it but that’s how I got it back on track. Probably a long shot but just a thought. FYI at the home where M33 lives we have a lot of grid work as well so I use a UPS now.

Best luck getting her going again

Thanks Rob but with the rolling blackouts in this country where we have no electricity 3 times per day for 2.5 to 4 hours at a time I’m sure this happens anyway. But I do appreciate your input and suggestion. It’s a pity that Roon have chosen to ignore this even though it may have been the blackouts every day damaging the BluOS module I hoped their service would be adequate if not immediate. Seems life time membership was a poor choice on my part. No refunds to cancel this subscription so there’s no need for them to respond. They’ve got their money.

By the way are you happy with the M33 - it seems like a very good “all in one” solution?