Roon AGAIN Quit Seeing Apple TV 4

Mac Mini late 2012 2.5 GHz intel core i5 running OSX El Capitan 10.11.1

Roon version 1.5 build 334

Apple TV4 OS 11.4.1

Set to allow airplay for anyone on network, password on.

Roon/Apple TV interface has been reaaaaallllly buggy lately, but after dropping tidal, even though tidal password correct, tried restarting roon, everything apple tv / airplay related gone. can’t even see the zone

Tried turning everything off, turned back on router followed by apple tv followed by mac mini. same results, can’t see apple tv as a networked zone

1 Like

Hey @david_burnside — Thanks for sharing your report with us. We appreciate the feedback!

May I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

  • Are you still unable to login to TIDAL? Are you receiving any errors? Are you able to play to TIDAL from this device outside of Roon using the app or web player?
  • Are other, non-Airplay devices playing okay? If so, how are these devices connected? Any difference in the connection between them and the Airplay devices?


DDylan, thanks for the response. To answer your questions, I can now login to Tidal in Roon. Unfortunately, it appears to me that Roon is only communicating with the gozinta side of my network. I can’t see the Apple TV on the audio settings under network devices, nor can any of our Roon apps find the core anymore.

The only non AirPlay device I have is a built in dac on a Parasound P5 preamp. It’s connected via usb and playing fine. The only way I can control Roon is through the Mac mini that has the core.

I think I may have screwed something up. When Roon quit communication with tidal (which happens far too often, btw), and I restarted the mini running the core, I ignored a message about raat. I can’t find anywhere to turn raat on now. I don’t know if that has anything to do with accessing AirPlay though, but it certainly seems worth mentioning.

FWIW, AirPlay is otherwise functional. I’m mirroring tidal from this iPad right now. The tidal app on Apple TV also works fine, but lacks artist radio so we prefer to mirror.

Lastly, here are our google WiFi specs, pulled straight from the phone app. If anything is missing let me know and I’ll try to dig it up.

Google Wifi tech specs
AC1200 2x2 Wave 2 Wifi
Expandable mesh Wifi
Simultaneous dual-band Wifi (2.4GHz / 5GHz) supporting IEEE 802.11a/b/g/n/ac
TX Beamforming
Bluetooth® Smart Ready
2 Gigabit Ethernet ports per Wifi point
WAN and LAN on primary Wifi point; both act as LAN ports on additional Wifi points
Color and Material
White, lightweight, durable plastic
Automatic security updates
Infineon SLB 9615 trusted platform module
4GB eMMC flash
Quad-core ARM CPU, each core up to 710 MHz
15W power adapter
~9W consumed
Dimensions and Weight
Diameter: 4.17 in (106.12 mm)
Height: 2.70 in (68.75 mm)
12 oz (340 g)

Kind regards,

Thanks for the details, @david_burnside!

It sounds like there may be some networking difficulties at play here. How is your Roon Core connected to the network? Ethernet or WiFi?

An app like Fingwill scan your network for devices it can see. If you use Fing or a similar app, do you see the Core machine and all networked endpoints?


Roon core is connected via WiFi. The google WiFi app can see what is connected. Roon is getting tidal and the mini is connected to our network in every other way. I can browse the web for instance. What specifically should I look for to see what network difficulties Roon is having?

Hey @david_burnside,

Can you try connecting the Core machine via Ethernet to your router and see if there is any change in behavior?Knowing whether or not the same behavior occurs will be a great data point for where this issue may be stemming from.


I finged my network I can see the mini. I don’t know if there’s anything I should look for with Fing to see Roon in particular. I won’t be able to get to hooking the mini directly to the router for a few weeks. I’m going away for two weeks this weekend.

Hey @david_burnside,

No rush at all here, David. I definitely think that this will be the best next step here in troubleshooting this issue. When you return please give this a try and let me know how it goes. I hope you have a great trip!


What about Fing? I have it now at your suggestion, which came before the suggestion about Ethernet. What should I look for with fing?

Hey @david_burnside,

Fing will show any devices that are on the network that your device is connected to. Are you able to see both the Roon Core machine and the Apple TV?



I can see both the Roon core machine and the Apple TV on Fing.

Kind Regards,

Thanks for confirming, @david_burnside.

That’s definitely good to know. Since they’re both seen on the network it may very well be an issue with the WiFi connection between the Core machine and the Apple TV. Having the Core machine connected via Ethernet will definitely give us a better idea of where the issue is stemming from.


Thanks. Don’t forget none of our Roon apps on iDevices can see the Roon core anymore either. I’m wondering about the RAAT. I think I might have screwed something up ignoring that message.

Hey @david_burnside,

I definitely think a wired connection will help, but if you’re still seeing the issue with a wired connection, here’s what I’d try next:

  • Before anything, please create a backup of your current Roon database.

  • Once you’ve created the back up of your Roon database please close all active instances of the application and reboot the machine hosting your Roon core.

  • When the machine hosting your core is powered back up I would like you to please test with a new RAATServer folder in place.

    • Your “RAATServer” folder will be in the same directory as your Roon database
    • Rename the entire RAATServer folder to RAATServer_old
  • Once you have renamed your “RAATServer” folder to “RAATServer_Old”, please relaunch the application, and confirm if you are still experiencing the issue.