Roon always stop playing music after 30 minutes

Hi all,

Recently I have setup a new computer (i7-10700, 64GB ram, 250GB NvMe ssd). OS is AudioLinux with HQP embedded. The music path is NAS -> Roon rock (intel nuc) -> HQP -> NAA (raspberry pi4) -> R2R DAC.Initially HQP embedded version is 4.20.1. Roon always stop playing music after 30 minutes (I have buy license, not license issue). I have to go to HQP config page and click apply. It can force HQP reconnect to NAA and then play music again.
It is very annoying issue. Piero remotely checked my HQP computer but nothing found. How ca I solve this problem?


I install and enable Roon server in same server with HQP embedded. But it still stop playing music after 30 minutes

HQPlayer is in evaluation mode and stops playing after 30 minutes. You need to buy a license and properly upload that license to the installed HQPlayer. Note the “upload” part of that sentence.

Note that you can verify if the license is properly installed by going to the “About” page in the web interface.

Thanks for you reply!

However, I bought the license and installed properly but music still stop playing after 30 minutes.

Hi @Eric_Law,

Just to confirm, if you remove HQP from the equation does everything work okay?

Can you share a screenshot of the signal path?

Post a screen shot of your HQPlayer Embedded “About” screen…

HQP license

Yes, before using HQP, my music path is : NAS -> Intel NUC (Roon Rock) -> Switch -> RoPieee -> DAC. It never stop playing music for several days, very good.

The new path is NAS -> Intel NUC (Roon Rock) -> Switch -> i7-10700 (HQP) -> NAA -> DAC. It always stop playing music after 30 minutes.

Piero@AudioLinux told me Roon and HQP on same computer may solve the problem, so my latest music path is NAS -> Switch -> i7-10700 (Roon and HQP) -> NAA -> DAC. No luck, still stop playing music after 30 minutes.

The HQP log shows:
+ 2021/01/19 01:38:27 NAA output network engine started at: 384000
# 2021/01/19 02:08:41 clStreamReaderHTTP::Execute(): clStreamReaderHTTP::Execute(): read timeout
** 2021/01/19 02:08:46 End of track**
& 2021/01/19 02:08:46 Next
** 2021/01/19 02:08:46 Idle request**

It’s time to get @jussi_laako involved…

Do you have the sleep timer set in Roon ?

It sounds like you have to upload the license again.
I had the same problem of it stopping after 30 minutes in hq player embedded…drove me crazy until figured out that the key license hadn’t been uploaded.
Once I found the key license file on my computer and uploaded it…no problems.

His key is uploaded as under license the name is shown not trial

Could you tell where this setting in Roon?

Oh, it really a good news! Big thanks of you experience!

Right…I see that now.

Click the speaker icon in Roon.Then you will see a moon click on that.Have you tried Roon by itself or HQPlayer to see which one is giving you the issue

I have checked the settings but sleep timer not enabled.

Uploaded license again but nothing change :frowning:

Try Roon and HQPlayer separately so you can at least tell which one is causing the problem.