Roon and RAATServer processes stay in Task Manager after closing Roon [Resolved]

When I close Roon + Core on my Windows 10/Creator’s Update machine, the RAATServer and Roon processes stay in Task Manager for a few to several minutes until I either reboot or they finish whatever they are doing. I cannot kill the processes manually in Task Manager – the only option is to reboot or wait.

That means that if I need to close/re-open Roon + Core on my Windows box, it’s a multi-minute evolution and may be an indication that deeper stuff lies behind whatever behavior prompted me to close Roon in the first place.

Is this normal or not, please?

Hi @Jeff_Bellune ---- Thank you for the report and sharing this observation with us. The feedback is appreciated.

To answer you question, “No”, this is not behavior we’d expect to be seeing. Can you confirm for me if you are making use of any antivirus applications on this Win10 machine?


Hi @Eric,

I am using Webroot.

(Sidebar: Ever since the big kerfuffle worldwide about ransomware, Webroot has been really aggressive about letting new or updated known software access the Internet. After 2 minutes when a program is launched and subsequently challenged by Webroot, it will default to allowing the connection, but the user can override the timer and future alerts by forcing an “Allow Always” operation. Roon and RAATServer have Allow Always trust normally and as soon as possible after an update. Allow Always is in effect for the latest version of webroot, and my issue is after exit, not during launch.)

Do you want logs or other system info yet?

1 Like

Hi @Jeff_Bellune ---- Thank you for touching base and verifying that information for me.

Moving forward, may I kindly ask you to please verify/provide the following:

  1. If you were to (temporarily of course), disable Webroot do you make the same observation in the task manager?

  2. Can you please provide the specs of the Win10 device that is hosting your core, being sure to provide what build number you are currently running?

  3. How big is your music collection, based on number of tracks?

  4. While this may seem a bit elementary :innocent:, can you please verify how you are closing the application once you are done with your listening session(s)?


Hi @Eric,

  1. Yes, the unkillable tasks in Task Manager remain with A/V disabled.

  1. Just short of 8,000 tracks.

  2. I close Roon by clicking the red X in the top right corner of the window.

Please let me know if you need more info.


Bump. Any ideas on this? It’s becoming a real pain.

When these Roon processes continue to appear in Task Manager, do you see any ongoing CPU use, I/O activity, etc?

You might try investigating with some tools from SysInternals (part of Microsoft). Download the suite. I’d then start with, say, DiskMon, Disk Usage, Handle, Process Explorer, Process Monitor; other possibilities are Sysmon, TCPVIew and WinObj.

No. The memory allocated stays allocated, and the CPU usage stays at zero. At least until the process quits on its own, which sometimes does happen, when the CPU usage goes to 1%.

If there’s no CPU use and no I/O activity, the most likely explanation is that a thread in the process is waiting for something (and it could be a DLL waiting; Process Explorer might be of use here). The Roon development people may have some ideas.

Hi @Jeff_Bellune ---- Thank you for the follow up and providing the requested information, my apologies for the slow response here.

Moving forward, I would like to gather the following from you for our tech team evaluate:

  1. Logs.
  • Very important - please reproduce the behavior being reported and note the time when the observation is made.

  • Once the issue has been replicate, please follow the instructions found here and upload us a set of logs.

  1. Create a Dump file.
  • While Roon appears to still be active in your task manager…

  • Click the Processes tab, and locate Roon.

  • Right-click on it and then click Create Dump File.

  • After the file is created, go to the following folder specified in the Dumping Process dialog in Windows Explorer to access the dump (.dmp) file.

  • Upload along with the logs.


HI @Eric,

I PM’d you. The requested files have been uploaded.

Sorry it took me so long to get back to you. Obviously I missed the email notification!


Hi @Jeff_Bellune ---- Thank you for following up with me and providing the requested materials.

At first glance it looks like I have everything I need but if additionally materials are needed I will be sure to let you know. We greatly appreciate your patience while our team conducts their evaluation. Once I have some feedback I will be sure to update this thread promptly.


1 Like

Hi @Jeff_Bellune ----- Thank you for your patience while our techs have been looking into this issue you’ve reported to us. It is very appreciated!

Moving forward, the team is having a hard time pinpointing the cause of this behavior you’re experiencing and right now the working theory is that this could still be linked to the “Webroot” application.

While I understand that you’ve tested with it disabled, the team suggests uninstalling it completely and confirming if you make the same observations with process still being active in the task manager.


Hi @Eric

I’ll try uninstalling Webroot to see if that makes any difference. I’ll report back, but it may not be until this weekend or Monday at the latest.


Hi @Eric,

I uninstalled webroot completely (no easy task), rebooted, and the issue remains. If anything, it’s gotten worse. I tried to add Ten Years After’s A Space In Time from TIDAL into my library, and the last 2 songs came in as duplicates: each track appeared twice as part of a work with the same name. Re-Analyzing and Re-Identifying and Re-Scanning had no effect. When I closed Roon in hopes that restarting it would remove the duplicate tracks + work display, the Roon process took even longer to disappear from Task Manager than it usually does.

The time of closing Roon was apporximately 1640. I will PM you with the logs from this session. I have not restarted Roon since the TYA incident.


Hi @Jeff_Bellune ---- Thank you for touching base with me and giving the proposed test a shot, I am sorry to hear that it did not yield a more positive result.

Confirming that I have received your PM :sunglasses:

I considered performing a full reset of Windows 10 to see if I could get this issue to go away. However, my schedule didn’t allow me the 3-4 days of down time I would need to fully reinstall all my programs and plugins, so I didn’t reset Windows.

As of Roon version 1.3 (Build 262), I no longer have this issue. So whether it was recent Windows updates, recent Roon updates, or both, the issue is solved for me.

This fits in well with my personal philosophy of: “if you ignore a problem long enough, it will go away”. :slight_smile:


1 Like