Roon and Tidal play - but not together[Solved]

I am probably being stupid but…

My setup:
Windows10 (64-bit) Not using remotes currently all run from desktop
Roon 1.2 build 142 (64-bit)
Tidal (W. 1.14.5-9)(NP. 2.3.1)

Roon works fine from its own window. Using this through a networked Transporter to a Meridian 861
Tidal does not work in Roon (although shows up as logged in). Tracks show a spinning wheel for 2 seconds and disappear.
Tidal does not work in its own window (spinning wheel forever)
Tidal DOES work via

Getting very frustrated…


[quote=“Liam_Scanlan, post:1, topic:10840”]
Tidal does not work in its own window (spinning wheel forever)
[/quote]Is that the Tidal app that is not working?

Thing to try:
Reboot PC and Router.
Try the Tidal app again … if ok
Try Roon playing a Tidal track.
If not good, log Roon out of Tidal, stop Roon, restart Roon and log back in to Tidal.

Are you able to run a broadband speed test from that PC?
Is that PC hardwired or using WiFi to connect to the LAN?

Hi Carl,

Thanks for the rapid response

Router rebooted
PC rebooted
Tidal (via in Chrome works)
Tidal via stand-alone app just spins waiting
stopped Tidal
stopped Roon
Restart Roon
Tidal (is automatically logged in)
Not working… (sigh)

Ping 35 ms
Download speed 150.14 Mb/s
Upload speed 15.47 Mb/s

Any more ideas? Complete reinstall?

Apologies - forgot to add:

Network is hard-wired 1G

Also - I seem not to be able to ‘log out’ of Tidal in Roon - appears to start automatically when Roon starts! (hmmm!)


With both Roon and the Tidal app having a problems playing Tidal tracks I’m inclined to think it is environment issue rather than Roon.

You could try, as a test, temporarily switching off your firewall.

As you said a reinstall might also help … watch out for and authorise any firewall routing requests. I would try the Tidal app first and that get working followed by Roon.

Re-installed - both Tidal and Roon - no difference
Disabled Firewall - no difference

I discovered that Tidal videos play flawlessly in 1080p and sound good too! (On the stand alone window). Music tracks do NOT play in the same environment.- just get a spinning ‘wait’ symbol.
In Roon - music tracks just ‘flow through’ (i.e. each track name appears and goes away after 2 seconds or thereabouts) with no sound

I’m stumped!

Any ideas?

I’ve see this before in an earlier alpha build, it was related to the audio endpoint. I’m leaving a flag for @Mike to follow up with you.

What audio device are you using? And if you’re able try swapping it out for something else.

Thanks for this Carl.
Audio device couldn’t be simpler - onboard sound (speakers) or sent to a networked transporter.
Hmmm - would it work better with s/pdif? - I’ll try that into the M861v4

The issue I saw was to the system output … networked devices where fine.
It think there’s more going on here now which will need @mike or @vova to collect some Roon log file info from you.

Hey @Liam_Scanlan – are there any web proxy settings involved? Can you give us some more details about your network, and the hardware involved? Where are you located?

Have you talked with TIDAL support about the issues with their desktop app? It sounds like something is blocking your connection with their servers, so as @Carl said, I would suspect something environmental here.

Hi Mike,
Many thanks for responding. I too believe this may be an environment issue - but I am at a loss as to how to resolve it. I am awaiting a response from Tidal support.
There are no proxys set up (I have checked during the connection to Tidal) Nothing strange there. Network shows standard settings (I think!). I have obfuscated physical address etc)
Windows10 (64-bit)
Roon 1.2 build 142 (64-bit)
Tidal (W. 1.14.5-9)(NP. 2.3.1)
Using Norton Security on every machine on network (and Malwarebytes(Free edition))
I have tried disabling the Firewall - no change
Ping 35 ms
Download speed 150.14 Mb/s
Upload speed 15.47 Mb/s

Connection-specific DNS Suffix:
Description: Intel® Ethernet Connection I217-V
Physical Address: xxxxxxxxxxxxxxx
DHCP Enabled: Yes
IPv4 Address:
IPv4 Subnet Mask:
Lease Obtained: 16 May 2016 23:33:12
Lease Expires: 19 May 2016 09:03:44
IPv4 Default Gateway:
IPv4 DHCP Server:
IPv4 DNS Server:
IPv4 WINS Server:
NetBIOS over Tcpip Enabled: Yes
Link-local IPv6 Address:xxxxxxxxxxxxxxxxxxxxxxx
IPv6 Default Gateway:
IPv6 DNS Server:

The hardware:
Gigabyte Z97 -D3H motherboard
Intel i7-4790
4.6GHz Pro
256GB SSD (160+GB free)
4GB secondary disc

On network:
Panasonic BD recorder
Oppo DVD player
Sky box
Virgin Tivo
Netgear Duo NAS (All services stopped/Unit switched off during testing)

Two other computers permanently connected (but off while testing)
Tried remote from another machine - exactly the same symptoms (Roon OK, Tidal not)

What confuses me most is that Tidal works for videos at 1080p flawlessly (and sound on video is OK) but not music. Nothing from Tidal inside Roon.
I appear to be logged in to Tidal within Roon (no messages to contrary)
Tidal can’t see RAAT server (transporter) from standalone or web interface (is this normal?)

Many thanks for your thoughts on this. I am getting quite close to giving up (particularly as it seems very difficult to contact Tidal support)

Best regards

Do you use proxy in Chrome ? Are you completely sure that all firewalls/antiviruses (including built-in windows firewall/defender) were disabled during the tests ?

No proxy in Chrome (confirmed - uses system settings - no proxy)
Windows Firewall/Defender turned off by Norton Security (I then turned off Norton’s smart firewall!)
I am not keen on operating without firewall/anti-intrusion/anti-virus as I have already been subject to quite a serious attack.

What really confuses me is that I get Tidal working fine on the web application (in Chrome) but not standalone app nor in Roon. Videos are OK in the standalone app (Roon = no support for video yet, I assume)

If all else fails I may set up a test machine just to run Roon/Tidal and to store music (need to order parts for that so it can’t be immediately tested).

Just tried the HIFI variant of Tidal - and it works perfectly…
However Meridian 861 shows 44K from the s/pdif out of the computer. The speakers shoow “MHR 96K” - I assume the 861 is upsampling. I have checked the set-up of the soundcard - runs OK with 44K,48K,88K, and 96K - I do not believe the 861 can handle 192K - but why is Tidal just showing up as 44K on the 861? - or is the 44K the max for album tracks - and lossless descriptor refers to the bitrate? Are there any tracks on Tidal at 96K? I may be missing not only the point - but the entire scenario! My apologies, but can anybody elucidate for me. Is there a better way to get the sound out of the computer and into the 861 digitally?

Hi Liam,

Tidal Hifi is limited to 44k/16bit output (cd quality). As well, the Meridian streaming protocol is limited to 96k/24bit.

So, it does look like you have it set up properly. You can tap or click on the little dot to the right of the currently playing song to see the Signal Path. It should show as lossless. Something like this.

Cheers, Greg

1 Like

Thanks so much for the verification. I really appreciate you taking the time to reply!

1 Like