1.8 freezing with one certain artist

Core Machine (Operating system/System info/Roon build number)

Core: Roon version 1.8 (build 756) stable running on ROCK Version 1.0 (build 227) stable
App: Roon version 1.8 (build 756) stable running on macOS Catalina Version 10.15.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Switched GigaBit Ethernet

Description Of Issue

I have a strange issue: I have the album “Purple Mountains” by artist “Purple Mountains” added from Tidal to my library. All was well, I could see the album page as well as the artist page. All of a sudden - I cannot remember doing something special - I cannot go to the artist page anymore. The Roon window is “frozen” - not even the Roon logo is pulsing anymore. gets unresponsive and has to be killed.

Here’s a screenshot of the album page:

And here’s a screenshot after clicking the artist name “Purple Mountains”:

The Roon logo is not pulsing, the MacOS mouse pointer is changing to the “BeachBall” and the application is not reacting anymore:

I can kill but on starting the app again, I have it again freezing. I already tried re-installing a fresh download of - but that did not help.

I also deleted the album from Tidal favourites and added it again - same problem.

Access via iPhone and iPad is working normal. Access via my MacBook is also working normal. Only my Desktop iMac is affected.

Any help is appreciated. Thank you very much.

Hi @Oliver_Stettner

Apologies for the trouble here! Can you navigate to your database location and change the Roon folder to Roon_Old? After doing so try reinstalling the app again from our website and let us know if that helps.


Hi Dylan,

thanks for your advice. I did the following:

  • I made a current Backup (“Backup now” in Settings/Backup)
  • Stopped “Roon Server Software” on the ROCK GUI webpage
  • Renamed the directory smb://rock/Data/RoonServer to smb://rock/Data/RoonServer_Old
  • Restarted “Roon Server Software” on the ROCK GUI webpage
  • Re-installed a fresh copy of on my iMac
  • Connected to a “new” Roon core
  • Waited for all my music to get imported (local and Tidal)
  • Tested - but unfortunately I have the same problem again.

For now I have switched back to my former RoonServer Directory in order to have all my bookmarks and tags available. But I kept the new RoonServer directory, so I can switch forth and back for testing issues f this helps you.

Thanks for your support so far. Do you have any other suggestions? As described: my other devices (MacBook, iPad, iPhone) do not have that problem - only my iMac.

Update: I think I fixed it :slight_smile:

With my original (old) ROCK database (smb://rock/Data/RoonServer) I quit on my iMac, renamed ~/Library/Roon on my iMac to ~/Library/Roon_old and restarted A new version of ~/Library/Roon got created. Now the problem is gone. :smiley:

I just had to configure some of my settings (Settings/General) and the order of my bookmarks - everything else seems to be fine.

I will keep my backups for some time and will observe if everything runs smoothly. If yes, I will set this support issue as solved.

All working fine - so I close this issue :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.