Roon app confused by 4K monitor on Windows 10

Roon Core Machine

OS: Windows 10 Pro 64-bit (10.0, Build 19043)
Machine Mfg: Lenovo
Model: 20QD001XUS
CPU: Intel(R) Core™ i7-8665U CPU @ 1.90GHz

Networking Gear & Setup Details

Router: BGW210 (supplied by AT&T)

Connected Audio Devices

Streamer/NAS: Bluesound Vault 2i
Endpoints: Bluesound Pulse Mini 2i (2)

Number of Tracks in Library

Approximately 15,000 tracks.

Description of Issue

Bug (has nothing to do with networking or audio!):
The Roon application insists upon running full-screen on my laptop computer. Under some circumstances it pops up a message box to warn that the screen is too small (resolution too low??). On my desktop, which runs the same version of Windows at 1920x1080x32, the Roon app has no complaints about the size of the display.

My laptop has a 4K display panel set to a resolution of 3840x2160x32. The application also has a bit of trouble actually managing the 4K display: Graphics resources are mostly displayed correctly, except for the cover image bitmap (see attached screenshot). But there is logic somewhere in the application to decide whether it must force full-screen, and that logic is mistaking the 4K resolution for a too-low resolution.

The issue is probably scaling. You have the scaling set so that the effective resolution is too low. Try setting it to 100% and see if it makes a difference.

You can set individual app scaling for roon. A long and detailed thread about Windows scaling here.

1 Like

The long thread is very helpful. Thank you!