Roon App crashing on startup. Windows & iOS

My roon app is crashing on startup. At first it was just on the iOS devices, and now on the Windows PC also. I see no errors or anything, it simply crashes after the initial loading logo.

I saw the tech support note suggesting to reinstall and reboot on Windows, which I did with no success.

I also tried uninstalling and reinstalling the iOS app on all apple devices, and verified iOS was the latest version. I’m running on a iPhone 14 pro and a latest gen iPad.

I have a 1.5 yr old Nucleus. Windows machine is Windows 10 Pro 19045.2728

I’ve tried power-cycling the Nucleus as well.

I’m stuck, since I can’t even get the app to come to any interactive screen, there is nothing I can do.

This sounds like your Nucleus is not on the latest Roon build but your remotes are, this has been happening of late unfortunately.
Can you navigate to your Nucleus via a web browser by entering its ip address?
From its ui you should be able to see its build, it needs to be 1223 (as a minimum, I think there is a new build out of 1232).
If it is not you can update the build right from the same web portal.

1 Like

Like @AceRimmer said. In detail:

Go to the admin web page of your Nucleus and check if it is up to date. Open your internet browser and try http://nucleus or if this does not work try http://nucleus.local. If this does not work either, use the IP address of the Nucleus instead of “nucleus” (which you should find in the admin web page of your router where the network devices are listed)

The Roon Server Software version should be Version 2.0 build 1232 production (as of today, or at least the previous 1223). If it is lower, you may be a victim of this recent quite frequent issue:

Current releases of control devices / remotes crash when the Core is not up do date. Maybe your Nucleus did not update for a while but your remotes probably have. (This has happened recently for some Nucleuses without user fault). If all your remotes crash then you can’t initiate the update from the remote but you can trigger the update by going to the admin web page and clicking the Reinstall button for the Operating System:

(From the Updating Nucleus help page)

This will also trigger the update of the Roon Server Software version. This is riskless and has helped in countless recent cases

I already alerted Roon to this and they are investigating a solution


Indeed that was the issue. Thanks for the assistance!

Another easy way to get to the web interface on iOS is to go to Settings->Roon and turn on reset app on startup. Then when the app starts before connecting to the nucleus there’s a link in the bottom right go to the web admin interface.

Thank you. That solved the problem.

1 Like

Interesting, thanks. So that’s in the iOS settings for the Roon app, right?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.